Overclock.net › Forums › Distributed Computing › Distributed Computing - General › Having issues when running 3 or more Cards
New Posts  All Forums:Forum Nav:

Having issues when running 3 or more Cards

post #1 of 8
Thread Starter 
Right now I have ASRock FM2A85X Extreme 6, running 3 GPUs on the x16 slots with powered risers. I can also replicate this on my other Mobo: Gigabyte GA-F2A85X-UP4. When I use 3 or more GPUs my hash rate suffers and it becomes uber sensitive to thread concurrency. Right now to get the 3 of them to run I have to use a TC of 16384. I know people run 6 GPUs on a mobo. How do they do it? If you're running 3 or more GPUs on a rig what are your settings? OS? Driver ver? SDK ver? CGMiner config? I even tried BAMT with similar results. Any insight on this? I have a 10 TC reward to who presents the information to solve my problem. I have 9 GPUs in total and its driving me CRAZY!

GPU: SAPPHIRE 21196-00-20GHD (Have 6 just trying to tackle 3 right now)

Mobo: ASRock FM2A85X Extreme 6

CPU: AMD A6-5400K APU 3.6Ghz

PSU1: OCZ 1000W ZX Series ZX1000 PSU2: Seasonic AX-850

I have tested each card individually and using a TC of 21712 I get ~660kh/s. Running 3 I get ~610-~630kh/s but it becomes super sensitive to TC and wll force GPUs off or cause a plethora of HW errors.

I have tried a lot of different things but run into the same dead end! Running Win 7 64bit using CGMiner it is set up properly hardware wise using powered risers and a dual mobo atx cable to put load on the 2nd PSU. I appreciate you reading thanks
post #2 of 8
I have noticed this too on my mining rigs. How much VRAM do you have and how much DRAM do you have? I've read that in order to mine scrypt well, you will need to start adding a lot of DRAM despite the low usage during mining. I cant mine scrypt on my rigs right now because they just dont have the ram to run TC high enough to keep them from getting HW errors... I am unfortunately only mining SHA256 now, until I buy more RAM. I have 8GB installed in one pc that has about 9GB of VRAM.
6600K
(12 items)
 
  
CPUMotherboardGraphicsRAM
i5-6600k 4.6GHz Gigabyte z170XP-SLi-CF Sapphire R9-280X Toxic Corsair DDR4 2133MHz @ 3,000MHz 
Hard DriveCoolingOSKeyboard
Intel 535 480GB SSD Noctua NH-D15 Windows 10 Pro 64bit Microsoft Natural 4000 
PowerCaseMouseMouse Pad
Corsair TX950 ThermalTake Armor Logitech G700 Ripper XXL 
  hide details  
Reply
6600K
(12 items)
 
  
CPUMotherboardGraphicsRAM
i5-6600k 4.6GHz Gigabyte z170XP-SLi-CF Sapphire R9-280X Toxic Corsair DDR4 2133MHz @ 3,000MHz 
Hard DriveCoolingOSKeyboard
Intel 535 480GB SSD Noctua NH-D15 Windows 10 Pro 64bit Microsoft Natural 4000 
PowerCaseMouseMouse Pad
Corsair TX950 ThermalTake Armor Logitech G700 Ripper XXL 
  hide details  
Reply
post #3 of 8
Try opening Command prompt as Admin and typing these commands one at a time.

setx GPU_MAX_ALLOC_PERCENT 100

setx GPU_USE_SYNC_OBJECTS 1
    
CPUMotherboardGraphicsGraphics
i7 3770k 5.2ghz  GIGABYTE G1 Assassin Sniper 3 7950 with Alphacool block 7950 w/ Alphacool Block 
GraphicsRAMHard DriveCooling
7950 w/ Alphacool block G.SKILL Trident X 2500mhz 2x4gb SanDisk Extreme 240gb sata III 6gbs x5 SwiftTech Apongee Drive II 
CoolingCoolingCoolingOS
Monsta 360 86mm thick rad X 4 MCP 35X Pump x2 400ML Frozen Q Fusion res x3 Windows 7 Ultimate 64 bit 
MonitorKeyboardPowerCase
CatLeap 2560x1440 + Acer hn274h bmiiid 120hz 3D Logitech G19 Corsair Ax1200 watts  Mountain Mods Ascension 
MouseAudio
Logitech M570 Pioneer SP-BS21 Bookshelf Loudspeakers + Lepai Amp 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
i7 3770k 5.2ghz  GIGABYTE G1 Assassin Sniper 3 7950 with Alphacool block 7950 w/ Alphacool Block 
GraphicsRAMHard DriveCooling
7950 w/ Alphacool block G.SKILL Trident X 2500mhz 2x4gb SanDisk Extreme 240gb sata III 6gbs x5 SwiftTech Apongee Drive II 
CoolingCoolingCoolingOS
Monsta 360 86mm thick rad X 4 MCP 35X Pump x2 400ML Frozen Q Fusion res x3 Windows 7 Ultimate 64 bit 
MonitorKeyboardPowerCase
CatLeap 2560x1440 + Acer hn274h bmiiid 120hz 3D Logitech G19 Corsair Ax1200 watts  Mountain Mods Ascension 
MouseAudio
Logitech M570 Pioneer SP-BS21 Bookshelf Loudspeakers + Lepai Amp 
  hide details  
Reply
post #4 of 8
Thread Starter 
This is a common misconception for mining scrpyt. It depends on the miner. When using Reaper it requires lots of DRAM because it copies VRAM into memory. Depending on card its usualy recommended to have ~1.5GB per GPU. When using CGMiner there is no such requirement and this is confirmed by the author of CGMiner.
post #5 of 8
Thread Starter 
Quote:
Originally Posted by Hokies83 View Post

Try opening Command prompt as Admin and typing these commands one at a time.

setx GPU_MAX_ALLOC_PERCENT 100

setx GPU_USE_SYNC_OBJECTS 1
Those variables are set already and have no problem setting Intensity to 20. Here's relevant parameters
Code:
-I 20 -w 256 --lookup-gap 2 --thread-concurrency 16384 -g 1
post #6 of 8
Really? Do you have a link to that? I have the same issues that you are having on the FM2board you listed..I sure would like to mine scrypt in CGminer again..


When you run CGminer with high TC, does it crash? or will the rate just plummet / hw errors?
6600K
(12 items)
 
  
CPUMotherboardGraphicsRAM
i5-6600k 4.6GHz Gigabyte z170XP-SLi-CF Sapphire R9-280X Toxic Corsair DDR4 2133MHz @ 3,000MHz 
Hard DriveCoolingOSKeyboard
Intel 535 480GB SSD Noctua NH-D15 Windows 10 Pro 64bit Microsoft Natural 4000 
PowerCaseMouseMouse Pad
Corsair TX950 ThermalTake Armor Logitech G700 Ripper XXL 
  hide details  
Reply
6600K
(12 items)
 
  
CPUMotherboardGraphicsRAM
i5-6600k 4.6GHz Gigabyte z170XP-SLi-CF Sapphire R9-280X Toxic Corsair DDR4 2133MHz @ 3,000MHz 
Hard DriveCoolingOSKeyboard
Intel 535 480GB SSD Noctua NH-D15 Windows 10 Pro 64bit Microsoft Natural 4000 
PowerCaseMouseMouse Pad
Corsair TX950 ThermalTake Armor Logitech G700 Ripper XXL 
  hide details  
Reply
post #7 of 8
Thread Starter 
Depending on TC the following I have seen -
1 / 3 of GPU will have Off state and if I try to enable the GPU CGMiner crashes,
GPU off + wonky hash rates and HW errors,
GPU Off + wonky hash rates + No HW errors
GPU Off + decent hashrate 605-630kh/s + no hw error
Above scenarios with all 3 GPUs on

If CGMiner crashes run cgminer.exe -T and see if that works. More often than not from what I've experienced its related to OpenCL when CGMiner can't run. I have a lot of batch scripts I wrote to help with testing different driver and OpenCL combinations. If you delete the OpenCL files you could install another version and see how that affects your miner.

I sincerely hope we could get this figured out. I want to write a guide because many of the things that could've gone wrong did and not enough centralized or concise information out there. Are we allowed to link to other forums? I know some informative threads that may be helpful.

[Edit]: Couple of things you can check which OpenCL version CGMiner is using by running cgminer.exe -list (I believe) if you have different versions (platforms) available to you this command will identify it and you're able to chose which platform to run. That command is --platform 0 (I believe)
Edited by CrazyMiata - 6/6/13 at 10:04pm
post #8 of 8
^^I tried -T and it started working. I wasn't able to change any other settings on the fly though. After I ran for a few minutes with -T, I was able to get an instance of CGminer working for each individual card which I could not do before. Not sure if that's related or not but yay. Hopefully we do get this down, with the BTC diff increase, nearly anything scrypt based is worth more to mine now.
6600K
(12 items)
 
  
CPUMotherboardGraphicsRAM
i5-6600k 4.6GHz Gigabyte z170XP-SLi-CF Sapphire R9-280X Toxic Corsair DDR4 2133MHz @ 3,000MHz 
Hard DriveCoolingOSKeyboard
Intel 535 480GB SSD Noctua NH-D15 Windows 10 Pro 64bit Microsoft Natural 4000 
PowerCaseMouseMouse Pad
Corsair TX950 ThermalTake Armor Logitech G700 Ripper XXL 
  hide details  
Reply
6600K
(12 items)
 
  
CPUMotherboardGraphicsRAM
i5-6600k 4.6GHz Gigabyte z170XP-SLi-CF Sapphire R9-280X Toxic Corsair DDR4 2133MHz @ 3,000MHz 
Hard DriveCoolingOSKeyboard
Intel 535 480GB SSD Noctua NH-D15 Windows 10 Pro 64bit Microsoft Natural 4000 
PowerCaseMouseMouse Pad
Corsair TX950 ThermalTake Armor Logitech G700 Ripper XXL 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Distributed Computing - General
Overclock.net › Forums › Distributed Computing › Distributed Computing - General › Having issues when running 3 or more Cards