post #1 of 1
Thread Starter 
OK so this is starting to really p*ss me off. I've tried everything and i can't seem to point out whether this is a faulty PSU destroying mobo's or just me being ignorant...

Specs:
Asus P8Z77-V LK
i5 3570k
8GB Corsair Vengeance RED
7950 Sapphire Vapor-X
Corsair AX860i
3x 1TB Mechanical drives (2 WD Greens, 1 Seagate)
1x SSD Samsung 840 PRO series

Old mobo/cpu/psu for testing purpose:
AMD Phenom X4
Corsair TX650
M4A785TD-V EVO


So here goes:

I've upgrade my PSU from Corsair TX650 to a Corsair AX860i, i didn't change anything else, just the PSU. The first thing that hits me when i boot up is the slower-than-usual POST bootup time (3 minute-ish) and after that i see:
"Error: Windows failed to start. A recent hardware or software change may be the cause in Windows Vista computer."

So i try a startup repair using my Windows CD and rebooted. That didn't work. So i switched my primary OS drive to a different SATA port, where my storage drive used to sit. Windows loaded up succesfully but this time i couldn't find the storage drive. Also my 3rd harddrive wasn't showing up either, this one wasn't detected even during the POST-process nor was it detected in BIOS.

I swap both drives back to their original positions and from that point clearly it looked like dead SATA ports to me. After a few minutes of testing, changing cables and swapping from port to port, each SATA port including the ones which used to "died" aswell. Either they are saying that my harddrive is missing BOOTMGR or i need to install a proper boot device. I tried my every harddrive on my friends computer and they seem to work without any problems whatsoever (i could view/use the files and i ran HDtune on each one of them).

Also i tried changing back to my old PSU, problem remains, going back to old MOBO, no difference. Booting up outside computer case, ye you guessed it: no difference. But i did connect the new PSU (which might be the biggest mistake ever) first before trying my old PSU when testing my old MOBO. Perhaps the 860i is the one causing all the problems, killing both MOBOS? Everything else seems to work well though (like the self-test button).
Edited by Demnok - 6/9/13 at 3:50pm