Overclock.net › Forums › AMD › AMD Motherboards › ASUS Crosshair Formula Z not detecting GPU
New Posts  All Forums:Forum Nav:

ASUS Crosshair Formula Z not detecting GPU

post #1 of 2
Thread Starter 
Hi.

I just received a new motherboard after my old one melted with the CPU (PSU failed). I've installed everything back and it works fine, with one exception. I also sent in the SSD and my GPU (a 5870) to the place where I bought it so they could check all components for damages, and they sent it back where it tested fine. The GPU apparently did a burn in test NP, but when I connect it to my new board, the motherboard doesn't recognize it at all. Nothing, nada, zip. The cooler fans starts spinning on the GPU, but no picture is present. I've tried it in multiple PCI slots, but nothing. I'm now using the PC with an old GT220 in the primary PCI slot, and that works fine, so it's definitely the GPU which is at fault.

Do you guys know of anything that can cause this (that doesn't mean the GPU is borked)? I've tried resetting the BIOS, upgraded the bios, installed drivers, nothing. The motherboard simpyl will not act as if there's anything plugged in. It has power from 2x6pins, and as mentioned, the cooler starts spinning, but there's no video out. The only thing that happens is that the "LED_BOOT" LED is permanently on (on the moterboard) and no video comes out of either of the ports on the card, or in any PCI slots.

I'm hoping this is an issue where the GPU isn't dead, as it was working when I sent it in, and apparently it was working when they tested it, but as soon as I plugged it in here, it didn't.

Any help is much appriciated.
post #2 of 2
Since it doesn't work in any slot while another card does, it sounds pretty dead to me. One last thing to try is put it in another computer and see if it works then. Otherwise, I think you'll need a new card.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD Motherboards
Overclock.net › Forums › AMD › AMD Motherboards › ASUS Crosshair Formula Z not detecting GPU