Overclock.net › Forums › Cooling › Water Cooling › Mcp 655 noise (not vibration)
New Posts  All Forums:Forum Nav:

Mcp 655 noise (not vibration)

post #1 of 3
Thread Starter 
Hello guys.

Lately i've been trying to complete my new loop with the so-called "quiet" Laing D5/Swiftech 655/ whatever, and...oh boy does this bugger whine Oo.

I've used the D5 in my old computer and it was pretty silent, while in the new one, it's the loudest part of my computer.


I could not get rid of the whining noise, whatever setting i put the pump on. On top of it, these units (tried 3 of those) seem to growl (litterally) at certain rotation speeds.

Even on the lowest setting, the noise is just annoying.


Could the lenght of my loop impact the pump rotation ? it seems that short loops/ low restriction loops tend to make your pump run faster.
My old rig had 3 rads (360/240/120) and 3 blocks, while my new little rig only has a single 120 and one CPU block.

Any help appreciated.
My System
(13 items)
 
  
CPUMotherboardGraphicsHard Drive
I7 950 Asus Rampage 3 Extreme Asus 5970 2x OCZ 128Gb SSD 
OSKeyboardPowerCase
Win7 64 Ultimate Logitech G19 Corsair HX 850 ATCS 840 
Mouse
Razer Lachesis 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsHard Drive
I7 950 Asus Rampage 3 Extreme Asus 5970 2x OCZ 128Gb SSD 
OSKeyboardPowerCase
Win7 64 Ultimate Logitech G19 Corsair HX 850 ATCS 840 
Mouse
Razer Lachesis 
  hide details  
Reply
post #2 of 3
Did you just fill the loop? is so give it a few days - sometimes up to a week for all those tiny bubbles to release. The sound you are most likely hearing is the air bubbles being passed through the pump channels.

If its been past a week since you filled the loop try bleeding the rads maybe?
post #3 of 3
Thread Starter 
Well its not some kind of grinding/rattling noise, it's just a whine or humm.

I've let the system running for about 48 hours and so far, the noise is just the same.

One thing i forgot to mention, is that my pump is mounted vertically in my new setup, with the inlet facing upwards.
In my old rig, which was silent, the inlet was facing sidewards.
My System
(13 items)
 
  
CPUMotherboardGraphicsHard Drive
I7 950 Asus Rampage 3 Extreme Asus 5970 2x OCZ 128Gb SSD 
OSKeyboardPowerCase
Win7 64 Ultimate Logitech G19 Corsair HX 850 ATCS 840 
Mouse
Razer Lachesis 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsHard Drive
I7 950 Asus Rampage 3 Extreme Asus 5970 2x OCZ 128Gb SSD 
OSKeyboardPowerCase
Win7 64 Ultimate Logitech G19 Corsair HX 850 ATCS 840 
Mouse
Razer Lachesis 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › Mcp 655 noise (not vibration)