Overclock.net › Forums › Graphics Cards › NVIDIA › Nvidia 590 "Blinking Logo"
New Posts  All Forums:Forum Nav:

Nvidia 590 "Blinking Logo"

post #1 of 8
Thread Starter 
my friend gave me his nvidia 590, it wasn't overclocked ever, the logo just blinks he said it was working in his pc before he gave me it, i took the whole thing apart and looked at the spots where others say that is what normally fails, and nothing looks burnt up.
Edited by Nightfallx - 6/22/13 at 2:11pm
post #2 of 8

Make sure you connect the power cables correctly to the GPU.

 

It happened to me before and it turned out that 2 of the pins on the power cable was a bit loose.

My Rig
(17 items)
 
Gaming Laptop
(7 items)
 
 
CPUMotherboardGraphicsRAM
i7 4790k Asus Z97-A Asus GTX Dual 1070 Corsair Vengance Pro 16gb @2400mhz 
Hard DriveHard DriveHard DriveCooling
WD 1TB @7200 RPM Kingston SSDnow 120GB Sandisk Plus 480GB Corsair H60 
OSMonitorKeyboardPower
Windows 10 (NSA Edition) LG 29UM68-P Ultra Wide Bloody 740A Mechanical Evga SuperNOVA G2 750W  
CaseMouseMouse PadAudio
Corsair 400R Logitech G303 Razer Goliathus Extended Bose Companion 2 series iii 
Audio
Skullcandy PLYR1 
CPUGraphicsRAMHard Drive
i7 2630QM Geforce GTX460M 8GB DDR3 @ 1333mhz 1TB 
OSMonitorMouse
Windows 10 (NSA edition) 17.3 inch 1080p Logitech M560 
  hide details  
Reply
My Rig
(17 items)
 
Gaming Laptop
(7 items)
 
 
CPUMotherboardGraphicsRAM
i7 4790k Asus Z97-A Asus GTX Dual 1070 Corsair Vengance Pro 16gb @2400mhz 
Hard DriveHard DriveHard DriveCooling
WD 1TB @7200 RPM Kingston SSDnow 120GB Sandisk Plus 480GB Corsair H60 
OSMonitorKeyboardPower
Windows 10 (NSA Edition) LG 29UM68-P Ultra Wide Bloody 740A Mechanical Evga SuperNOVA G2 750W  
CaseMouseMouse PadAudio
Corsair 400R Logitech G303 Razer Goliathus Extended Bose Companion 2 series iii 
Audio
Skullcandy PLYR1 
CPUGraphicsRAMHard Drive
i7 2630QM Geforce GTX460M 8GB DDR3 @ 1333mhz 1TB 
OSMonitorMouse
Windows 10 (NSA edition) 17.3 inch 1080p Logitech M560 
  hide details  
Reply
post #3 of 8
Thread Starter 
Quote:
Originally Posted by iARDAs View Post

Make sure you connect the power cables correctly to the GPU.

It happened to me before and it turned out that 2 of the pins on the power cable was a bit loose.

does this board look bad to you?
post #4 of 8

I don't see anything bad with the board from the looks of it.

 

Someone more experienced can also answer that. Maybe I am missing a detail.

My Rig
(17 items)
 
Gaming Laptop
(7 items)
 
 
CPUMotherboardGraphicsRAM
i7 4790k Asus Z97-A Asus GTX Dual 1070 Corsair Vengance Pro 16gb @2400mhz 
Hard DriveHard DriveHard DriveCooling
WD 1TB @7200 RPM Kingston SSDnow 120GB Sandisk Plus 480GB Corsair H60 
OSMonitorKeyboardPower
Windows 10 (NSA Edition) LG 29UM68-P Ultra Wide Bloody 740A Mechanical Evga SuperNOVA G2 750W  
CaseMouseMouse PadAudio
Corsair 400R Logitech G303 Razer Goliathus Extended Bose Companion 2 series iii 
Audio
Skullcandy PLYR1 
CPUGraphicsRAMHard Drive
i7 2630QM Geforce GTX460M 8GB DDR3 @ 1333mhz 1TB 
OSMonitorMouse
Windows 10 (NSA edition) 17.3 inch 1080p Logitech M560 
  hide details  
Reply
My Rig
(17 items)
 
Gaming Laptop
(7 items)
 
 
CPUMotherboardGraphicsRAM
i7 4790k Asus Z97-A Asus GTX Dual 1070 Corsair Vengance Pro 16gb @2400mhz 
Hard DriveHard DriveHard DriveCooling
WD 1TB @7200 RPM Kingston SSDnow 120GB Sandisk Plus 480GB Corsair H60 
OSMonitorKeyboardPower
Windows 10 (NSA Edition) LG 29UM68-P Ultra Wide Bloody 740A Mechanical Evga SuperNOVA G2 750W  
CaseMouseMouse PadAudio
Corsair 400R Logitech G303 Razer Goliathus Extended Bose Companion 2 series iii 
Audio
Skullcandy PLYR1 
CPUGraphicsRAMHard Drive
i7 2630QM Geforce GTX460M 8GB DDR3 @ 1333mhz 1TB 
OSMonitorMouse
Windows 10 (NSA edition) 17.3 inch 1080p Logitech M560 
  hide details  
Reply
post #5 of 8
ive read in other places, the blinking logo means there's not enough power going to the card thumb.gif
my toy :D
(16 items)
 
  
Reply
my toy :D
(16 items)
 
  
Reply
post #6 of 8
Thread Starter 
Quote:
Originally Posted by lordhinton View Post

ive read in other places, the blinking logo means there's not enough power going to the card thumb.gif

i have a 650watt power supply, and my other friend tested it for me he said on a 1kw psu.
post #7 of 8
maybe there's cracked solder or something else causing a gap between the power inputs and else where on the card, but im all out of knowledge now biggrin.gif hopefully someone can help you thumb.gif
my toy :D
(16 items)
 
  
Reply
my toy :D
(16 items)
 
  
Reply
post #8 of 8
Thread Starter 
i plug it up it just sits there and blinks, it's plugged up as we speak and it blinks but im still able to use onboard. and my device manager doesn't recognize the card at all.
Edited by Nightfallx - 6/22/13 at 3:06pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › Nvidia 590 "Blinking Logo"