Overclock.net › Forums › Intel › Intel Motherboards › [Asus Z87-DELUXE] USB Camera doesn't work?
New Posts  All Forums:Forum Nav:

[Asus Z87-DELUXE] USB Camera doesn't work?

post #1 of 13
Thread Starter 
System specs here.

Built this computer three days ago. Using both Windows 8 Pro and Windows 7 Professional, I haven't been able to get my Logitech Webcam Pro 9000, nor my HP HD-2200 running. They work fine on my older PCs, but not on this one. Unusually, the built-in microphone still functions, and the Windows Camera "app" on Windows 8 works (sometimes with significant delay in getting the camera started, other times instantaneous). Skype recognises the camera in both the Windows 7 and 8 versions, but states "Can't start video" or "Looks like there's a problem with your recording". Windows 8 troubleshooter says it's a USB 3.0 error, and to plug it into a USB 2.0 port...when it was plugged into a USB 2.0 port. It appears to throw that error regardless of port that it is in; Windows 7 troubleshooter doesn't say anything at all.

Steps taken:
  • Try a clean install of Windows 7 Pro. I hastily blamed this on Windows 8 driver inadequacies; doesn't appear to be the case.
  • Try different ports (6x USB 3.0 on the back, 4x USB 2.0 on the back, 2x USB 3.0 on the front).
  • Try Logitech LWS 2.8, 2.5, 1.1 and their respective drivers, ran native and with Win7 and WinXP compatibility mode.
  • Toggle legacy USB support.

My motherboard does not appear to be DOA, and the USB ports function fine with regards to my keyboard, mouse, and external HDD, with USB 3.0 speeds across the adequate USB "groups" on the motherboard, and USB 2.0 speeds on the USB 2.0 group.

Also, nothing is overclocked, so that should not be taken into consideration about the motherboard.
post #2 of 13
Thread Starter 
Update: Motherboard officially declared dead on arrival. All USB ports began displaying similar USB "initialisation delay" issues before failing altogether.
post #3 of 13
Asus Z-87 Deluxe USB 2.0 Problem Error Issue ???

I assembled my computer about a week ago. Asus Z-87 Deluxe, Windows Pro 64-bit and an "older" Logitech C270 USB webcam. Webcam is compatible with Windows 8 and does work on another older computer (2.0 USB). The web cam is detected, but I can't capture any images (image capture fail message). Windows Action Center provides an error message stating the camera needs to be connected to a USB 2.0 port. I tried connecting it to all of the USB ports (front/back, 2.0/3.0) with same results.All the latest drivers and BIOS have been installed.

I chatted with Asus support and they recommended resetting CMOS, reinstalling USB drivers and the problem still exists. They are suggesting a faulty USB controller on the board. I'll be bringing the board back to my retailer to have it checked out and hopefully receive a replacement. Hopefully this isn't a mass problem for Asus and the replacement board has the same issues.

Thanks for your post, at least I'm not alone here.
Edited by Rabbit One - 7/6/13 at 8:38am
post #4 of 13
I am having the same issue with my Z87 Pro running Win7-64 and a Logitech C310 webcam. The cam shows up under Imaging Devices in the Dev Mgr and the mic seems to work - just no video. I tried capturing with VLC but no luck. I do not believe there is anything wrong with the hdw (cam or mb usb) since the cam works on another machine (Asus P5NE-SLI running win8 Pro 64b) and every other device I have connected to the Z87 usb seems to function normally. I suspect some driver or software is getting the way. If you find a solution - please update this thread!
post #5 of 13
If you have AI Suite III installed and AI Charger+, apply this update to fix any USB devices not being recognized:


This module will go up on the main support pages soon (under validation).

post #6 of 13
Thank you very much! That patch fixed the webcam problem! I've been fighting this all week - even have a usb 2.0 hub card on order - well you can never have too many usb ports.
Thank you again for such a rapid response.
post #7 of 13
I installed the file but it doesnt work yet. i have windows 7 home premium. and an asus z87 deluxe, all is working fine, but only the webcam thing, even the microphone works :S my cam is a creative webcam live! ultra, and yes it works on other pcs with windows 7 home premium
Edited by Naitse0 - 8/12/13 at 6:42am
post #8 of 13
I was having the same issue. tried two different webcams and it wouldn't work in any video app. I installed the patch, and now its working for me in the win 8 camera app, the win 8 Skype app, and the desktop Lync app. However it still won't work in the Skype desktop app. I had no problem on my last machine using the same camera and same version of Skype (, so i can only attribute the issue to the board / drivers.
post #9 of 13
Thread Starter 
I somewhat solved this by not using AI Suite III, but I would like to try using it again just to see.

I noticed that the update pack has hit the support page, but is 1.00.00 instead of 1.00.01. Which is newer, and if I install the updated version of AI Charger+ (3.01.01), do I need to install the pack?

I may just "yolo" and take the plunge by risking my Windows installation. I guess if I remove AI Suite III afterwards, it should go back to operating as before, yeah?
post #10 of 13
THANK YOU, Raja! I installed the AI Charger+ update you linked to above and now my Logitech webcam works again. Outstanding!

Now if I can stop the USB ports from frequently disconnecting and reconnecting. Maybe this patch fixed that, too. I'll have to wait and see...

Robert Bernstein
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › [Asus Z87-DELUXE] USB Camera doesn't work?