Overclock.net › Forums › Components › Keyboards › Really awkward bug with the input language
New Posts  All Forums:Forum Nav:

Really awkward bug with the input language

post #1 of 3
Thread Starter 
Hey guys, im having some really annoying issue with almost every game i play, basically i can't move the character with "WASD" set. If i remap the movement to the arrows the movement works fine, im having this issue on my PC keyboard and on my laptop too (the bug persists on my laptop native keyboard and the external PS2 keyboard -usb 2.0 or usb 3.0 connected). The bug appears on games such as Team Fortress 2, Wow, Aliens vs Predator, Hitman etc, and it is pretty annoying. On games like Assassins Creed and Skyrim i dont bump into this issue tho.

I tried changing the input language to US, but it doesnt work. My keyboards support both Cyrillic and Latin, but its almost a year later and i still havent found a solution to this.

My laptop specs: i7 3630qm, gtx660m, 8gm 1666MHz, 1tb hdd 5.4k rpm, latest graphics, laptop and keyboard drivers.
Edited by bazziliska - 6/26/13 at 12:43pm
post #2 of 3
I'm guessing your OS's Interface is not in English, have you tried the keys next to WASD (ESDF) ?


Here's how to put your rig in your sig:
http://www.overclock.net/t/1258253/how-to-put-your-rig-in-your-sig
TheSadFlute
(17 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI Golden Ed GTX980 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  HP 32' 1440p Logitech G710+ EVGA G2 750W 
CaseMouseMouse PadAudio
Cooler Master Stryker Logitech G602 Steel Series On-Board 
Audio
Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
TheSadFlute
(17 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI Golden Ed GTX980 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  HP 32' 1440p Logitech G710+ EVGA G2 750W 
CaseMouseMouse PadAudio
Cooler Master Stryker Logitech G602 Steel Series On-Board 
Audio
Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
post #3 of 3
Thread Starter 
I have tried other letters but it doesn't work, the symbol keys work perfect however- numbers, arrows etc. Basically you can see a struggle of the character to move, but he passes like half a feet over 10 keyboard clicks, which is beyond being playable.

I forgot to point out that my OS is Win7 x64 Ultimate on both the PC and the laptop.

Region and Language settings are set on the following- Formats (English USA), Location- USA, Display Language- English, Main Keyboard Input language- English, Administrative- English.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Keyboards
Overclock.net › Forums › Components › Keyboards › Really awkward bug with the input language