Overclock.net › Forums › Cooling › Water Cooling › Making a drain loop which connectors to get?
New Posts  All Forums:Forum Nav:

Making a drain loop which connectors to get? - Page 2

post #11 of 15
Quote:
Originally Posted by jakemfbacon View Post

sorry I am just new to this. How do I pull the cold plate off? And are you talking about the cpu water block. Thanks for your help.

Yes. By the cold plate I mean the copper base of the water block. The fins milled into the base are extremely thin, so they function like a filter of sorts. I'm not sure what water block you have, but on my Raystorm, there are 4 screws on the bottom you need to remove, and the plate comes right off. There will be o-rings that you will have to get back into their channels, but it isn't hard. I guess you could try running some water backwards through the outlet of the block before you try and remove the cold plate, that would probably clean anything out that may be caught in there.
    
CPUMotherboardGraphicsRAM
[Intel Core i7 5820K] {4.5GHz} [Asus Rampage V Extreme] [R9 290X Crossfire] {1205/1375} [Crucial DDR4] {16GB-2400MHz} 
Hard DriveHard DriveHard DriveOptical Drive
[Western Digital WD10EALS] [Samsung 840 Evo 250GB] [Western Digitan WD10EZEX] [Lite-On iHAS-524-B] 
CoolingOSMonitorKeyboard
[Custom Loop - Twin 360mm Rads] [Windows 8.1 Pro x64] [Samsung Syncmaster BX2450] [Logitech G510] 
PowerCaseMouseMouse Pad
[XFX Pro 1250] [CaseLabs Magnum M10] [Logitech G500] [GPGR Large] 
Audio
[Creative Sound Blaster Z] 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
[Intel Core i7 5820K] {4.5GHz} [Asus Rampage V Extreme] [R9 290X Crossfire] {1205/1375} [Crucial DDR4] {16GB-2400MHz} 
Hard DriveHard DriveHard DriveOptical Drive
[Western Digital WD10EALS] [Samsung 840 Evo 250GB] [Western Digitan WD10EZEX] [Lite-On iHAS-524-B] 
CoolingOSMonitorKeyboard
[Custom Loop - Twin 360mm Rads] [Windows 8.1 Pro x64] [Samsung Syncmaster BX2450] [Logitech G510] 
PowerCaseMouseMouse Pad
[XFX Pro 1250] [CaseLabs Magnum M10] [Logitech G500] [GPGR Large] 
Audio
[Creative Sound Blaster Z] 
  hide details  
Reply
post #12 of 15
Thread Starter 
Quote:
Originally Posted by AddictedGamer93 View Post

Yes. By the cold plate I mean the copper base of the water block. The fins milled into the base are extremely thin, so they function like a filter of sorts. I'm not sure what water block you have, but on my Raystorm, there are 4 screws on the bottom you need to remove, and the plate comes right off. There will be o-rings that you will have to get back into their channels, but it isn't hard. I guess you could try running some water backwards through the outlet of the block before you try and remove the cold plate, that would probably clean anything out that may be caught in there.

oh ok cool thanks I actually have the raystorm aswell. What did you use to clean it with?
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 @ 4.0 Ghz Gigabyte GA-X58A-UD3R xfx radeon 7950 patriot viper 3 8gb 1600mhz 
Hard DriveOSMonitorPower
curcial mx100 512gb windows 8.1 64bit LG 34um95 Cooler Master GX750 
Case
nzxt switch 810 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 @ 4.0 Ghz Gigabyte GA-X58A-UD3R xfx radeon 7950 patriot viper 3 8gb 1600mhz 
Hard DriveOSMonitorPower
curcial mx100 512gb windows 8.1 64bit LG 34um95 Cooler Master GX750 
Case
nzxt switch 810 
  hide details  
Reply
post #13 of 15
Quote:
Originally Posted by jakemfbacon View Post

oh ok cool thanks I actually have the raystorm aswell. What did you use to clean it with?

I just wiped the stuff off with my shirt lol. You can take a flashlight and look into the inlet of the block, you should see the silver jet plate, and the fins on the base. If anything is trapped in there, you will see it looking into the inlet.
Edited by AddictedGamer93 - 6/27/13 at 12:19pm
    
CPUMotherboardGraphicsRAM
[Intel Core i7 5820K] {4.5GHz} [Asus Rampage V Extreme] [R9 290X Crossfire] {1205/1375} [Crucial DDR4] {16GB-2400MHz} 
Hard DriveHard DriveHard DriveOptical Drive
[Western Digital WD10EALS] [Samsung 840 Evo 250GB] [Western Digitan WD10EZEX] [Lite-On iHAS-524-B] 
CoolingOSMonitorKeyboard
[Custom Loop - Twin 360mm Rads] [Windows 8.1 Pro x64] [Samsung Syncmaster BX2450] [Logitech G510] 
PowerCaseMouseMouse Pad
[XFX Pro 1250] [CaseLabs Magnum M10] [Logitech G500] [GPGR Large] 
Audio
[Creative Sound Blaster Z] 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
[Intel Core i7 5820K] {4.5GHz} [Asus Rampage V Extreme] [R9 290X Crossfire] {1205/1375} [Crucial DDR4] {16GB-2400MHz} 
Hard DriveHard DriveHard DriveOptical Drive
[Western Digital WD10EALS] [Samsung 840 Evo 250GB] [Western Digitan WD10EZEX] [Lite-On iHAS-524-B] 
CoolingOSMonitorKeyboard
[Custom Loop - Twin 360mm Rads] [Windows 8.1 Pro x64] [Samsung Syncmaster BX2450] [Logitech G510] 
PowerCaseMouseMouse Pad
[XFX Pro 1250] [CaseLabs Magnum M10] [Logitech G500] [GPGR Large] 
Audio
[Creative Sound Blaster Z] 
  hide details  
Reply
post #14 of 15
Just for clarity, I take it your radiator and/or reservoir doesn't have an unused port? I find those make the perfect fill/drain locations many times.
post #15 of 15
Quote:
Originally Posted by 47 Knucklehead View Post

Just for clarity, I take it your radiator and/or reservoir doesn't have an unused port? I find those make the perfect fill/drain locations many times.

He should have a spare port on his res. He is using an xspc bay res of some kind, I don't know of any xspc bay res's that only have two ports.

Edit: Actually, I just found one. Nvm.
Edited by AddictedGamer93 - 6/27/13 at 12:31pm
    
CPUMotherboardGraphicsRAM
[Intel Core i7 5820K] {4.5GHz} [Asus Rampage V Extreme] [R9 290X Crossfire] {1205/1375} [Crucial DDR4] {16GB-2400MHz} 
Hard DriveHard DriveHard DriveOptical Drive
[Western Digital WD10EALS] [Samsung 840 Evo 250GB] [Western Digitan WD10EZEX] [Lite-On iHAS-524-B] 
CoolingOSMonitorKeyboard
[Custom Loop - Twin 360mm Rads] [Windows 8.1 Pro x64] [Samsung Syncmaster BX2450] [Logitech G510] 
PowerCaseMouseMouse Pad
[XFX Pro 1250] [CaseLabs Magnum M10] [Logitech G500] [GPGR Large] 
Audio
[Creative Sound Blaster Z] 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
[Intel Core i7 5820K] {4.5GHz} [Asus Rampage V Extreme] [R9 290X Crossfire] {1205/1375} [Crucial DDR4] {16GB-2400MHz} 
Hard DriveHard DriveHard DriveOptical Drive
[Western Digital WD10EALS] [Samsung 840 Evo 250GB] [Western Digitan WD10EZEX] [Lite-On iHAS-524-B] 
CoolingOSMonitorKeyboard
[Custom Loop - Twin 360mm Rads] [Windows 8.1 Pro x64] [Samsung Syncmaster BX2450] [Logitech G510] 
PowerCaseMouseMouse Pad
[XFX Pro 1250] [CaseLabs Magnum M10] [Logitech G500] [GPGR Large] 
Audio
[Creative Sound Blaster Z] 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › Making a drain loop which connectors to get?