Overclock.net › Forums › Components › Mice › Issue with my Razer Mamba, can anyone help?
New Posts  All Forums:Forum Nav:

Issue with my Razer Mamba, can anyone help?

post #1 of 2
Thread Starter 
First of all, I'm new to this website, I created an account just to ask this question as I have a unique issue with mine and can't seem to find a solution to it. Now before I continue, if you're just going to give me a hard time for even owning one Razer product in general, or say something along the lines of "Your issue is that it's a Razer mouse", leave this thread and don't even continue to read it.

Anyways, so my issue with mine started while playing Minecraft (I was bored with nothing to do) anyways, the mouses DPI for Minecraft was extremely fast so I attempted to change the DPI using the two buttons next to the left mouse button. Well, what happened after I did this was the mouse became unresponsive after changing the DPI either up or down, but after clicking the left or right mouse button it would start working again but began to place blocks immediately everywhere I looked (which is done by clicking the right mouse button). Well after a couple more times, the mouse became completely unresponsive, the mouse cursor doesn't move, I can't click anything, and the red DPI indicator flashes repeatedly. When I put it on the charging stand it acts as if it's chargining, but instead of the subtle pulse that the mouse led does, it flashes on and off (not fast, but once every 1-2 seconds). When I plug in the cord to the mouse, it shuts off completely.

I've tried switching the USB ports the mouse is plugged into with no luck, I've checked the battery and there doesn't seem to be any signs of damage besides a little mark on one of the gold contacts. I could try updating the firmware but the reason why I haven't done this is because I haven't been able to find anybody else with my same issue except for one person on YouTube who I have no clue if he's fixed the issue or not.

For reference, this is the exact issue I'm having right here http://m.youtube.com/watch?v=gR6_OPs_gF0

Any help is appreciated, thank you!
Edited by Bastrios - 7/1/13 at 9:28am
post #2 of 2
It sounds like you need to call up Razer Support and have them replace the mouse for you...seems like a defect you won't be able to fix on your own.
2600k
(18 items)
 
  
CPUMotherboardGraphicsRAM
2600k Asus P8Z68-V/GEN3 GTX 460 SC G.SKILL Ripjaws Z 
Hard DriveHard DriveHard DriveHard Drive
Crucial M4 Crucial M4 OCZ Agility 3 Seagate 
CoolingOSMonitorMonitor
Corsair H100 Win7 BenQ XL2420T Qnix QX2710 
KeyboardPowerCaseMouse
Leopold Otaku Corsair AX850 Corsair Obsidian 650D Zowie EC1 eVo & Razer Mamba 
Mouse PadAudio
SteelSeries QCK+ & SteelSeries Experience I-2 Harmon Kardon 2.1 & Logitech G930 
  hide details  
Reply
2600k
(18 items)
 
  
CPUMotherboardGraphicsRAM
2600k Asus P8Z68-V/GEN3 GTX 460 SC G.SKILL Ripjaws Z 
Hard DriveHard DriveHard DriveHard Drive
Crucial M4 Crucial M4 OCZ Agility 3 Seagate 
CoolingOSMonitorMonitor
Corsair H100 Win7 BenQ XL2420T Qnix QX2710 
KeyboardPowerCaseMouse
Leopold Otaku Corsair AX850 Corsair Obsidian 650D Zowie EC1 eVo & Razer Mamba 
Mouse PadAudio
SteelSeries QCK+ & SteelSeries Experience I-2 Harmon Kardon 2.1 & Logitech G930 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › Issue with my Razer Mamba, can anyone help?