Overclock.net › Forums › Overclockers Care › Overclock.net Folding@Home Team › GPU Folding Natively in Linux
New Posts  All Forums:Forum Nav:

GPU Folding Natively in Linux - Page 5

post #41 of 57
Created with GIMP

Updated to 3.9.9 kernel and downloaded 319.32 drivers from nvidia and this is what i get, doesn't appear to report it correctly.
My System
(21 items)
 
Server/HTPC
(11 items)
 
 
CPUMotherboardGraphicsRAM
AMD 8320 Asus m5a99fx pro EVGA 660ti  Gskill 8GB F3-1600C9-8GXM x2 
RAMHard DriveHard DriveHard Drive
4GB x2 OCZ Agility 3 Sasmsung 840 EVO Western Digital Caviar Blue 
Hard DriveOptical DriveOptical DriveCooling
Seagate 500gb Asus DRW-24B1ST Asus BC-12B1ST cool master hyper 212 evo 
OSOSMonitorMonitor
Windows 10 Pro x64 Arch  Asus 23" VH238 Asus 23" VH238H 
PowerCase
Corsair CX600M Fractal Design Define R5  
CPUMotherboardRAMHard Drive
i3 6100 Asus Z170M-Plus something 16gb DDR4 Western Digital 200GB 
Hard DriveHard DriveHard DriveOS
Western Digital 1TB Samsung 2TB Western Digital Red 3TB Centos 7 
OSPowerCase
Ubuntu Server - VM Corsair CX430  Cooler Master HAF 912 
  hide details  
Reply
My System
(21 items)
 
Server/HTPC
(11 items)
 
 
CPUMotherboardGraphicsRAM
AMD 8320 Asus m5a99fx pro EVGA 660ti  Gskill 8GB F3-1600C9-8GXM x2 
RAMHard DriveHard DriveHard Drive
4GB x2 OCZ Agility 3 Sasmsung 840 EVO Western Digital Caviar Blue 
Hard DriveOptical DriveOptical DriveCooling
Seagate 500gb Asus DRW-24B1ST Asus BC-12B1ST cool master hyper 212 evo 
OSOSMonitorMonitor
Windows 10 Pro x64 Arch  Asus 23" VH238 Asus 23" VH238H 
PowerCase
Corsair CX600M Fractal Design Define R5  
CPUMotherboardRAMHard Drive
i3 6100 Asus Z170M-Plus something 16gb DDR4 Western Digital 200GB 
Hard DriveHard DriveHard DriveOS
Western Digital 1TB Samsung 2TB Western Digital Red 3TB Centos 7 
OSPowerCase
Ubuntu Server - VM Corsair CX430  Cooler Master HAF 912 
  hide details  
Reply
post #42 of 57
Quote:
Originally Posted by anubis1127 View Post


I don't think that value is being reported accurately with Kepler GPUs. I saw the same 705mhz on my 690 GPU cores, and they run at 1058mhz stock after boost. I was getting around the same TPF / PPD as I would in windows with the card not overclocked, so I assume it was still running at 1058mhz.

This is what I also read on the interweb though that was with quite old drivers. But my PPD was half on the GPUs in Windows implying they were running 705Mhz..

I then tried to do the coolbits but of course can't find the necessary file. I tried the various commands I found from another link and even though you can "enable" OCing, none of the values you define get set.
Just a 'puter
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 6700K ASUS Maximus VIII Hero iGPU thanks to Nvidia 970 3.5GB Corsair Vengeance LPX CMK8GX4M2B3200C16 
Hard DriveHard DriveCoolingCooling
Samsung 950 PRO 512GB Crucial M4 256GB RX360 V3 Koolance CPU-380I 
CoolingCoolingOSMonitor
Koolance RP-452X2 Reservoir Koolance PMP-450 12V Variable Speed Pump Windows 10 Pro x64 benq XL2411Z 
KeyboardPowerCaseMouse
logitech G510 Seasonic X-760 Corsair 800D Mionix Castor 
AudioAudio
Creative Sound Blaster X-Fi Titanium HD DT 990 Premium 250Ohm 
  hide details  
Reply
Just a 'puter
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 6700K ASUS Maximus VIII Hero iGPU thanks to Nvidia 970 3.5GB Corsair Vengeance LPX CMK8GX4M2B3200C16 
Hard DriveHard DriveCoolingCooling
Samsung 950 PRO 512GB Crucial M4 256GB RX360 V3 Koolance CPU-380I 
CoolingCoolingOSMonitor
Koolance RP-452X2 Reservoir Koolance PMP-450 12V Variable Speed Pump Windows 10 Pro x64 benq XL2411Z 
KeyboardPowerCaseMouse
logitech G510 Seasonic X-760 Corsair 800D Mionix Castor 
AudioAudio
Creative Sound Blaster X-Fi Titanium HD DT 990 Premium 250Ohm 
  hide details  
Reply
post #43 of 57
My ppd seemed to be the same on it as in windows but i didn't let it run long. I'll leave it on in linux and try fro the foldathon.
My System
(21 items)
 
Server/HTPC
(11 items)
 
 
CPUMotherboardGraphicsRAM
AMD 8320 Asus m5a99fx pro EVGA 660ti  Gskill 8GB F3-1600C9-8GXM x2 
RAMHard DriveHard DriveHard Drive
4GB x2 OCZ Agility 3 Sasmsung 840 EVO Western Digital Caviar Blue 
Hard DriveOptical DriveOptical DriveCooling
Seagate 500gb Asus DRW-24B1ST Asus BC-12B1ST cool master hyper 212 evo 
OSOSMonitorMonitor
Windows 10 Pro x64 Arch  Asus 23" VH238 Asus 23" VH238H 
PowerCase
Corsair CX600M Fractal Design Define R5  
CPUMotherboardRAMHard Drive
i3 6100 Asus Z170M-Plus something 16gb DDR4 Western Digital 200GB 
Hard DriveHard DriveHard DriveOS
Western Digital 1TB Samsung 2TB Western Digital Red 3TB Centos 7 
OSPowerCase
Ubuntu Server - VM Corsair CX430  Cooler Master HAF 912 
  hide details  
Reply
My System
(21 items)
 
Server/HTPC
(11 items)
 
 
CPUMotherboardGraphicsRAM
AMD 8320 Asus m5a99fx pro EVGA 660ti  Gskill 8GB F3-1600C9-8GXM x2 
RAMHard DriveHard DriveHard Drive
4GB x2 OCZ Agility 3 Sasmsung 840 EVO Western Digital Caviar Blue 
Hard DriveOptical DriveOptical DriveCooling
Seagate 500gb Asus DRW-24B1ST Asus BC-12B1ST cool master hyper 212 evo 
OSOSMonitorMonitor
Windows 10 Pro x64 Arch  Asus 23" VH238 Asus 23" VH238H 
PowerCase
Corsair CX600M Fractal Design Define R5  
CPUMotherboardRAMHard Drive
i3 6100 Asus Z170M-Plus something 16gb DDR4 Western Digital 200GB 
Hard DriveHard DriveHard DriveOS
Western Digital 1TB Samsung 2TB Western Digital Red 3TB Centos 7 
OSPowerCase
Ubuntu Server - VM Corsair CX430  Cooler Master HAF 912 
  hide details  
Reply
post #44 of 57
Thread Starter 
You won't see a big gain vs using windows, maybe 5 to 10 percent. I have used this as more of a learning tool. I'm testing whether or not running the DM makes a big impact on GPU ppd.
post #45 of 57
Hmmm, I must be missing something. I installed FAH in Ubuntu 12.04 and got it working for the CPU, but when I added the 2 GPU slots for my GTX 580's it just sits there saying "Ready" and "Download" on the 2 GPU slots. I added the "gpu gpu-species nvidia_fermi" tag, but no luck.

Do I have to upgrade to 13.04?

Well, upgrading to 12.10 didn't work. Guess I'll try upgrading to 13.04 for giggles.

BTW, this is in my log:

22:12:06:WARNING:WU01:FS01:Failed to get assignment from 'assign-GPU.stanford.edu:80': Empty work server assignment
22:12:06:WU01:FS01:Connecting to assign-GPU.stanford.edu:8080
22:12:06:WU02:FS02:News: Welcome to Folding@Home
22:12:06:WARNING:WU02:FS02:Failed to get assignment from 'assign-GPU.stanford.edu:80': Empty work server assignment
22:12:06:WU02:FS02:Connecting to assign-GPU.stanford.edu:8080
Edited by 47 Knucklehead - 9/30/13 at 3:14pm
post #46 of 57
I guess you checked that you are using Nvidia proprietary drivers, and a client-type=beta and that the Folding Power slider is set to Full.
On the latest 7.3.6 the gpu-species isn't needed, probably doesn't hurt either though.
Frigg d.y.
(23 items)
 
 
CPUMotherboardGraphicsRAM
i7 3770K@4600MHz 1.288V ASUS P8Z68-V EVGA Geforce GTX780Ti@1293MHz 2x4GB G.Skill TrindentX 2400 CL10@2133 CL10 
Hard DriveHard DriveCoolingCooling
Corsair Force F60 2.5" SSD OCZ Agility 3 120GB 2.5" SSD EK-Supremacy CSQ Full Nickel EK-FC Titan Nickel CSQ 
CoolingCoolingCoolingCooling
Alphacool VPP655 w/ EK D5 X-Top Rev.2 EK-Coolstream Rad XTX 360 & XSPC RS240 Phobya Balancer 150 Reservoir 3xScythe GT AP-15@7V, 2xNexus Real Silent 120mm... 
OSOSMonitorMonitor
Linux Mint 16 64-bit Windows 7 64-bit Qix Qx2710LED Evolution II 2560x1440 Dell U2311H 1920x1080 
KeyboardPowerCaseMouse
Keycool 84 w/ Cherry MX Clear  Enermax Platimax 1500W NZXT H630 Func MS3 
Mouse PadAudioOther
Qpad Sweclockers Edition BRIK DAC & AMP Ducky DK9008G2 Pro w/ Cherry MX Clear  
  hide details  
Reply
Frigg d.y.
(23 items)
 
 
CPUMotherboardGraphicsRAM
i7 3770K@4600MHz 1.288V ASUS P8Z68-V EVGA Geforce GTX780Ti@1293MHz 2x4GB G.Skill TrindentX 2400 CL10@2133 CL10 
Hard DriveHard DriveCoolingCooling
Corsair Force F60 2.5" SSD OCZ Agility 3 120GB 2.5" SSD EK-Supremacy CSQ Full Nickel EK-FC Titan Nickel CSQ 
CoolingCoolingCoolingCooling
Alphacool VPP655 w/ EK D5 X-Top Rev.2 EK-Coolstream Rad XTX 360 & XSPC RS240 Phobya Balancer 150 Reservoir 3xScythe GT AP-15@7V, 2xNexus Real Silent 120mm... 
OSOSMonitorMonitor
Linux Mint 16 64-bit Windows 7 64-bit Qix Qx2710LED Evolution II 2560x1440 Dell U2311H 1920x1080 
KeyboardPowerCaseMouse
Keycool 84 w/ Cherry MX Clear  Enermax Platimax 1500W NZXT H630 Func MS3 
Mouse PadAudioOther
Qpad Sweclockers Edition BRIK DAC & AMP Ducky DK9008G2 Pro w/ Cherry MX Clear  
  hide details  
Reply
post #47 of 57
Quote:
Originally Posted by arvidab View Post

I guess you checked that you are using Nvidia proprietary drivers, and a client-type=beta and that the Folding Power slider is set to Full.
On the latest 7.3.6 the gpu-species isn't needed, probably doesn't hurt either though.

Yeah, they are older drivers, Linuz-x86_64, version 304.88 ... at least that is according to the nVidia X Server Settings app.

Lemme pull the gpu-series tag and add the beta tag.\


That did it ... Thanks.

Had to use client-type beta for the GPU cores. Now everything is running!
Edited by 47 Knucklehead - 9/30/13 at 3:18pm
post #48 of 57
Wonderful! Are you experience any lag?
Frigg d.y.
(23 items)
 
 
CPUMotherboardGraphicsRAM
i7 3770K@4600MHz 1.288V ASUS P8Z68-V EVGA Geforce GTX780Ti@1293MHz 2x4GB G.Skill TrindentX 2400 CL10@2133 CL10 
Hard DriveHard DriveCoolingCooling
Corsair Force F60 2.5" SSD OCZ Agility 3 120GB 2.5" SSD EK-Supremacy CSQ Full Nickel EK-FC Titan Nickel CSQ 
CoolingCoolingCoolingCooling
Alphacool VPP655 w/ EK D5 X-Top Rev.2 EK-Coolstream Rad XTX 360 & XSPC RS240 Phobya Balancer 150 Reservoir 3xScythe GT AP-15@7V, 2xNexus Real Silent 120mm... 
OSOSMonitorMonitor
Linux Mint 16 64-bit Windows 7 64-bit Qix Qx2710LED Evolution II 2560x1440 Dell U2311H 1920x1080 
KeyboardPowerCaseMouse
Keycool 84 w/ Cherry MX Clear  Enermax Platimax 1500W NZXT H630 Func MS3 
Mouse PadAudioOther
Qpad Sweclockers Edition BRIK DAC & AMP Ducky DK9008G2 Pro w/ Cherry MX Clear  
  hide details  
Reply
Frigg d.y.
(23 items)
 
 
CPUMotherboardGraphicsRAM
i7 3770K@4600MHz 1.288V ASUS P8Z68-V EVGA Geforce GTX780Ti@1293MHz 2x4GB G.Skill TrindentX 2400 CL10@2133 CL10 
Hard DriveHard DriveCoolingCooling
Corsair Force F60 2.5" SSD OCZ Agility 3 120GB 2.5" SSD EK-Supremacy CSQ Full Nickel EK-FC Titan Nickel CSQ 
CoolingCoolingCoolingCooling
Alphacool VPP655 w/ EK D5 X-Top Rev.2 EK-Coolstream Rad XTX 360 & XSPC RS240 Phobya Balancer 150 Reservoir 3xScythe GT AP-15@7V, 2xNexus Real Silent 120mm... 
OSOSMonitorMonitor
Linux Mint 16 64-bit Windows 7 64-bit Qix Qx2710LED Evolution II 2560x1440 Dell U2311H 1920x1080 
KeyboardPowerCaseMouse
Keycool 84 w/ Cherry MX Clear  Enermax Platimax 1500W NZXT H630 Func MS3 
Mouse PadAudioOther
Qpad Sweclockers Edition BRIK DAC & AMP Ducky DK9008G2 Pro w/ Cherry MX Clear  
  hide details  
Reply
post #49 of 57
A little. If I move it down to "Medium" then the CPU Folding works, but it pauses the GPU Folding. Lag is no worse than when I'm Folding under full power with Windows.

I'll have to mess with it some more. The numbers I was getting under Windows for my 580's was ... HORRIBLE. Now to see what SMP6 and 2 GTX 580's do under Linux.

post #50 of 57

That is how it is supposed to work. 

 

Performance Levels for Web Control’s folding power slider

Level Not Idle Idle Target
  On AC On Battery On AC On Battery  
Off Off  
Idle Light Off Light with GPU Off Laptops
Idle Off Full Desktops
Light ceil(total CPUs / 2) or 50% of one CPU Off add GPU Off Laptops
Medium (total – 1) CPUs or 80% of one CPU add GPU Desktops
Full All CPUs and GPU (N-1 CPUs if ATI GPU) Hardcore folders

 

source.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Overclock.net Folding@Home Team
Overclock.net › Forums › Overclockers Care › Overclock.net Folding@Home Team › GPU Folding Natively in Linux