post #1 of 1
Thread Starter 
Just as some background first, I recently got a X-Star PLS panel and overclocked it to 120hz. Everything works sweet with my current single Galaxy 670 factory OC'ed. I'm also running an i5 3570K OC'ed to 4.2 and a Silverstone ST75F-P 750W power supply.

I really wanted to get the most of the new panel so I bought another 670. I couldn't find the same card anywhere, so I bought a Gigabyte Windforce 670 thats also factory OC'ed.

Both cards boot up fine by themselves. Both cards boot up fine in both PCI-E 16x slots on the motherboard (Asrock Extreme4 Z77).

When I plug both cards in I get past the Asrock boot, then the screen flashes black and loops to restart. This will happen until I hit the power button. This also happens no matter if both cards are plugged into the power supply individually, or if only the primary card is plugged in and the other card gets power from the SLI bridge. Both cards have been in both PCI-E slots and tested as well for the same result. I have re-seated everything in my system three times. I've also removed the overclock on the CPU and tried that, then tried undervolting the CPU at stock speed as well. No dice.

From what I have read the power supply I am using should be sufficient for the power requirements of the system. But I'm not sure. I'm stuck at the moment and need a little help!