Overclock.net › Forums › Graphics Cards › AMD/ATI › 7970 screen flicker?
New Posts  All Forums:Forum Nav:

7970 screen flicker?

post #1 of 5
Thread Starter 
SO i have real bad screen flicker or I don't know what's the deal here every time i have 2 screens hooked up this happens if i play a video or play a game, i check msi afterburner i see my clock at 500 mhz .... i had 13.4 drivers just got 13.6 beta 2 still going on... here is a video of it sorry about the noise and the quality i had the ac on and stuff...

http://www.youtube.com/watch?v=AvYevKvr0aM&feature=youtu.be
Phantom X
(14 items)
 
  
CPUMotherboardGraphicsRAM
5820k ASrock X99 Extreme 4  Nvidia TITAN X  Corsair 16GB 2 x 8GB DDR4-3000 32GB 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO  Samsung 840 EVO  H220  Windows 10 Pro 64bit 
MonitorKeyboardPowerCase
Dell P2715Q 4k G910  Evga Super Nova 850W NZXT H440 
MouseAudio
Logitech g502 G51 
  hide details  
Reply
Phantom X
(14 items)
 
  
CPUMotherboardGraphicsRAM
5820k ASrock X99 Extreme 4  Nvidia TITAN X  Corsair 16GB 2 x 8GB DDR4-3000 32GB 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO  Samsung 840 EVO  H220  Windows 10 Pro 64bit 
MonitorKeyboardPowerCase
Dell P2715Q 4k G910  Evga Super Nova 850W NZXT H440 
MouseAudio
Logitech g502 G51 
  hide details  
Reply
post #2 of 5
Normally if you had 2 cards in CF I would say disable the ULPS but that isn't the case here. It's got to be driver related. Did you by chance run ATIman uninstaller when you were changing drivers? This program clears out any old drivers that can cause conflicts so when you change versions it has to do a full install of the driver package. I would start with 13.4 first before the betas unless you have an OC you're trying out.
post #3 of 5
Thread Starter 
Trying to open 13.6 beta I'm getting some nsis error.... but if i open 13.4 it open fine .... jesus what's the deal AMD and their drivers mad.gif
Phantom X
(14 items)
 
  
CPUMotherboardGraphicsRAM
5820k ASrock X99 Extreme 4  Nvidia TITAN X  Corsair 16GB 2 x 8GB DDR4-3000 32GB 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO  Samsung 840 EVO  H220  Windows 10 Pro 64bit 
MonitorKeyboardPowerCase
Dell P2715Q 4k G910  Evga Super Nova 850W NZXT H440 
MouseAudio
Logitech g502 G51 
  hide details  
Reply
Phantom X
(14 items)
 
  
CPUMotherboardGraphicsRAM
5820k ASrock X99 Extreme 4  Nvidia TITAN X  Corsair 16GB 2 x 8GB DDR4-3000 32GB 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO  Samsung 840 EVO  H220  Windows 10 Pro 64bit 
MonitorKeyboardPowerCase
Dell P2715Q 4k G910  Evga Super Nova 850W NZXT H440 
MouseAudio
Logitech g502 G51 
  hide details  
Reply
post #4 of 5
This happened to me a few months back, same exact problem. Found a solution and has long been solved.

http://www.overclock.net/t/1385568/7970-artifacts-entire-screen-flickers-and-turns-blue-with-jagged-lines-when-watching-youtube-videos

Solutions and fixes can be found here at this post:

http://www.overclock.net/t/1385568/7970-artifacts-entire-screen-flickers-and-turns-blue-with-jagged-lines-when-watching-youtube-videos#post_19831160
(A link within a link, Linkception.)

Then keep reading replies until last page to see what all I did to get it fixed.
T-980X
(14 items)
 
  
CPUMotherboardGraphicsRAM
Cyberdyne Systems i7 980X Hexa Core @ 4.2Ghz Asus Rampage III Extreme Reference VTek 7970 @ 1150/1700 Stock Bios Stable 12GB Mushkin Blackline DDR3 1600Mhz 
Hard DriveOptical DriveCoolingOS
(2) WD Caviar Black 1TB HDD's Total 2TB Asus Multi DVD Drive Noctua DH-14 SKYNET Neural Net-Based Artificial Intelligence 
MonitorPowerCase
24" Asus VE248H 1920 x 1080 Antec TruePower Quattro 1200w HAF 932 
  hide details  
Reply
T-980X
(14 items)
 
  
CPUMotherboardGraphicsRAM
Cyberdyne Systems i7 980X Hexa Core @ 4.2Ghz Asus Rampage III Extreme Reference VTek 7970 @ 1150/1700 Stock Bios Stable 12GB Mushkin Blackline DDR3 1600Mhz 
Hard DriveOptical DriveCoolingOS
(2) WD Caviar Black 1TB HDD's Total 2TB Asus Multi DVD Drive Noctua DH-14 SKYNET Neural Net-Based Artificial Intelligence 
MonitorPowerCase
24" Asus VE248H 1920 x 1080 Antec TruePower Quattro 1200w HAF 932 
  hide details  
Reply
post #5 of 5
I'm kind of glad you posted this. I was about to RMA my MSI 7950 TF2

Mine is doing it with Windows Media Player (luckily I usually use VLC anyways)
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › 7970 screen flicker?