Overclock.net › Forums › Components › Monitors and Displays › Sceptre x22 problem, please help!
New Posts  All Forums:Forum Nav:

Sceptre x22 problem, please help!

post #1 of 4
Thread Starter 
I just bought this:

SCEPTRE x22wg-Gamer Black 22" 5ms DVI Widescreen HDMI LCD Monitor 300 cd/m2 1200:1 Built in Speakers - Retail

Got it from Newegg.

I'm using the monitor right now, but in 1280x1024 resolution. The native resolution on this monitor is 1680x1050. But when I try to set it to that resolution, the picture gets all screwed up. Green and red pixels everywhere, distortion, etc.

-I have the latest ATI drivers.
-I already installed the x22 drivers, and set it to the proper monitor in display properties.
-The refresh rate is set at 60hz, its default.
-I'm using a direct DVI connection.
-Both connections are tightly secured.

1440x900 is the highest resolution it will go to before I start getting the crazy red and green pixels everywhere. The second I go into 1680x1050, the picture is screwed up. The second I drop to a resolution lower than 1680x1050, the picture looks fine (except for the fact that it doesn't look optimal since it's not its native resolution)

Any ideas on what the problem could be or how to fix it? I called Sceptre tech support, but they only had an answering machine. It's that or e-mail, so I left a message. Still waiting to hear back from them.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
E6600 Intel Core 2 Duo @ 3.4ghz. Vcore 1.425 ASUS P5W64 WS PRO ASUS 5870 1GB V2 8GB G.SKILL DDR2 800 
Hard DriveOSMonitorKeyboard
2 74 gig WD RAPTOR RAID 0 / 1 Terrabyte ext. WD Windows 7 64-bit Home Premium LG L227WTG/Viewsonic VX910 LCD Generic 
PowerCaseMouse
OCZ GameXStream 750W Antec P180 Black Logitech G9 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
E6600 Intel Core 2 Duo @ 3.4ghz. Vcore 1.425 ASUS P5W64 WS PRO ASUS 5870 1GB V2 8GB G.SKILL DDR2 800 
Hard DriveOSMonitorKeyboard
2 74 gig WD RAPTOR RAID 0 / 1 Terrabyte ext. WD Windows 7 64-bit Home Premium LG L227WTG/Viewsonic VX910 LCD Generic 
PowerCaseMouse
OCZ GameXStream 750W Antec P180 Black Logitech G9 
  hide details  
Reply
post #2 of 4
Did the monitor come with any installation CD or anything?
My Rigasaurus-reX
(13 items)
 
  
CPUMotherboardGraphicsRAM
Toledo 3800 X2 E6 (CCBWE) DFI nF4 LanParty Ultra-D XFX 6800GS 500/1200 2x512MB OCZ Enhanced Latency 
Hard DriveOptical DriveOSMonitor
250GB WD-Caviar 16M 3GB/s NEC ND-3550A Windows XP Pro SP2 17in. ŁĊĐ 
KeyboardPowerCaseMouse
Logitech G11 Åntec TRUEPOWERII 550W ThermalTake Tsunami Logitech G7 Wireless 
Mouse Pad
SteelPad S&S 
  hide details  
Reply
My Rigasaurus-reX
(13 items)
 
  
CPUMotherboardGraphicsRAM
Toledo 3800 X2 E6 (CCBWE) DFI nF4 LanParty Ultra-D XFX 6800GS 500/1200 2x512MB OCZ Enhanced Latency 
Hard DriveOptical DriveOSMonitor
250GB WD-Caviar 16M 3GB/s NEC ND-3550A Windows XP Pro SP2 17in. ŁĊĐ 
KeyboardPowerCaseMouse
Logitech G11 Åntec TRUEPOWERII 550W ThermalTake Tsunami Logitech G7 Wireless 
Mouse Pad
SteelPad S&S 
  hide details  
Reply
post #3 of 4
Thread Starter 
Quote:
Originally Posted by JacKz5o View Post
Did the monitor come with any installation CD or anything?
No installation CD was included. I did, however, download the driver from the website, and made sure that it was setup properly in display properties.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
E6600 Intel Core 2 Duo @ 3.4ghz. Vcore 1.425 ASUS P5W64 WS PRO ASUS 5870 1GB V2 8GB G.SKILL DDR2 800 
Hard DriveOSMonitorKeyboard
2 74 gig WD RAPTOR RAID 0 / 1 Terrabyte ext. WD Windows 7 64-bit Home Premium LG L227WTG/Viewsonic VX910 LCD Generic 
PowerCaseMouse
OCZ GameXStream 750W Antec P180 Black Logitech G9 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
E6600 Intel Core 2 Duo @ 3.4ghz. Vcore 1.425 ASUS P5W64 WS PRO ASUS 5870 1GB V2 8GB G.SKILL DDR2 800 
Hard DriveOSMonitorKeyboard
2 74 gig WD RAPTOR RAID 0 / 1 Terrabyte ext. WD Windows 7 64-bit Home Premium LG L227WTG/Viewsonic VX910 LCD Generic 
PowerCaseMouse
OCZ GameXStream 750W Antec P180 Black Logitech G9 
  hide details  
Reply
post #4 of 4
Thread Starter 
Quote:
Originally Posted by kurtdh View Post
I just bought this:

SCEPTRE x22wg-Gamer Black 22" 5ms DVI Widescreen HDMI LCD Monitor 300 cd/m2 1200:1 Built in Speakers - Retail

Got it from Newegg.

I'm using the monitor right now, but in 1280x1024 resolution. The native resolution on this monitor is 1680x1050. But when I try to set it to that resolution, the picture gets all screwed up. Green and red pixels everywhere, distortion, etc.

-I have the latest ATI drivers.
-I already installed the x22 drivers, and set it to the proper monitor in display properties.
-The refresh rate is set at 60hz, its default.
-I'm using a direct DVI connection.
-Both connections are tightly secured.

1440x900 is the highest resolution it will go to before I start getting the crazy red and green pixels everywhere. The second I go into 1680x1050, the picture is screwed up. The second I drop to a resolution lower than 1680x1050, the picture looks fine (except for the fact that it doesn't look optimal since it's not its native resolution)

Any ideas on what the problem could be or how to fix it? I called Sceptre tech support, but they only had an answering machine. It's that or e-mail, so I left a message. Still waiting to hear back from them.
Found the problem. The included DVI cable was bad. I swapped DVI cables and everything works fine!
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
E6600 Intel Core 2 Duo @ 3.4ghz. Vcore 1.425 ASUS P5W64 WS PRO ASUS 5870 1GB V2 8GB G.SKILL DDR2 800 
Hard DriveOSMonitorKeyboard
2 74 gig WD RAPTOR RAID 0 / 1 Terrabyte ext. WD Windows 7 64-bit Home Premium LG L227WTG/Viewsonic VX910 LCD Generic 
PowerCaseMouse
OCZ GameXStream 750W Antec P180 Black Logitech G9 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
E6600 Intel Core 2 Duo @ 3.4ghz. Vcore 1.425 ASUS P5W64 WS PRO ASUS 5870 1GB V2 8GB G.SKILL DDR2 800 
Hard DriveOSMonitorKeyboard
2 74 gig WD RAPTOR RAID 0 / 1 Terrabyte ext. WD Windows 7 64-bit Home Premium LG L227WTG/Viewsonic VX910 LCD Generic 
PowerCaseMouse
OCZ GameXStream 750W Antec P180 Black Logitech G9 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › Sceptre x22 problem, please help!