Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › aptitude dist-upgrade dependency errors where apt-get seems to be fine
New Posts  All Forums:Forum Nav:

aptitude dist-upgrade dependency errors where apt-get seems to be fine

post #1 of 3
Thread Starter 
I'm trying to go from Wheezy to Jessie... I set up my sources.list and ran apt-get update. Now, when trying to run aptitude dist-upgrade, I get a crapload of dependency errors, which I sort of expected, but apt-get dist-upgrade seems to work fine (EDIT: by "seems to work fine" I mean that I get no dependency errors... none at all)... so now I'm wondering, is it safe to run apt-get dist-upgrade given that aptitude seems to think the system is going to implode if I update the system?
Edited by bomfunk - 8/2/13 at 7:07pm
post #2 of 3
tbh I only ever use apt-get.

However don't take that as advice in this senario, I don't know enough about debian to give a recommendation. However if you have ZFS / Btrfs on your root then I guess you could always snapshot then upgrade.
post #3 of 3
Thread Starter 
Sweet, I didn't even think of doing a snapshot (have a btrfs root)... I'll probably do that after the downloads are complete (throttled, will be done in a couple of days or so).
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › aptitude dist-upgrade dependency errors where apt-get seems to be fine