Overclock.net › Forums › Graphics Cards › AMD/ATI › Issue with DP links on 3x 1440P displays
New Posts  All Forums:Forum Nav:

Issue with DP links on 3x 1440P displays

post #1 of 3
Thread Starter 
So I just recently got 3 27" 1440P displays, and after a few badly timed computer crashes, I finally got everything hooked up to my 7970 and "working", but no matter what I try, I can't get all running at 1440P at once. I'm connecting one up directly via DL-DVI, and the other two are connected via active mini-dp to dl-dvi adapters. WHen I have just the two mini-dp ones connected, both will run at 1440P, but when I connect the third DVI, one of the mini-dp ones will drop to 1080P and catalyst will say there is a "link failure", and that it can't run at full resolution. It still correctly detects the monitor as 1440P, it just won't drive it at anything beyond 1080P.

Any idea how to solve this?
My System
(13 items)
 
  
CPUMotherboardGraphicsOS
i5-2500k Asus P8P67 480GTX Windows 7 Pro x64 
MonitorKeyboardCaseMouse
Dell U3011, Dell 2407 WFP Logitech g15 Antec 900 Logitech Peformance MX 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsOS
i5-2500k Asus P8P67 480GTX Windows 7 Pro x64 
MonitorKeyboardCaseMouse
Dell U3011, Dell 2407 WFP Logitech g15 Antec 900 Logitech Peformance MX 
  hide details  
Reply
post #2 of 3
Which adapters are you using?
post #3 of 3
Thread Starter 
Quote:
Originally Posted by simplec6 View Post

Which adapters are you using?

Monoprice mini-dp to dl-dvi.

I actually have solved the issue now, by installing the 13.8 catalyst beta drivers.
My System
(13 items)
 
  
CPUMotherboardGraphicsOS
i5-2500k Asus P8P67 480GTX Windows 7 Pro x64 
MonitorKeyboardCaseMouse
Dell U3011, Dell 2407 WFP Logitech g15 Antec 900 Logitech Peformance MX 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsOS
i5-2500k Asus P8P67 480GTX Windows 7 Pro x64 
MonitorKeyboardCaseMouse
Dell U3011, Dell 2407 WFP Logitech g15 Antec 900 Logitech Peformance MX 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Issue with DP links on 3x 1440P displays