Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › Windows 8 caching FTP transfers
New Posts  All Forums:Forum Nav:

Windows 8 caching FTP transfers

post #1 of 7
Thread Starter 
I have a problem with Windows caching FTP file transfers and not freeing up the memory after. so after a few big transfers, Windows shows me a pop up telling me to close programs to free up memory. I close everything, and my memory usage is still at 90%. you guys got any ideas how I can stop Windows from caching the transfer? or how to free up the cache after the transfer is finished?

I am using Windows 8 with Filezilla. I also tried WinSCP, same problem. I tracked down the problem after watching cache usage in resource monitor. If I pause the FTP transfer, cache usage stops going up, when I resume it goes up again.
Daily Workhorse
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 4670K MSI Z87-GD65 Asus GTX 660 DC2-OC  G.Skill RipjawsX 4x4GB 1600 
Hard DriveOptical DriveCoolingOS
OCZ Agility 60GB none Noctua NH-U12P Windows 8 
MonitorKeyboardPowerCase
Dell U2312HM CoolerMaster Quick Fire CMStorm Red Corsair 650HX Lian Li PC-K9WX 
MouseAudio
Logitech G400 Creative X-Fi HD USB 
  hide details  
Reply
Daily Workhorse
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 4670K MSI Z87-GD65 Asus GTX 660 DC2-OC  G.Skill RipjawsX 4x4GB 1600 
Hard DriveOptical DriveCoolingOS
OCZ Agility 60GB none Noctua NH-U12P Windows 8 
MonitorKeyboardPowerCase
Dell U2312HM CoolerMaster Quick Fire CMStorm Red Corsair 650HX Lian Li PC-K9WX 
MouseAudio
Logitech G400 Creative X-Fi HD USB 
  hide details  
Reply
post #2 of 7
How much physical RAM do you have in your system? Your system profile says 4x4GB - 16GB total? That should be PLENTY. The only quick and dirty reason I can see for why you might be getting the low memory message in Windows 8 would be if you turned off your page file. Never, ever, remove your page file completely. I'd recommend setting it to 2GB as an absolute minimum, regardless of how much physical RAM you might have.

It's completely normal for Windows to cache data that is written to disk, so that if you have to read it back - it doesn't have to read the disk to get it. If applications request more RAM, it should first come out of the "free" memory pile, and then when that is exhausted, it will come out of the "cached" memory pile. When both free and cached memory are exhausted, then you should get the "out of memory" message, or a warning to close applications.

It's important to keep in mind that memory that's flagged as "cached" is as good as being "available" as far as active applications are concerned. It's only being used for cache because Windows would rather use it to boost performance than to sit there unutilized.

Greg

p.s. Interesting tag line you have there. Keep in mind "IBM PC" is trademarked, and Apple specifically never uses the terminology "personal computer" when referring to a Mac. It's a branding thing, not a descriptive English thing. =)
Edited by hammong - 8/3/13 at 8:27pm
post #3 of 7
You can't, I've been down this road with Win7. You can not turn off or modify the caching at all, and if you can, I don't know how.

What you can do is download RAMMap and clear the "standby" memory after a while so that it becomes free. I notice no performance degradation from this, but I do notice a decrease in "low memory" messages.
post #4 of 7
This is not normal behavior. You must have something installed that messes with your ram.
post #5 of 7
Thread Starter 
Quote:
Originally Posted by hammong View Post

How much physical RAM do you have in your system? Your system profile says 4x4GB - 16GB total? That should be PLENTY. The only quick and dirty reason I can see for why you might be getting the low memory message in Windows 8 would be if you turned off your page file. Never, ever, remove your page file completely. I'd recommend setting it to 2GB as an absolute minimum, regardless of how much physical RAM you might have.

It's completely normal for Windows to cache data that is written to disk, so that if you have to read it back - it doesn't have to read the disk to get it. If applications request more RAM, it should first come out of the "free" memory pile, and then when that is exhausted, it will come out of the "cached" memory pile. When both free and cached memory are exhausted, then you should get the "out of memory" message, or a warning to close applications.

It's important to keep in mind that memory that's flagged as "cached" is as good as being "available" as far as active applications are concerned. It's only being used for cache because Windows would rather use it to boost performance than to sit there unutilized.

Greg

p.s. Interesting tag line you have there. Keep in mind "IBM PC" is trademarked, and Apple specifically never uses the terminology "personal computer" when referring to a Mac. It's a branding thing, not a descriptive English thing. =)

My paging file is set at 800MB, I currently have 12 GB memory installed. (I needed to RMA one stick.) but I figured 12 GB is still plenty like you said. so my paging file is not turned off, I am still getting this "out of memory" message.
Quote:
What you can do is download RAMMap and clear the "standby" memory after a while so that it becomes free. I notice no performance degradation from this, but I do notice a decrease in "low memory" messages.

thanks for the mention. i'll look up RAMMAP.
Quote:
Originally Posted by larsch View Post

This is not normal behavior. You must have something installed that messes with your ram.
I have RAMDisk installed, but I don't think that should matter? because I had RAMDisk installed previously on WIndows 7, and it didn't cause a problem.
Daily Workhorse
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 4670K MSI Z87-GD65 Asus GTX 660 DC2-OC  G.Skill RipjawsX 4x4GB 1600 
Hard DriveOptical DriveCoolingOS
OCZ Agility 60GB none Noctua NH-U12P Windows 8 
MonitorKeyboardPowerCase
Dell U2312HM CoolerMaster Quick Fire CMStorm Red Corsair 650HX Lian Li PC-K9WX 
MouseAudio
Logitech G400 Creative X-Fi HD USB 
  hide details  
Reply
Daily Workhorse
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 4670K MSI Z87-GD65 Asus GTX 660 DC2-OC  G.Skill RipjawsX 4x4GB 1600 
Hard DriveOptical DriveCoolingOS
OCZ Agility 60GB none Noctua NH-U12P Windows 8 
MonitorKeyboardPowerCase
Dell U2312HM CoolerMaster Quick Fire CMStorm Red Corsair 650HX Lian Li PC-K9WX 
MouseAudio
Logitech G400 Creative X-Fi HD USB 
  hide details  
Reply
post #6 of 7
Quote:
Originally Posted by Xiphos View Post

My paging file is set at 800MB, I currently have 12 GB memory installed. (I needed to RMA one stick.) but I figured 12 GB is still plenty like you said. so my paging file is not turned off, I am still getting this "out of memory" message.

Try bumping that 800 MB paging file up to 2-3GB and see what happens. In my original message when I said setting it to 2GB at a minimum was because you start running into page allocation issues if the page file isn't big enough to index your entire block of memory. On my system with 32GB of physical RAM, it requires 4GB to adequately index all memory. With 12 GB, you probably need 1.5GB as the minimum.

You have a RAM DISK? How big?

Greg
post #7 of 7
Thread Starter 
Ok, I am a fool and mixed up nonpaged memory pool and cached tongue.gif I had a nonpaged memory pool leak on Windows 8 and Killer E2200 NIC. I've since then fixed it.
Daily Workhorse
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 4670K MSI Z87-GD65 Asus GTX 660 DC2-OC  G.Skill RipjawsX 4x4GB 1600 
Hard DriveOptical DriveCoolingOS
OCZ Agility 60GB none Noctua NH-U12P Windows 8 
MonitorKeyboardPowerCase
Dell U2312HM CoolerMaster Quick Fire CMStorm Red Corsair 650HX Lian Li PC-K9WX 
MouseAudio
Logitech G400 Creative X-Fi HD USB 
  hide details  
Reply
Daily Workhorse
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 4670K MSI Z87-GD65 Asus GTX 660 DC2-OC  G.Skill RipjawsX 4x4GB 1600 
Hard DriveOptical DriveCoolingOS
OCZ Agility 60GB none Noctua NH-U12P Windows 8 
MonitorKeyboardPowerCase
Dell U2312HM CoolerMaster Quick Fire CMStorm Red Corsair 650HX Lian Li PC-K9WX 
MouseAudio
Logitech G400 Creative X-Fi HD USB 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Windows
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › Windows 8 caching FTP transfers