Overclock.net › Forums › Components › Hard Drives & Storage › SSD › troubles with ssd speed and drivers
New Posts  All Forums:Forum Nav:

troubles with ssd speed and drivers

post #1 of 5
Thread Starter 
so my ssd is operating on sata 2 3gbps on a sata 3 mobo.
i contacted samsung about it and they said:
It is possible that the issue comes from the Magician and not from the SSD itself. Please uninstall the AMD drivers from Disk management and reboot the PC: Windows will install its own drivers.

i think the support guy made a mistake because i didnt say i had any amd products, i only mentioned that i had asus motherboard.
anyway, i went into disk manger and uninstalled the ssd drivers and after 2 pc restarts nothing seemed to change so my next step is to uninstall the asus stuff but besides the programs on the driver disc i cant find where to uninstall the actual drivers.

how do i uninstall the asus drivers? and what do you guys make of this?
i will probably email back but asking here first is quicker smile.gif
1st DIY PC
(14 items)
 
  
CPUMotherboardGraphicsRAM
phenom ii 965 asus hd 5770 vapor x 4gb 
Hard DriveOptical DriveCoolingOS
1tb 1 dvd-rw noctua u12p windows 7 
MonitorKeyboardPowerCase
32in bush tv wireless antec coolermaster centurion 5ii 
  hide details  
Reply
1st DIY PC
(14 items)
 
  
CPUMotherboardGraphicsRAM
phenom ii 965 asus hd 5770 vapor x 4gb 
Hard DriveOptical DriveCoolingOS
1tb 1 dvd-rw noctua u12p windows 7 
MonitorKeyboardPowerCase
32in bush tv wireless antec coolermaster centurion 5ii 
  hide details  
Reply
post #2 of 5
Quote:
Originally Posted by elitestranger View Post

so my ssd is operating on sata 2 3gbps on a sata 3 mobo.

i will probably email back but asking here first is quicker smile.gif

What do you mean by "operating on sata 2?" Are you using the SSD via a plug into SATA 3? If so, what program is telling you that you are runing at SATA 2 speeds?
post #3 of 5
Thread Starter 
samsumg magician software tells me i dont have sata 3 and benchmarks show its only using 3gbps when top speed should be 550
1st DIY PC
(14 items)
 
  
CPUMotherboardGraphicsRAM
phenom ii 965 asus hd 5770 vapor x 4gb 
Hard DriveOptical DriveCoolingOS
1tb 1 dvd-rw noctua u12p windows 7 
MonitorKeyboardPowerCase
32in bush tv wireless antec coolermaster centurion 5ii 
  hide details  
Reply
1st DIY PC
(14 items)
 
  
CPUMotherboardGraphicsRAM
phenom ii 965 asus hd 5770 vapor x 4gb 
Hard DriveOptical DriveCoolingOS
1tb 1 dvd-rw noctua u12p windows 7 
MonitorKeyboardPowerCase
32in bush tv wireless antec coolermaster centurion 5ii 
  hide details  
Reply
post #4 of 5
Quote:
Originally Posted by elitestranger View Post

samsumg magician software tells me i dont have sata 3 and benchmarks show its only using 3gbps when top speed should be 550

If you have an AMD graphics card, the generic AMD drivers are installed with the graphics card. If you ever had an AMD product installed with the drivers, then those drivers may be causing that SATA 2 issue.

Use Driver Fusion to uninstall all the unnecessary drivers. Here is the product page: http://treexy.com/products/driver-fusion
Then run Windows Update to get the correct AHCI drivers.

Alternatively, you can do a fresh install of windows. If you do, look at this thread prior to doing so: here.

EDIT: Do you still have this ASUS motherboard? (ASUS M4A88TD-V EVO) You may need to go back to the motherboard's product page on ASUS to download the newest drivers.

You may have to update the firmware on your Samsung SSD, if it is available.
Edited by aznpersuazn - 8/6/13 at 6:28am
post #5 of 5
Quote:
Originally Posted by elitestranger View Post

so my ssd is operating on sata 2 3gbps on a sata 3 mobo.
i contacted samsung about it and they said:
It is possible that the issue comes from the Magician and not from the SSD itself. Please uninstall the AMD drivers from Disk management and reboot the PC: Windows will install its own drivers.

i think the support guy made a mistake because i didnt say i had any amd products, i only mentioned that i had asus motherboard.
anyway, i went into disk manger and uninstalled the ssd drivers and after 2 pc restarts nothing seemed to change so my next step is to uninstall the asus stuff but besides the programs on the driver disc i cant find where to uninstall the actual drivers.

how do i uninstall the asus drivers? and what do you guys make of this?
i will probably email back but asking here first is quicker smile.gif

I assume you are using the new Magician software, 4.0 or better?

It sounds like the Samsung support person knew exactly what was going on, and asked you to uninstall the AMD drivers on your AMD board, that's what is in your signature, an ASUS AMD CPU/Chipset board.

The Magician software is not compatible with all AMD chipsets, and switching to the MS AHCI driver was the goal of uninstalling the AMD drivers. The support person recognized the symptoms you described as those caused by AMD drivers and chipsets.

But it sounds like the OP uninstalled "the SSD drivers" under Disk Drives, and not the SATA Storage Controller driver. The AMD SATA controller's driver is the one they wanted you to uninstall.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: SSD
Overclock.net › Forums › Components › Hard Drives & Storage › SSD › troubles with ssd speed and drivers