Overclock.net › Forums › Components › Monitors and Displays › Benq xl2420t loses dvi signal randomly
New Posts  All Forums:Forum Nav:

Benq xl2420t loses dvi signal randomly

post #1 of 6
Thread Starter 
hi guys,

my monitor loses dvi signal at random times when i leave it while i am downloading or busy doing something else, i come back my pc and my monitor just stays black. if i touch a button the menu comes up and if i push dvi it says no signal detected?

it doesn't do this all the time and i have checked all cables are in. the only way i can get it to work and is to restart my pc.

any help please ?
post #2 of 6
I had an older Benq 24" monitor before they came out with the XL series that did the same thing. I called Benq and they RMA'ed it.

I now have an XL2410t and that issue has never returned.
post #3 of 6
Thread Starter 
I've managed to get a rma from benq but they are swapping it with a refurbished one. I hope i don't get a scratched one coz mine looks brand new
post #4 of 6
If you happen to get a refurb that is not to your liking (scratched, scuffed, light bleed, etc.) just call their RMA dept and complain enough they will send you a new unit.

I went through 3 refurbs all shipped next day AM delivery I might add before they just decided to give me a new unit.
post #5 of 6
Thread Starter 
cool thanks wink.gif
post #6 of 6
Thread Starter 
do you think it could be graphic driver related. i can`t get it to do it again it just happen randomly when i leave the pc, i think both times it happened i was downloading something with steam and left my pc running
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › Benq xl2420t loses dvi signal randomly