Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › Low FPS Issues with 7970
New Posts  All Forums:Forum Nav:

Low FPS Issues with 7970 - Page 4

post #31 of 42
Thread Starter 
Quote:
Originally Posted by szeged View Post

i believe the OP wants to just stock air cool his cards, but for other users, yes beware this card is not compatible with EK waterblocks however a universal waterblock will still fit, as long as you passive/air cool the other components on the card itll work thumb.gif
yeah I don't plan to do water cooling anytime soon except for CPU only water cooling. Eventually I will get to liquid cooling.
post #32 of 42
Thread Starter 
Ok everyone so I am having another issue, now that everything seems to be working fine I am still not getting good FPS in WoW. In any other game it seems fine but in WoW I am only getting around 30 fps in populated areas. I looked up some WoW benchmarks for the 7970 and I should be getting around 80 fps EASILY! I tried changing some of the settings that supposedly are a big FPS killer and it only changed by a couple FPS which tells me they aren't really effecting the card. Even turning all the settings down I only got 60 fps and it should have been much higher than that. I also tried disabling all add-ons and that didn't help either. I tried enabling and disabling vertical sync and tried making sure the game was full screen but nothing helped at all. Something else I noticed is that the card is only using about 47% power when I am playing wow, shouldn't it be using like 100%? And I know my nothing could be causing a bottleneck.
The low FPS on WoW was what made me post this post in the first place, after all the work I did today I finally realized that the drivers were working perfectly fine, I thought they weren't because of the low FPS in WoW and the fact that Crysis 3 and other games kept freezing. But now (after messing with OC for a few hours) I realized that Crysis 3 crashes when I push the card above about 1050MHz and I can't increase the voltage at all to make it more stable at the higher clock speeds. If I push it to 1100MHz it freezes Crysis 3 and the display drivers stop working momentarily.
So does anyone have any suggestions on the low FPS on Wow, should I try reinstalling WoW?
post #33 of 42
Thread Starter 
And I'm still getting major FPS issues with WoW, if I don't play it overnight then when I try to play in the morning I get around 16 FPS when normally I get around 30 which is still low for this card. Should I just reinstall WoW?
post #34 of 42
Thread Starter 
So it is the card, I am getting terrible FPS on Crysis 3 now as well, the drivers must still be the problem. It's weird because when I reinstall them they're fine for like 12 hours and then stop working. Also the graphics card seems to be stuck at around 15 fps which is also really weird. Someone please help!
post #35 of 42
It might be your cpu then if your 7970 is working fine. The 8350 doesnt do exceptionally well in mmos such as wow.
LEGION
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7 6700K ASUS Maximus VIII Impact EVGA GTX TITAN X G.skill 16gb 3200 ddr4 
Hard DriveHard DriveHard DriveCooling
Samsung 840 pro 250gb Samsung 840 evo 250gb Samsung 840 evo 250gb Ice kings magic. 
OSMonitorKeyboardPower
WIN 10 Wasabi Mango 42" 4k Corsair k70 EVGA 1000w P2 
CaseMouseAudio
Caselabs Mercury S3 Razer naga :( sennheiser HD 558 
  hide details  
Reply
LEGION
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7 6700K ASUS Maximus VIII Impact EVGA GTX TITAN X G.skill 16gb 3200 ddr4 
Hard DriveHard DriveHard DriveCooling
Samsung 840 pro 250gb Samsung 840 evo 250gb Samsung 840 evo 250gb Ice kings magic. 
OSMonitorKeyboardPower
WIN 10 Wasabi Mango 42" 4k Corsair k70 EVGA 1000w P2 
CaseMouseAudio
Caselabs Mercury S3 Razer naga :( sennheiser HD 558 
  hide details  
Reply
post #36 of 42
Thread Starter 
No because I still get good FPS when I reinstall the drivers but then after 12 hours they go bad again, it's like something is deleting my drivers or something.
post #37 of 42
Thread Starter 
I think I am just going to end up returning this card and buying another 660 ti,the benchmarks for that are amazing anyway. I only got this card because I am an AMD fan, but with all these issues its pointless so I might as well stick with NVidia for now.
post #38 of 42
For some reason I'm not thinking this is the gpu's fault.
LEGION
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7 6700K ASUS Maximus VIII Impact EVGA GTX TITAN X G.skill 16gb 3200 ddr4 
Hard DriveHard DriveHard DriveCooling
Samsung 840 pro 250gb Samsung 840 evo 250gb Samsung 840 evo 250gb Ice kings magic. 
OSMonitorKeyboardPower
WIN 10 Wasabi Mango 42" 4k Corsair k70 EVGA 1000w P2 
CaseMouseAudio
Caselabs Mercury S3 Razer naga :( sennheiser HD 558 
  hide details  
Reply
LEGION
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7 6700K ASUS Maximus VIII Impact EVGA GTX TITAN X G.skill 16gb 3200 ddr4 
Hard DriveHard DriveHard DriveCooling
Samsung 840 pro 250gb Samsung 840 evo 250gb Samsung 840 evo 250gb Ice kings magic. 
OSMonitorKeyboardPower
WIN 10 Wasabi Mango 42" 4k Corsair k70 EVGA 1000w P2 
CaseMouseAudio
Caselabs Mercury S3 Razer naga :( sennheiser HD 558 
  hide details  
Reply
post #39 of 42
Have you tried running Unigine?
Green Dragon
(19 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7 3930K ASrock Extreme4 X79 LGA 2011 EVGA GTX 780 6GB EVGA GTX 780 6GB 
RAMHard DriveHard DriveCooling
12GB (3x4) Samsung 2133 Mhz Sandisk SSD 500GB Samsung Spinpoint F3 Corsair H100 
OSMonitorMonitorMonitor
Windows 10 Professional 64-bit Acer G7 G237HLbi Acer G7 G237HLbi Acer G7 G237HLbi 
KeyboardPowerCaseMouse
Razer Black Widow Chroma Corsair HX 750 Lancool K62 Dragonlord Razer taipan 
AudioAudio
Creative Soundblaster Z Razer Krakeen 7.1 Chroma 
  hide details  
Reply
Green Dragon
(19 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7 3930K ASrock Extreme4 X79 LGA 2011 EVGA GTX 780 6GB EVGA GTX 780 6GB 
RAMHard DriveHard DriveCooling
12GB (3x4) Samsung 2133 Mhz Sandisk SSD 500GB Samsung Spinpoint F3 Corsair H100 
OSMonitorMonitorMonitor
Windows 10 Professional 64-bit Acer G7 G237HLbi Acer G7 G237HLbi Acer G7 G237HLbi 
KeyboardPowerCaseMouse
Razer Black Widow Chroma Corsair HX 750 Lancool K62 Dragonlord Razer taipan 
AudioAudio
Creative Soundblaster Z Razer Krakeen 7.1 Chroma 
  hide details  
Reply
post #40 of 42
Thread Starter 
Quote:
Originally Posted by szeged View Post

For some reason I'm not thinking this is the gpu's fault.
Well my 660 ti works fine, so either the GPU is defective or the drivers just hate my computer. I am no noob when it comes to computers and drivers, so posting on here was after I tried everything I could think of myself. Whatever is happening simply doesn't make any sense! I can no longer return the 7970 to Newegg though because I cut out and sent in the UPC barcode for the rebate already, I contacted XFX about it and I am waiting for a reply.
New Posts  All Forums:Forum Nav:
  Return Home
Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › Low FPS Issues with 7970