Overclock.net › Forums › Components › Power Supplies › Silverstone Strider PSU fan clicking sound, possible RMA
New Posts  All Forums:Forum Nav:

Silverstone Strider PSU fan clicking sound, possible RMA

post #1 of 2
Thread Starter 
So it's been a problem for almost 6 months now however it's been getting more and more severe.

When idle, the fan in my power supply produces a clicking sound. From what I've collected this fan is faulty in that it cannot be undervolted properly.

My problem is that I cannot afford to have my desktop turn into a brick if I was to RMA the power supply, and even if I do RMA it I'm afraid during transportation the movement will make the fan not produce a clicking pound until well into running idle for a few days.

I considered voiding my warranty and replacing the 135mm fan inside as a last resort.

Does anybody have any experience with a power supply RMA they'd like to share?

Thanks a lot
post #2 of 2
RMA'ing power supply's is a easy enough task but it can take upto a month to get sorted out.

Do you know anyone with a spare power supply kicking about?

The clicking could just be the bearings needing a little oil on them, if It was me I would just void the warranty and change the fan over but that would only be if the fan was really getting on my nerves (And I dont recommend you do it either unless your confident you know what your doing and your happy that if it breaks it does so under no fault of anyone else but your own.)

If you do RMA it ask them for a postage label otherwise you will find your self with a not very nice postage bill.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › Silverstone Strider PSU fan clicking sound, possible RMA