Overclock.net › Forums › Intel › Intel CPUs › just delidded my cpu and need help with thermal paste
New Posts  All Forums:Forum Nav:

just delidded my cpu and need help with thermal paste

post #1 of 3
Thread Starter 
hi i just (last day) delidded my cpu and cpu works perfectly but i have issues with thermal compound and temps
i am using hyper212 evo
my CPU and my overclock 3570k - 4.2Ghz -.1.176v -all power saving features enabled
i lapped the ihs once i delidded my cpu (around 800grid not sure)
i applied very thing layer of xigmatek PTI-G3606 on core die itself and spread it even all across the die
i also applied same paste on lapped ihs and spread it all over ihs (this is also thin but that as much i have done on core die itself) (using this technique )
once i put the hyper212 on the cpu i booted up and temps were way better compared to my old apply (i peaked 105c on 2 cores biggrin.gif while other 2 was chilling at 65c at ibt very high test ,now its 84c on hottest core)
the problem is my temps were not that different before i delidded i maxed around 90c what am i doing wrong?
post #2 of 3
Looks like way too much paste. On the die you don't even need half a rice grain. And between ihs and cooling block you only need about a grain's worth. It should spread on its own when you put the block on. Just a little spot and you should be golden.
post #3 of 3
Thread Starter 
changed thermal paste countless times now and YET the lowest i could get was 8 degree lower than my pre delid results i am getting sick and tired of this:mad:mad.gif ,i am going for h80i direct die cooling cooling soon im just gonna deal with these temps yet im sure they will get lower by time
i cant get good thermal paste here if i had mx4 or liquid pro im sure i would have atleast 15c difference
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel CPUs
Overclock.net › Forums › Intel › Intel CPUs › just delidded my cpu and need help with thermal paste