Overclock.net › Forums › Graphics Cards › NVIDIA › SLI screen flicker and Artifacts
New Posts  All Forums:Forum Nav:

SLI screen flicker and Artifacts

post #1 of 2
Thread Starter 
Hi there

First let me post my system specs

i5-2500k
2x MSI geforce GTX570 Twin Frozr III power edition
Sound Blaster z Sound card
MSI z77a-G45 thunderbolt motherboard
Corsair AX850w PSU
Cooler master Sniper case with the front HDD cage removed for better airflow
Qnix QX2710 @ 60HZ/59Hz Whatever stock is.


So I have my cards on stock clocks when connected to dual link DVI port on the monitor. When i run both in SLI I get eiter Screen flicker or artifacts in my games only.

What i have tried
1. Changed SLi bridge (The flexible kind)
2. Changed to another SLi connector on the card
3. Swapped cards arround
4. I took out one card and then it works fine no flicker etc etc. (Tested both that way)
5. Tried a different DVI dual link cable
6. Tried different drivers from 320.xx up to latest beta drivers.
7. Tried other DVI connections on cards
8. Connecting to old 1080p monitor only with same cable and let the GPU do the scaling and everything is fine.

So as you can see I almost tried everything there is to test. Can anyone suggest me what I should do. Funny thing is when tested on my old 1080p monitor as I can remember everything was fine until I switched to my new monitor. Bare in mind there is no scaler so GPU is doing the scaling. I also ran the following and was fine untill I go into a game especially Planetside 2 and far cry 3, BF3 also crashes some times. Was playing BF3 one night and my screen went off then on again.

http://www.testufo.com/#test=framerates
Main Gaming RIG
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-4790k ASUS VII Ranger Galax hof gtx 980 ti 16GB 1600mhz adata ram 
Hard DriveHard DriveHard DriveCooling
128GB SSD Samsung 840 evo 1TB WD blue Liteon 256GB SSD Phanteks PH-TC14PE 
OSMonitorKeyboardPower
Windows 8.1 ASUS PG279Q Cooler master Quickfire XT Corsair AX850w 
CaseMouseMouse PadAudio
Corsair Air carbide 540 Steelseries Ikari Laser Steelsereies QCK+ sound Blaster Z 
Audio
Sennheiser HD 598 
  hide details  
Reply
Main Gaming RIG
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-4790k ASUS VII Ranger Galax hof gtx 980 ti 16GB 1600mhz adata ram 
Hard DriveHard DriveHard DriveCooling
128GB SSD Samsung 840 evo 1TB WD blue Liteon 256GB SSD Phanteks PH-TC14PE 
OSMonitorKeyboardPower
Windows 8.1 ASUS PG279Q Cooler master Quickfire XT Corsair AX850w 
CaseMouseMouse PadAudio
Corsair Air carbide 540 Steelseries Ikari Laser Steelsereies QCK+ sound Blaster Z 
Audio
Sennheiser HD 598 
  hide details  
Reply
post #2 of 2
Thread Starter 
This is my issue http://www.youtube.com/watch?v=lMGeQj0jhBM
Main Gaming RIG
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-4790k ASUS VII Ranger Galax hof gtx 980 ti 16GB 1600mhz adata ram 
Hard DriveHard DriveHard DriveCooling
128GB SSD Samsung 840 evo 1TB WD blue Liteon 256GB SSD Phanteks PH-TC14PE 
OSMonitorKeyboardPower
Windows 8.1 ASUS PG279Q Cooler master Quickfire XT Corsair AX850w 
CaseMouseMouse PadAudio
Corsair Air carbide 540 Steelseries Ikari Laser Steelsereies QCK+ sound Blaster Z 
Audio
Sennheiser HD 598 
  hide details  
Reply
Main Gaming RIG
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-4790k ASUS VII Ranger Galax hof gtx 980 ti 16GB 1600mhz adata ram 
Hard DriveHard DriveHard DriveCooling
128GB SSD Samsung 840 evo 1TB WD blue Liteon 256GB SSD Phanteks PH-TC14PE 
OSMonitorKeyboardPower
Windows 8.1 ASUS PG279Q Cooler master Quickfire XT Corsair AX850w 
CaseMouseMouse PadAudio
Corsair Air carbide 540 Steelseries Ikari Laser Steelsereies QCK+ sound Blaster Z 
Audio
Sennheiser HD 598 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › SLI screen flicker and Artifacts