Overclock.net › Forums › Graphics Cards › NVIDIA › GTX 760 BAD FPS BF3.
New Posts  All Forums:Forum Nav:

GTX 760 BAD FPS BF3.

post #1 of 9
Thread Starter 
Hey guys, I need some help.
So an hour ago I was playing BF3.
Capture The Flag, all on ultra, 1366x768 since my monitor is ****.
FPS is from 70 to 200, never drops under 60.

Now something is wrong.
Playing CTF and my FPS is about 50-90, mostly 50-60.
I don't know what happened.
I installed AMD Chipset and that's when it happened.
I removed it and I still have this lower fps than I should have issue.
Tried OCing the GPU, same..
Specs:
GTX 760 Gigabyte
AMD FX-8320 @ 4.2 GHz
1TB HDD
8GB 1600MHZ RAM
650W PSU
post #2 of 9
in b4 switch to Intel brah

Reinstall Nvidia driver and report back.
    
CPUMotherboardGraphicsRAM
3930k 4.7 1.368v RIVE BIOS 2105 680L 1330/7011 16GB Samsung 2133Mhz  
Hard DriveCoolingOSMonitor
Crucial M4 240GB  H110 after 4x H220 RMA Win 8.1 64bit XL2420T Lightboost  
KeyboardPowerCaseMouse
SS 6Gv2  EVGA 1300G2  Arc Midi R2 Zowie AM, many opticals 
Mouse PadAudioAudioAudio
SS QCK+ Xonar Essence STX AK100 MKII Shure SE846  
AudioAudioOther
Ultrasone Pro 900 Sennheiser HD700 Intel EXPI9301CT NIC 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
3930k 4.7 1.368v RIVE BIOS 2105 680L 1330/7011 16GB Samsung 2133Mhz  
Hard DriveCoolingOSMonitor
Crucial M4 240GB  H110 after 4x H220 RMA Win 8.1 64bit XL2420T Lightboost  
KeyboardPowerCaseMouse
SS 6Gv2  EVGA 1300G2  Arc Midi R2 Zowie AM, many opticals 
Mouse PadAudioAudioAudio
SS QCK+ Xonar Essence STX AK100 MKII Shure SE846  
AudioAudioOther
Ultrasone Pro 900 Sennheiser HD700 Intel EXPI9301CT NIC 
  hide details  
Reply
post #3 of 9
Quote:
Originally Posted by Supriver View Post

Hey guys, I need some help.
So an hour ago I was playing BF3.
Capture The Flag, all on ultra, 1366x768 since my monitor is ****.
FPS is from 70 to 200, never drops under 60.

Now something is wrong.
Playing CTF and my FPS is about 50-90, mostly 50-60.
I don't know what happened.
I installed AMD Chipset and that's when it happened.
I removed it and I still have this lower fps than I should have issue.
Tried OCing the GPU, same..
Specs:
GTX 760 Gigabyte
AMD FX-8320 @ 4.2 GHz
1TB HDD
8GB 1600MHZ RAM
650W PSU

It can be 1 of 2 things:
1) the map you were playing had 64 players (which would limit your FPS because of CPU bottleneck, especially at lower resolutions)
2) something from the amd catalyst chipset drivers is conflicting with your nvidia drivers. Better run your pc on safe mode (or use a driver sweeper) and wipe AMD drivers and nvidia ones and reinstall nvidia ones and try again.
Still 50 fps and up is very playable. Of course that at that resolution it should be more.
You should be wary that if you upgrade your monitor to at least 1080p you will have a serious FPS decrease.
Also, there's a couple of AMD patches (for the CPU) for windows out there that increase your CPU performance quite a bit.
Edited by pokerapar88 - 8/23/13 at 1:58pm
post #4 of 9
Thread Starter 
Quote:
Originally Posted by pokerapar88 View Post

It can be 1 of 2 things:
1) the map you were playing had 64 players (which would limit your FPS because of CPU bottleneck, especially at lower resolutions)
2) something from the amd catalyst chipset drivers is conflicting with your nvidia drivers. Better run your pc on safe mode (or use a driver sweeper) and wipe AMD drivers and nvidia ones and reinstall nvidia ones and try again.
Still 50 fps and up is very playable. Of course that at that resolution it should be more.
You should be wary that if you upgrade your monitor to at least 1080p you will have a serious FPS decrease.
I know about the FPS decrease.
It will still be about 60.
I will remove my NVIDIA drivers now.
Why should I do it in safe mode?
I can't find the tutorial how to remove old nvidia drivers.
I know you just cant install new ones over them.
I hope this will fix.

An no, this wasnt because of 64 players. I've played on 64 player server and 60+ fps.
It was on all servers.
post #5 of 9
Thread Starter 
Removing old drivers and updating to the 20th of August beta drivers didn't fix it.
In TDM its very playable, only sometimes at 50 but in conquest etc..
And at this resolution. :O
Why the hell does it drop?
I didn't do anything lol..
post #6 of 9
Thread Starter 
Used driver sweeper to remove any AMD registry and that improved FPS a bit but still not as good as it was before.
post #7 of 9
Thread Starter 
Just installed a new copy of windows.
Going to test Battlefield and other games in a bit.
Also testing Valley Benchmark.
Hope this did the job.
post #8 of 9
wow.
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 4770K @ 4.7ghz Gigabyte Z87X-UD4H EVGA GTX 980TI ACX 2.0  8GB G.Skill Trident X 2400 mhz 
Hard DriveHard DriveHard DriveCooling
Samsung 830 SSD 128GB 3TB Toshiba  3TB Toshiba Custom Water 
OSMonitorPowerCase
Window 7 Ultimate 64 bit HP 23xi Corsair HX750i Phanteks Enthoo Luxe 
Mouse
Logitech G600 
  hide details  
Reply
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 4770K @ 4.7ghz Gigabyte Z87X-UD4H EVGA GTX 980TI ACX 2.0  8GB G.Skill Trident X 2400 mhz 
Hard DriveHard DriveHard DriveCooling
Samsung 830 SSD 128GB 3TB Toshiba  3TB Toshiba Custom Water 
OSMonitorPowerCase
Window 7 Ultimate 64 bit HP 23xi Corsair HX750i Phanteks Enthoo Luxe 
Mouse
Logitech G600 
  hide details  
Reply
post #9 of 9
Thread Starter 
Quote:
Originally Posted by PureBlackFire View Post

wow.
'
Hey.
Wow?
I solved this!
I reinstalled my Windows and my FPS is good again.
What could have been wrong?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › GTX 760 BAD FPS BF3.