post #1 of 1
Thread Starter 
Just installed my ASRock Z77 OC Formula Mobo, i7 3770k CPU, with the Kingston HyperX Beast 2400 2x8GB.
I specifically checked the ASRock website to ensure the Kingston memory was compatible.

Everything booted up okay, but there is no option in the bios to set my memory to 2400Mhz. The max option is DDR 1600Mhz.
There are no XMP Profiles to select as I have seen in youtube videos. Its just not there.

It's funny though, in the "Dram timing configuration", it lists the JEDEC and XMP timing settings.
I tried the dual channel in both slots, and single memory in all slots. Still nothing. Don't get the option to go over 1600Mhz.

So i did some research and concluded that if I update my Bios through the Bios Internet Flash it would fix any issues.
So it updated from version 1.80 to 2.30 successfully.

Still no XMP Profiles to select, can't go over 1600Mhz, and NOW Nich Shih's OC Profiles are missing from the top!!!

I contacted ASRock, but I wont hear anything until at least Monday.

Does anyone have any ideas of how to go about fixing this issue. This totally wrecked my entire weekend.

Thanks in advance.