Overclock.net › Forums › Software, Programming and Coding › Other Software › Firefox freezes when loading
New Posts  All Forums:Forum Nav:

Firefox freezes when loading

post #1 of 4
Thread Starter 
I guess this is the right spot for this?

If I open a link in a new tab and less commonly in the same tab, it will freeze Firefox for 15-30 seconds before recovering, most often if it needs to search a database or connect to a new server. Not always, but it happens often enough to be extremely irritating, especially if it has a number of scripts or media (despite Flashblock and NoScript disabling most of that) in use. I think it's cause by trying to render a page while I'm interacting with the one I'm on, like scrolling. CPU usage doesn't suddenly spike either and other applications keep going. This has only started up recently - within the last week or so. Does anybody else have this problem? I'd try Opera or IE, but their add-on libraries suck. I'd try Chrome, but it sucks up resources and I don't really trust Google. Do Firefox extensions work in, say, Waterfox? If they do, then I'll give it a shot.
Triumvirate
(20 items)
 
Osmium
(8 items)
 
EleMINT 24
(8 items)
 
CPUMotherboardGraphicsGraphics
Xeon E3-1226 v3 ASRock Z97M OC Formula Sapphire RX 480 (reference) MSI Low-Profile 750Ti 
RAMRAMHard DriveHard Drive
Kingston Blu Red - 2x4GB ADATA XPG - 2x4GB Crucial M500 960GB Samsung 840 250GB 
Hard DriveCoolingCoolingCooling
WD Scorpio Blue 1TB Cooler Master 212+ PNY Quadro 600 blower Corsair H55 + Kraken G10 
OSMonitorMonitorKeyboard
Windows 10 Pro ASUS VE247H - 1080p Gateway FPD1960 - 1280x1024 Rosewill RK9000I - Cherry MX Blue 
PowerCaseMouseOther
Rosewill HIVE 650W Fractal Design Arc Mini R2 Razer DeathAdder 2013 CyberPower 1500PFCLCD 
CPUMotherboardRAMHard Drive
AMD A10-7870K ASRock FM2A88X-ITX+ G.Skill Ripjaws X - 2x4GB @ 2400MT/s Samsung 840 120GB 
CoolingOSPowerCase
Evercool EC-HPS-810CP Windows 7 Pro 64-bit PicoPSU-120-WI-25 Mini-Box M350 
CPUMotherboardGraphicsRAM
Intel i3-4005U OEM Intel HD 4200 4GB DDR3 (soldered) 
Hard DriveOSMonitorPower
MyDigitalSSD Super Boot Eco 120GB Linux Mint 17.1 Cinnamon 1366x768 TN panel :'( brick 
  hide details  
Reply
Triumvirate
(20 items)
 
Osmium
(8 items)
 
EleMINT 24
(8 items)
 
CPUMotherboardGraphicsGraphics
Xeon E3-1226 v3 ASRock Z97M OC Formula Sapphire RX 480 (reference) MSI Low-Profile 750Ti 
RAMRAMHard DriveHard Drive
Kingston Blu Red - 2x4GB ADATA XPG - 2x4GB Crucial M500 960GB Samsung 840 250GB 
Hard DriveCoolingCoolingCooling
WD Scorpio Blue 1TB Cooler Master 212+ PNY Quadro 600 blower Corsair H55 + Kraken G10 
OSMonitorMonitorKeyboard
Windows 10 Pro ASUS VE247H - 1080p Gateway FPD1960 - 1280x1024 Rosewill RK9000I - Cherry MX Blue 
PowerCaseMouseOther
Rosewill HIVE 650W Fractal Design Arc Mini R2 Razer DeathAdder 2013 CyberPower 1500PFCLCD 
CPUMotherboardRAMHard Drive
AMD A10-7870K ASRock FM2A88X-ITX+ G.Skill Ripjaws X - 2x4GB @ 2400MT/s Samsung 840 120GB 
CoolingOSPowerCase
Evercool EC-HPS-810CP Windows 7 Pro 64-bit PicoPSU-120-WI-25 Mini-Box M350 
CPUMotherboardGraphicsRAM
Intel i3-4005U OEM Intel HD 4200 4GB DDR3 (soldered) 
Hard DriveOSMonitorPower
MyDigitalSSD Super Boot Eco 120GB Linux Mint 17.1 Cinnamon 1366x768 TN panel :'( brick 
  hide details  
Reply
post #2 of 4
Have you tried disabling your extensions and seeing if it still happens? If so have you then tried reinstalling Firefox?

Just make sure you don't have any mysterious extensions running. If there is nothing in Firefox and you have reinstalled, then it may be some other problem with your computer or operating system.
Pell
(4 items)
 
  
CPUMotherboardGraphicsOS
Qualcomm APQ8064 Xperia Tablet Z Adreno 320 Android 4.3 
  hide details  
Reply
Pell
(4 items)
 
  
CPUMotherboardGraphicsOS
Qualcomm APQ8064 Xperia Tablet Z Adreno 320 Android 4.3 
  hide details  
Reply
post #3 of 4
Thread Starter 
So I just restarted and reloaded fifteen tabs. Laggy? Yes. Crashy? No. The Internet connection has gotten somewhat crappy recently because TWC and/or the Apple router suck(s) though. The only extensions I have work just fine on my laptop with a third the cores, half the gigahertz, and probably fewer IPCs than piledriver. I've removed Collusion, DoNotTrackMe, and DuckDuckGo Plus (Team Ixquick!). Collusion was really lagging when rendering the data trails, so that may be part of the issue, especially since almost-crashing is most common on news and shopping sites.

EDIT: Oh yeah, it's the websites' faults. I got NoScript in the first place because trying to load more than three news stories at once would cause crashes. Now it's gotten bad enough that one will. Screw this Web 2.0 crap. I want content, not Facebook and autoloading videos and ads. Maybe you wouldn't need ads to pay for your site if your videos didn't suck up all the bandwidth?
Edited by CynicalUnicorn - 9/2/13 at 9:13am
Triumvirate
(20 items)
 
Osmium
(8 items)
 
EleMINT 24
(8 items)
 
CPUMotherboardGraphicsGraphics
Xeon E3-1226 v3 ASRock Z97M OC Formula Sapphire RX 480 (reference) MSI Low-Profile 750Ti 
RAMRAMHard DriveHard Drive
Kingston Blu Red - 2x4GB ADATA XPG - 2x4GB Crucial M500 960GB Samsung 840 250GB 
Hard DriveCoolingCoolingCooling
WD Scorpio Blue 1TB Cooler Master 212+ PNY Quadro 600 blower Corsair H55 + Kraken G10 
OSMonitorMonitorKeyboard
Windows 10 Pro ASUS VE247H - 1080p Gateway FPD1960 - 1280x1024 Rosewill RK9000I - Cherry MX Blue 
PowerCaseMouseOther
Rosewill HIVE 650W Fractal Design Arc Mini R2 Razer DeathAdder 2013 CyberPower 1500PFCLCD 
CPUMotherboardRAMHard Drive
AMD A10-7870K ASRock FM2A88X-ITX+ G.Skill Ripjaws X - 2x4GB @ 2400MT/s Samsung 840 120GB 
CoolingOSPowerCase
Evercool EC-HPS-810CP Windows 7 Pro 64-bit PicoPSU-120-WI-25 Mini-Box M350 
CPUMotherboardGraphicsRAM
Intel i3-4005U OEM Intel HD 4200 4GB DDR3 (soldered) 
Hard DriveOSMonitorPower
MyDigitalSSD Super Boot Eco 120GB Linux Mint 17.1 Cinnamon 1366x768 TN panel :'( brick 
  hide details  
Reply
Triumvirate
(20 items)
 
Osmium
(8 items)
 
EleMINT 24
(8 items)
 
CPUMotherboardGraphicsGraphics
Xeon E3-1226 v3 ASRock Z97M OC Formula Sapphire RX 480 (reference) MSI Low-Profile 750Ti 
RAMRAMHard DriveHard Drive
Kingston Blu Red - 2x4GB ADATA XPG - 2x4GB Crucial M500 960GB Samsung 840 250GB 
Hard DriveCoolingCoolingCooling
WD Scorpio Blue 1TB Cooler Master 212+ PNY Quadro 600 blower Corsair H55 + Kraken G10 
OSMonitorMonitorKeyboard
Windows 10 Pro ASUS VE247H - 1080p Gateway FPD1960 - 1280x1024 Rosewill RK9000I - Cherry MX Blue 
PowerCaseMouseOther
Rosewill HIVE 650W Fractal Design Arc Mini R2 Razer DeathAdder 2013 CyberPower 1500PFCLCD 
CPUMotherboardRAMHard Drive
AMD A10-7870K ASRock FM2A88X-ITX+ G.Skill Ripjaws X - 2x4GB @ 2400MT/s Samsung 840 120GB 
CoolingOSPowerCase
Evercool EC-HPS-810CP Windows 7 Pro 64-bit PicoPSU-120-WI-25 Mini-Box M350 
CPUMotherboardGraphicsRAM
Intel i3-4005U OEM Intel HD 4200 4GB DDR3 (soldered) 
Hard DriveOSMonitorPower
MyDigitalSSD Super Boot Eco 120GB Linux Mint 17.1 Cinnamon 1366x768 TN panel :'( brick 
  hide details  
Reply
post #4 of 4
All the alt. Mozilla browsers still use the default Firefox profiles (and any corruption that may be there), except Pale Moon, test with that: http://www.palemoon.org/

All those privacy tools may be overloading the browser; try using hpHosts or MVPhost (install and control it via HostsMan is easiest: http://www.abelhadigital.com/) for System-wide blocking and add fewer privacy tools to each browser.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Other Software
Overclock.net › Forums › Software, Programming and Coding › Other Software › Firefox freezes when loading