post #1 of 1
Thread Starter 
Hey guys,

I just built a light gaming computer for a friend. Everything went fine up until after I installed Windows. I'm using 4GB of ram, but Windows detected 2GB (1.45 usable).

However, CPU-Z does detect 4GB, but says that it's running single channel.

Speccy also reports the same:

So, thinking the RAM might be faulty, I plugged my Corsair Vengeance (2x8GB) into the slots, and same thing, Windows only detected half. Next, I tried trial and error. I plugged each ram into each slot. No matter which RAM I plugged in, I would get a black screen if I had only one stick plugged into the right slot. Left slot and both slots used worked normally, except sometimes Windows would freeze and look like this:

Never had that problem when I plugged in my RAM, so I'm guessing this is due to the system memory being really low?

Maximum memory isn't checked in Msconfig, there's only two RAM slots on my motherboard and both RAM sticks are seated properly.

Is it possible for one RAM slot to be faulty? That would be my first guess, but CPU-Z and Speccy both detect both RAM, so my other guess is something which I don't even is actually real. I don't really know AMD processors too well, but my other guess was that since this is an APU, the integrated gpu needs to use the RAM as much as the CPU does. So is it possible that one slot is allocated for the CPU, and other is allocated for the GPU (like VRAM) which is used by the GPU only and the system can't even detect it? That's my only guess, but I don't even know if that's actually a thing.

Any ideas?

Specs are:
A10 6800k
Crucial Ballistix Sport 4GB (2x2GB) DDR3 1600, but I'm temporarily using this until my new RAM gets here (Kingston HyperX 2x2GB DDR3 1866)
Samsung 840 Series 120gb
Corsair CX430M PSU
Windows 7 Professional 64 bit

Appreciate all the help you can offer, thanks.
Edited by apav - 9/4/13 at 1:10pm