Overclock.net › Forums › Software, Programming and Coding › Networking & Security › DHCP server is not passing through 2nd router
New Posts  All Forums:Forum Nav:

DHCP server is not passing through 2nd router

post #1 of 9
Thread Starter 
maybe not the best title but it should reflect my level of knowledge of the subject.
i have 2 Routers connected through LAN interface, one (Huawei) is coneected to the ADSL with DHCP on, the other (USRobotics) is working as a hotspot with DHCP off and nothing connected beside the LAN cable.

whenever i connect to the USRobitics, the devise end up with the wrong IP ,DNS and gatway (nothing from theDHCP range). and when i set them manullay i still cant get internet, but i can access other devices on the network that are connected to Huawei and his setup page itself.

more details:
The (USR) was my main router untill i swapped it for Huwawei, the only use i found for the USR was to use it as a hotspot to extend my wireless area coverage. i connected it through the LAN interface without changing any settings (DHCP was on), and it worked but i turned off later after i read about it online.
about a month ago i had internet problems and had to reset my Huawei to default, and thats when i first noticed my USR wireless is not working (not the same day, but somewhere after that event)

i dont understand all the settings but i try changing some of them and nothing works :\

here are screens from both setup pages maybe you can see something i cant see



thanks in advance.
Edited by agent__551 - 9/23/13 at 5:07am
OLD MAN
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon II x2 Gigabyte GA78LM-S2 radeon 7850 4GB 
Hard DriveCoolingOSMonitor
OCZ Vertex2 CM Hyper 212+ Win7 LG 19" WS + 42" HDTV 
PowerCaseAudio
Antec EA650 CM Scout Asus Xonar DG 
  hide details  
Reply
OLD MAN
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon II x2 Gigabyte GA78LM-S2 radeon 7850 4GB 
Hard DriveCoolingOSMonitor
OCZ Vertex2 CM Hyper 212+ Win7 LG 19" WS + 42" HDTV 
PowerCaseAudio
Antec EA650 CM Scout Asus Xonar DG 
  hide details  
Reply
post #2 of 9
If you have to specify a DHCP server for your 2nd router, make sure it is the address of your 1st. In your 2nd picture (2nd router's settings), you have the DHCP server set to 192.168.1.244, it looks like. Try setting that to 192.168.1.1 (your 1st router's address.)

Also, you may have to specify your 1st router as the "gateway" to the 2nd in some other settings menu.
post #3 of 9
i have my pfsense box as 192.168.0.1 and my wireless router as 192.168.0.2, you have the same sorta network i do...

why don't you try setting the dhcp server range to 192.168.1.100-192.168.1.254? and set your wireless router to 192.168.1.2

do you plan of having 250+ devices on your network?
Edited by Master__Shake - 9/8/13 at 8:32pm
Gaming Rig
(17 items)
 
File Server
(13 items)
 
 
CPUMotherboardGraphicsGraphics
Core i7 4790K ASUS Z97-WS Gigabyte GeForce GTX 980 Gigabyte GeForce GTX 980 
RAMHard DriveHard DriveCooling
16 Gb's Mushkin DDR3 @ 1600 MHz Crucial M500 SSD 240gb 4 Seagate Cheetah 15.7 15k rpm 300Gb Drives in... Coolit ECO C240 
OSMonitorMonitorPower
Windows 7 Ultimate ASUS PB287Q 4K Monitor HTC Vive Coolermaster Silent Pro M 1000W 
CaseMouseMouse PadAudio
Rosewill Blackhawk Ultra Razer Deathadder 2013 Steelseries Qck Mass Super Thick Cloth Mouse Pad Genius SW-G2.1 1250 4PC Gaming Speakers 
Other
Dell PERC H310 
CPUMotherboardRAMHard Drive
Core i3 2120 Supermicro X9SCM-F 4 Gb Kingston 1600mhz DDR3 ECC 12 Segate 2tb drives (RAID 6) 
Hard DriveHard DriveOSPower
ADATA SP600 SSD 24 Toshiba DT01ACA200 drives (2 RAID 6's) Windows 7 Ultimate 64 bit. OCZ ZT750 Supermicro PWS-665-PQ 
CaseOtherOtherOther
Norco 4020 and Norco 4224 LSI 9260-4i Raid Card Intel RES2SV240 20 port Expander. HP SAS 24 por... Voltaire 410Ex Hca Infiniband HBA 
  hide details  
Reply
Gaming Rig
(17 items)
 
File Server
(13 items)
 
 
CPUMotherboardGraphicsGraphics
Core i7 4790K ASUS Z97-WS Gigabyte GeForce GTX 980 Gigabyte GeForce GTX 980 
RAMHard DriveHard DriveCooling
16 Gb's Mushkin DDR3 @ 1600 MHz Crucial M500 SSD 240gb 4 Seagate Cheetah 15.7 15k rpm 300Gb Drives in... Coolit ECO C240 
OSMonitorMonitorPower
Windows 7 Ultimate ASUS PB287Q 4K Monitor HTC Vive Coolermaster Silent Pro M 1000W 
CaseMouseMouse PadAudio
Rosewill Blackhawk Ultra Razer Deathadder 2013 Steelseries Qck Mass Super Thick Cloth Mouse Pad Genius SW-G2.1 1250 4PC Gaming Speakers 
Other
Dell PERC H310 
CPUMotherboardRAMHard Drive
Core i3 2120 Supermicro X9SCM-F 4 Gb Kingston 1600mhz DDR3 ECC 12 Segate 2tb drives (RAID 6) 
Hard DriveHard DriveOSPower
ADATA SP600 SSD 24 Toshiba DT01ACA200 drives (2 RAID 6's) Windows 7 Ultimate 64 bit. OCZ ZT750 Supermicro PWS-665-PQ 
CaseOtherOtherOther
Norco 4020 and Norco 4224 LSI 9260-4i Raid Card Intel RES2SV240 20 port Expander. HP SAS 24 por... Voltaire 410Ex Hca Infiniband HBA 
  hide details  
Reply
post #4 of 9
Thread Starter 
Quote:
Originally Posted by The Hundred Gunner View Post

If you have to specify a DHCP server for your 2nd router, make sure it is the address of your 1st. In your 2nd picture (2nd router's settings), you have the DHCP server set to 192.168.1.244, it looks like. Try setting that to 192.168.1.1 (your 1st router's address.)

Also, you may have to specify your 1st router as the "gateway" to the 2nd in some other settings menu.

setting the 2nd router DHCP to 192.168.1.1 only make its address into the same as the 1st one
and i did make the 1st as the gateway in the 2nd settings, still nothing
Quote:
Originally Posted by Master__Shake View Post

i have my pfsense box as 192.168.0.1 and my wireless router as 192.168.0.2, you have the same sorta network i do...

why don't you try setting the dhcp server range to 192.168.1.100-192.168.1.254? and set your wireless router to 192.168.1.2

do you plan of having 250+ devices on your network?

i max at 20 i think, mobiles and tablets mostly, changing the DHCP ranges between them didnt help
OLD MAN
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon II x2 Gigabyte GA78LM-S2 radeon 7850 4GB 
Hard DriveCoolingOSMonitor
OCZ Vertex2 CM Hyper 212+ Win7 LG 19" WS + 42" HDTV 
PowerCaseAudio
Antec EA650 CM Scout Asus Xonar DG 
  hide details  
Reply
OLD MAN
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon II x2 Gigabyte GA78LM-S2 radeon 7850 4GB 
Hard DriveCoolingOSMonitor
OCZ Vertex2 CM Hyper 212+ Win7 LG 19" WS + 42" HDTV 
PowerCaseAudio
Antec EA650 CM Scout Asus Xonar DG 
  hide details  
Reply
post #5 of 9
Hi You need to turn your 2nd Device the one you use for a Hot spor into a WAP here is a guide which is pretty straightforward but if you have any trouble please post your concerns:



http://boards.portforward.com/viewtopic.php?f=6&t=93
post #6 of 9
Quote:
Originally Posted by agent__551 View Post

setting the 2nd router DHCP to 192.168.1.1 only make its address into the same as the 1st one

I'm not sure how that works. You need to tell the 2nd router that the 1st one is the DHCP server. That shouldn't set the 2nd router's actual IP to the same as the 1st. In fact, you need to specify your 2nd router's own address to be something static (something like 192.168.1.2.)
Quote:
Originally Posted by agent__551 View Post

and i did make the 1st as the gateway in the 2nd settings, still nothing
i max at 20 i think, mobiles and tablets mostly, changing the DHCP ranges between them didnt help

I think somewhere also you have to set the 2nd one to be in "router" mode as opposed to... something else. I can't remember off the top of my head and can't look it up at the moment, but if you look through the settings, there should be a few "modes," and one of them is "router" mode.
post #7 of 9
You need to configure the USRobotics as a "wireless bridge". It should be connected to one of the Huawei LAN to LAN, and once you enable wireless bridging, it should automatically pass data between the wireless interface and the LAN ports.

Greg
post #8 of 9
What kind of 'messed up' info do you get for the second router? I would bet that it is simply an APIPA 169.254/16 address from not receiving a response from DHCP.

Does traffic originating from a host on the second router show up as the router's address? You should be able to verify with wireshark.

I would also tidy up your DHCP pool and make sure the range it has can't overlap with assigned devices such as router 2.
Quote:
Originally Posted by hammong View Post

You need to configure the USRobotics as a "wireless bridge". It should be connected to one of the Huawei LAN to LAN, and once you enable wireless bridging, it should automatically pass data between the wireless interface and the LAN ports.

Greg

A wireless bridge is more used for having the wireless interface be an uplink that would facilitate traffic to wired clients..
post #9 of 9
You need to clean up your DHCP. You should have your DHCP pool start at .3 not .2
You need to update the DNS settings.
Not sure why you have 0.0.0.0 listed below when it need to be within your DHCP pool.

Your other router should have an address of 192.168.1.2 and not .244 because the .244 address is within the DHCP pool range.
The Raven
(16 items)
 
  
CPUMotherboardGraphicsGraphics
i7-2600K Gigabyte GA-P67A-UD5-B3 EVGA GTX 570 SC EVGA GTX 570 SC 
RAMHard DriveOptical DriveCooling
16GB G.SKILL Ripjaws X 1866 Samsung 840 Pro  iHAS324 - Lite-On DVD-RW Noctua NH-D14 
OSMonitorMonitorKeyboard
Windows 10 ASUS VN248 ASUS VN248 Logitech G510 
PowerCaseMouse
XFX 850W BE SILVERSTONE RV02B-EW Logitech MX518 
  hide details  
Reply
The Raven
(16 items)
 
  
CPUMotherboardGraphicsGraphics
i7-2600K Gigabyte GA-P67A-UD5-B3 EVGA GTX 570 SC EVGA GTX 570 SC 
RAMHard DriveOptical DriveCooling
16GB G.SKILL Ripjaws X 1866 Samsung 840 Pro  iHAS324 - Lite-On DVD-RW Noctua NH-D14 
OSMonitorMonitorKeyboard
Windows 10 ASUS VN248 ASUS VN248 Logitech G510 
PowerCaseMouse
XFX 850W BE SILVERSTONE RV02B-EW Logitech MX518 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Networking & Security
Overclock.net › Forums › Software, Programming and Coding › Networking & Security › DHCP server is not passing through 2nd router