Overclock.net › Forums › Graphics Cards › AMD/ATI › XFX 7850 Ghost not working?
New Posts  All Forums:Forum Nav:

XFX 7850 Ghost not working?

post #1 of 2
Thread Starter 
all of a sudden I went into the office to use my rig and my computer was off. Wouldn't post and had to reset the jumper without the card in for it to work.

I have babied the card pretty well and its only about 3 months old.

Any ideas if these series of cards have problems?

here is the exact card I have

http://www.legitreviews.com/xfx-radeon-hd-7850-1gb-core-edition-video-card-review_2048
Edited by dlee7283 - 9/6/13 at 1:49pm
    
CPUMotherboardGraphicsRAM
Pentium G4400 Gigabyte H110M-A MSI GTX 950 12GB Crucial Ballistix Sport DDR4-2100 
Hard DriveOptical DriveOSPower
Silicon Power 120GB SSD SATA6 Pioneer Blu-Ray Burner Windows 10 Pro Antec Neo Eco 620w 
Case
RIOTORO CR480 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Pentium G4400 Gigabyte H110M-A MSI GTX 950 12GB Crucial Ballistix Sport DDR4-2100 
Hard DriveOptical DriveOSPower
Silicon Power 120GB SSD SATA6 Pioneer Blu-Ray Burner Windows 10 Pro Antec Neo Eco 620w 
Case
RIOTORO CR480 
  hide details  
Reply
post #2 of 2
Have heard bad things about the black editions. Not sure about your card though. Warranty?

The cooler on that looks like it could lead to overheating if the thermal paste was not properly applied. Have you tried changing that?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › XFX 7850 Ghost not working?