Overclock.net › Forums › Components › Hard Drives & Storage › Mixing Raid 0 and non-Raid on an ASUS R4E MB
New Posts  All Forums:Forum Nav:

Mixing Raid 0 and non-Raid on an ASUS R4E MB

post #1 of 5
Thread Starter 
Firstly; tl;dr version.

Is it possible to have the following configuration:

6G Slot 1: Samsung 840 Pro
6G Slot 2: Empty
3G Slot 1&2: OCZ Vertex 2 in Raid 0


More indepth information -

While under my old setup, namely:

2x 74GB WD 10k drives in Raid 0 (used for the OS)
1 640GB for storage
1 Optical drive
2x 128GB Vertex 2 drives in Raid 0 (for games)

[I don't recall what slots I had them in, but this configuration worked fine)

I recently bought Rome 2, and with its dislike of Crossfire I ended up having to attempt to install the hotfix (13.10 beta driver). It never worked, it was always unable to locate a .INF file. I ended up losing my OS whilst updating windows as I played a game, and was forced to do a hard reset.

This was a pain, but I bought an 840 Pro, since I always wanted one, and would use it for the OS instead of the WD 74k drives.

Current issue:

I am never able to get the system to work with the single 840 Pro on its own with 2 Vertex drives in Raid 0.

Am I missing something, or is it just not possible? I spent 6 hours yesterday trying every setup I could imagine using AHCI, IDE, RAID in the SATA bios settings. I was able to install windows, but not with the RAID 0 setup. Or I was able to set up the RAID drives, but this meant the 840 Pro wouldnt appear when I tried to install windows.

One last question: Will the data on the old OS Raid 0 drives still be accessible, or will there be no option but to reformat them when I set them up again? I just want to access the file system to get some stuff.


Thanks for any help. I am at work, so won't be able to try anything suggested till I get home.
PC
(15 items)
 
  
CPUMotherboardGraphicsGraphics
3930k Rampage IV Extreme Diamond HD5970 Diamond HD5970 
RAMHard DriveCoolingOS
32GB [120GB Vertex 2] [120GB Vertex 2] Dark Knight II Win 7 64 Ultimate 
MonitorCase
27" HAFX  
  hide details  
Reply
PC
(15 items)
 
  
CPUMotherboardGraphicsGraphics
3930k Rampage IV Extreme Diamond HD5970 Diamond HD5970 
RAMHard DriveCoolingOS
32GB [120GB Vertex 2] [120GB Vertex 2] Dark Knight II Win 7 64 Ultimate 
MonitorCase
27" HAFX  
  hide details  
Reply
post #2 of 5
To use RAID you need to have the Intel SATA ports configured for RAID.

Depending on what RAID ROM is used (RSTe or IRST) you may need to manually load a driver during windows setup.

What you are attempting is perfectly possible. Your old RAID 0 volumes should also be intact.

If all else fails, disconnect all HDDs except the one you are installing windows on until you get everything up and running.
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.2/3.5GHz core/uncore, 1.175/1.15v Gigabyte X99 SOC Champion (F22n) Gigabyte AORUS GTX 1080 Ti (F3P) @ 2025/1485, 1... 4x4GiB Crucial @ 2667, 12-12-12-28-T1, 1.34v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.06) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Noctua NH-D15 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Sapphire Fury Nitro OC+ @ 1053/500, 1.225vGPU/1... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.2/3.5GHz core/uncore, 1.175/1.15v Gigabyte X99 SOC Champion (F22n) Gigabyte AORUS GTX 1080 Ti (F3P) @ 2025/1485, 1... 4x4GiB Crucial @ 2667, 12-12-12-28-T1, 1.34v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.06) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Noctua NH-D15 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Sapphire Fury Nitro OC+ @ 1053/500, 1.225vGPU/1... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
post #3 of 5
Thread Starter 
Quote:
Originally Posted by Blameless View Post

To use RAID you need to have the Intel SATA ports configured for RAID.

Depending on what RAID ROM is used (RSTe or IRST) you may need to manually load a driver during windows setup.

What you are attempting is perfectly possible. Your old RAID 0 volumes should also be intact.

If all else fails, disconnect all HDDs except the one you are installing windows on until you get everything up and running.

Thanks for the prompt reply.

It never asked me for a RAID driver, the MOBO just prompted me to enter the RAID configuration, thankfully.

I tried just having 1 drive installed, and was able to load windows. The issue arose when I set up the RAID array. The OS drive vanished.

Is using the ASMedia ports just like the others? I understand they are for HDs only, but have never actually tried to use them.
PC
(15 items)
 
  
CPUMotherboardGraphicsGraphics
3930k Rampage IV Extreme Diamond HD5970 Diamond HD5970 
RAMHard DriveCoolingOS
32GB [120GB Vertex 2] [120GB Vertex 2] Dark Knight II Win 7 64 Ultimate 
MonitorCase
27" HAFX  
  hide details  
Reply
PC
(15 items)
 
  
CPUMotherboardGraphicsGraphics
3930k Rampage IV Extreme Diamond HD5970 Diamond HD5970 
RAMHard DriveCoolingOS
32GB [120GB Vertex 2] [120GB Vertex 2] Dark Knight II Win 7 64 Ultimate 
MonitorCase
27" HAFX  
  hide details  
Reply
post #4 of 5
Update to the newest bios.
Asus just did a bios update that fixed my RAID problems.
Blue & Gold X79
(21 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-4930K  Asus X79-DELUXE  EVGA GTX 980 ti SC ACX 2.0 G.SKILL RipjawZ Series 16GB (4 x 4GB) 1866 
Hard DriveHard DriveHard DriveHard Drive
OCZ Vertex4 128GB (OS) WD RE4 2x500GB RAID0 WD Caviar Black 2TB OCZ Vector 180 
Hard DriveHard DriveHard DriveOptical Drive
OCZ Vector180 480GB 480GB OCZ Vector 180 series OCZ Vector 180 480GB Lite-on DVD Burner 
Optical DriveCoolingOSMonitor
LG Blue Ray Burner Cooler Master TPC 812  Microsoft Windows 10 x64 Asus PB278Q 
KeyboardPowerCaseMouse
Logitech G19 Corsair HX1000 HAF932 Blue (custom paint) Logitech G500 
Mouse Pad
Staples 
  hide details  
Reply
Blue & Gold X79
(21 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-4930K  Asus X79-DELUXE  EVGA GTX 980 ti SC ACX 2.0 G.SKILL RipjawZ Series 16GB (4 x 4GB) 1866 
Hard DriveHard DriveHard DriveHard Drive
OCZ Vertex4 128GB (OS) WD RE4 2x500GB RAID0 WD Caviar Black 2TB OCZ Vector 180 
Hard DriveHard DriveHard DriveOptical Drive
OCZ Vector180 480GB 480GB OCZ Vector 180 series OCZ Vector 180 480GB Lite-on DVD Burner 
Optical DriveCoolingOSMonitor
LG Blue Ray Burner Cooler Master TPC 812  Microsoft Windows 10 x64 Asus PB278Q 
KeyboardPowerCaseMouse
Logitech G19 Corsair HX1000 HAF932 Blue (custom paint) Logitech G500 
Mouse Pad
Staples 
  hide details  
Reply
post #5 of 5
Thread Starter 
Quote:
Originally Posted by ski-bum View Post

Update to the newest bios.
Asus just did a bios update that fixed my RAID problems.

I will try that, thanks.
PC
(15 items)
 
  
CPUMotherboardGraphicsGraphics
3930k Rampage IV Extreme Diamond HD5970 Diamond HD5970 
RAMHard DriveCoolingOS
32GB [120GB Vertex 2] [120GB Vertex 2] Dark Knight II Win 7 64 Ultimate 
MonitorCase
27" HAFX  
  hide details  
Reply
PC
(15 items)
 
  
CPUMotherboardGraphicsGraphics
3930k Rampage IV Extreme Diamond HD5970 Diamond HD5970 
RAMHard DriveCoolingOS
32GB [120GB Vertex 2] [120GB Vertex 2] Dark Knight II Win 7 64 Ultimate 
MonitorCase
27" HAFX  
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Hard Drives & Storage
Overclock.net › Forums › Components › Hard Drives & Storage › Mixing Raid 0 and non-Raid on an ASUS R4E MB