Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › ASUS 7970 DCU II crapped out from OC?
New Posts  All Forums:Forum Nav:

ASUS 7970 DCU II crapped out from OC?

post #1 of 2
Thread Starter 
It started suddenly in one of my gaming session. All of the sudden redish rainbow artifacts shooting from the center of the screen. Did that a couple of times. I decided to close the game.
All of the sudden my screen goes gray, with what it appeared to be squares.
Then my PC would have the black screen of death after the windows logo. It would just hang in there. It would go fine in safe mode tho. I would also have vertical think lines with greenish tint in BIOS (it wasn't my monitor)

I did OC'ed it. I managed to get a nice 1125/1500, and it ran fine while benchmarking it in Heaven 4.0. Temps never went over 75c. It was a great overlocked . Never had artifacts or crashed.

And of course the voltage was the stock 1.17v.

Going to have to RMA it. Not sure if I want to force the clocks on the new card. Tho I don't think a GPU should crap out if you push the OC, especially if you use the defalt voltage. It could become instable, but should be fine again if you just loose the clocks a bit. I mean there are reviews and people using them with 1.25 or 1.3v and 1200 mhz.

I have no facts, but it feels that the card might have crapped out even without OC'ing it, but it would have just taken longer. At least I have the 30 days within purchase to return to retailer, rather than to have to ship to ASUS for RMA. Better to find out flaws now than later, right?

And yea browsing around the internet, users do say that if you don't touch the voltage, the lifespan should not really change.

Just a bad card, or next time I should just stop around 1050/1450 and leave it at that (if ofc that is stable for that card)?
post #2 of 2
whats the rest of your specs?

psu in particular?
New Posts  All Forums:Forum Nav:
  Return Home
Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › ASUS 7970 DCU II crapped out from OC?