Overclock.net › Forums › Components › Mice › Mouse & KB input lag. Need help
New Posts  All Forums:Forum Nav:

Mouse & KB input lag. Need help - Page 2

post #11 of 22
Quote:
Originally Posted by superior View Post

Set maximum pre-rendered frames to 1
Set Adjust desktop size and position to No scaling
Set mouse hertz to 1000

Not saying this is the problem, but those few things could help reduce some of the input lag.

Polled rate can go either way.

Depending on total latency and refresh signal, it's possible to increase perceivable delay with higher polling rate, regardless of USB rendering updates faster.

Actually, shared case with other two attributes you mentioned. Really one of those things that requires compromise of update rate vs actual system latency.
Edited by Skylit - 9/16/13 at 12:35pm
post #12 of 22
Thread Starter 
Alright so it took some time but I was able to borrow another monitor real quick just to see what was up. I used a hp w2338h, not the greatest thing in the world but its got the same refresh rate and response time as this thing but it's a TN panel. Nothing has worked so far. Could it possibly be USB controller drivers? I got all mine from the asrock website.

I've also tried
reverting to low latency GPU drivers
Pretty much all bios related tips except for "turbo boost" which I cannot even highlight or click it change in BIOS
I gave the changing poll to 1000 hz a try but that didn't do anything at all. It just allowed some rates to be polled at 1000hz but my average was much lower than 1000 in use Mouse Rate (Click to show)

For most applications I wouldn't care but when I am trying to very snappy in natural selection it's just downright obnoxious.
MENTLEGEN
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770k @ 4.2 Asrock z77 extreme4 Gigabyte G1 GTX 1080 Samsung Wonder Ram pc12800 4gx4 (16g) 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO N/A Corsair h100i Windows 10 
MonitorKeyboardPowerCase
Crossfire 27QHD IPS @ 96hz Ducky Shine 3 ~ Soon to be Whitefox Seasonic 750W Gold CM Stryker 
MouseMouse PadAudio
Zowie EC1-A iCEMAT Audio Technica ATH-A900x 
  hide details  
Reply
MENTLEGEN
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770k @ 4.2 Asrock z77 extreme4 Gigabyte G1 GTX 1080 Samsung Wonder Ram pc12800 4gx4 (16g) 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO N/A Corsair h100i Windows 10 
MonitorKeyboardPowerCase
Crossfire 27QHD IPS @ 96hz Ducky Shine 3 ~ Soon to be Whitefox Seasonic 750W Gold CM Stryker 
MouseMouse PadAudio
Zowie EC1-A iCEMAT Audio Technica ATH-A900x 
  hide details  
Reply
post #13 of 22
Thread Starter 
So i was able to do some more tests.

1: confirmed not monitor. As i tried another one and I got no difference. AND see #2
2: pretty sure its not the mouse. When in game I have my finger about 1.5-2 inches above the mouse and I can click it real fast and have my finger all the way up before my character shoots. The audio matches the shot in game as late which is why I believe it's not the monitor as well or I would hear the shot before it's displayed on screen. This also happens when using a cheap optical DELL mouse.
MENTLEGEN
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770k @ 4.2 Asrock z77 extreme4 Gigabyte G1 GTX 1080 Samsung Wonder Ram pc12800 4gx4 (16g) 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO N/A Corsair h100i Windows 10 
MonitorKeyboardPowerCase
Crossfire 27QHD IPS @ 96hz Ducky Shine 3 ~ Soon to be Whitefox Seasonic 750W Gold CM Stryker 
MouseMouse PadAudio
Zowie EC1-A iCEMAT Audio Technica ATH-A900x 
  hide details  
Reply
MENTLEGEN
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770k @ 4.2 Asrock z77 extreme4 Gigabyte G1 GTX 1080 Samsung Wonder Ram pc12800 4gx4 (16g) 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO N/A Corsair h100i Windows 10 
MonitorKeyboardPowerCase
Crossfire 27QHD IPS @ 96hz Ducky Shine 3 ~ Soon to be Whitefox Seasonic 750W Gold CM Stryker 
MouseMouse PadAudio
Zowie EC1-A iCEMAT Audio Technica ATH-A900x 
  hide details  
Reply
post #14 of 22
Thread Starter 
So, ive gotten a new mouse and I am still getting input lag in games. however it is slightly less noticeable on the roccat pure optical. The polling rate seems to dip quite a bit and it never averages out to be 1000 hz. Still trying to confirm the diagnoses and think it may be rated to mobo or some drivers in windows. Thoughts?

MENTLEGEN
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770k @ 4.2 Asrock z77 extreme4 Gigabyte G1 GTX 1080 Samsung Wonder Ram pc12800 4gx4 (16g) 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO N/A Corsair h100i Windows 10 
MonitorKeyboardPowerCase
Crossfire 27QHD IPS @ 96hz Ducky Shine 3 ~ Soon to be Whitefox Seasonic 750W Gold CM Stryker 
MouseMouse PadAudio
Zowie EC1-A iCEMAT Audio Technica ATH-A900x 
  hide details  
Reply
MENTLEGEN
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770k @ 4.2 Asrock z77 extreme4 Gigabyte G1 GTX 1080 Samsung Wonder Ram pc12800 4gx4 (16g) 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO N/A Corsair h100i Windows 10 
MonitorKeyboardPowerCase
Crossfire 27QHD IPS @ 96hz Ducky Shine 3 ~ Soon to be Whitefox Seasonic 750W Gold CM Stryker 
MouseMouse PadAudio
Zowie EC1-A iCEMAT Audio Technica ATH-A900x 
  hide details  
Reply
post #15 of 22
move mouse at full speed?

other than that, read up on ur monitor on "prad". most older lcds have input lag varying between 16-30ms in optimal circumstances.
post #16 of 22
Thread Starter 
yep i moved my mouse speedy. Pretty sure its not a monitor deal as I've swapped monitors out and such. Also, if it was the monitor any in game actions would have real time audio and delayed visual. Delayed video matches delayed audio which makes me think its a related response to peripheral input devices.
MENTLEGEN
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770k @ 4.2 Asrock z77 extreme4 Gigabyte G1 GTX 1080 Samsung Wonder Ram pc12800 4gx4 (16g) 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO N/A Corsair h100i Windows 10 
MonitorKeyboardPowerCase
Crossfire 27QHD IPS @ 96hz Ducky Shine 3 ~ Soon to be Whitefox Seasonic 750W Gold CM Stryker 
MouseMouse PadAudio
Zowie EC1-A iCEMAT Audio Technica ATH-A900x 
  hide details  
Reply
MENTLEGEN
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770k @ 4.2 Asrock z77 extreme4 Gigabyte G1 GTX 1080 Samsung Wonder Ram pc12800 4gx4 (16g) 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO N/A Corsair h100i Windows 10 
MonitorKeyboardPowerCase
Crossfire 27QHD IPS @ 96hz Ducky Shine 3 ~ Soon to be Whitefox Seasonic 750W Gold CM Stryker 
MouseMouse PadAudio
Zowie EC1-A iCEMAT Audio Technica ATH-A900x 
  hide details  
Reply
post #17 of 22
Quote:
Originally Posted by Jaggar View Post

Pretty much all bios related tips except for "turbo boost" which I cannot even highlight or click it change in BIOS.

This picture shows the BIOS for your motherboard:



In that picture, you should be able to turn off: "Advance Turbo 30" , "Intel Speedstep", and "Intel Turbo Boost"

In the next picture you should have "Power Saving Mode" set to disabled:



In the next picture, you should disable: "Enhanced Halt State (C1E)", "CPU C3", "CPU C6", "Package C State Support", "CPU THermal Throttling", "No Execute Memory Protection", if you don't use VMWARE, might as well turn off virtualization/vanderpool too.

In the next picture, the setting "IGPU Multi Monitor" looks fishy, I haven't seen anywhere in this BIOS yet to turn off the iGPU entirely? My Gigabyte UD5H has a clear setting to disable the integrated GPU. If you can't disable IGPU entirely, that may be a significant problem source for input lag:



In the next page, turn off "Onboard HD Audio", Onboard HDMI audio"



The next page, you need to disable the ASmedia SATA controller, unless you actually use it for some reason instead of the native Intel one. I would probably turn off SATA Aggressive Link Power Management too:



I assume the setting in the next picture called "ACPI HPET Table" is the HPET Timer, which you would want turned off if that's the case:




Other stuff to turn off: Intel Rapid Start Technology, Serial Port
post #18 of 22
Thread Starter 
Followed instructions to a T apart from the ASMEDIA SATA Controller. I guess I;ve got my SSD plugged into that because those this MOBO uses the ASMEDIA controller for all SATA 3.0 devices. All other sata ports are 2.0. I was able to disable I-GPU multimonitor outrite. WIth these conditions NO INPUT LAG.... but now I've got no audio lol but at least im closer to figuring out what the deal is.
MENTLEGEN
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770k @ 4.2 Asrock z77 extreme4 Gigabyte G1 GTX 1080 Samsung Wonder Ram pc12800 4gx4 (16g) 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO N/A Corsair h100i Windows 10 
MonitorKeyboardPowerCase
Crossfire 27QHD IPS @ 96hz Ducky Shine 3 ~ Soon to be Whitefox Seasonic 750W Gold CM Stryker 
MouseMouse PadAudio
Zowie EC1-A iCEMAT Audio Technica ATH-A900x 
  hide details  
Reply
MENTLEGEN
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770k @ 4.2 Asrock z77 extreme4 Gigabyte G1 GTX 1080 Samsung Wonder Ram pc12800 4gx4 (16g) 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO N/A Corsair h100i Windows 10 
MonitorKeyboardPowerCase
Crossfire 27QHD IPS @ 96hz Ducky Shine 3 ~ Soon to be Whitefox Seasonic 750W Gold CM Stryker 
MouseMouse PadAudio
Zowie EC1-A iCEMAT Audio Technica ATH-A900x 
  hide details  
Reply
post #19 of 22
pretty sure its your monitor redface.gif
FPS Gaming System
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570K @ 4.2GHz Gigabyte Z77M D3H MVP MSI GTX 570 8 GB 1600 MHz G.Skill 
Hard DriveHard DriveOptical DriveCooling
Crucial M4 128 GB Western Digital 500 GB Samsung X22 Superwritemaster  Alpine 11 Pro 
OSMonitorKeyboardPower
Win 7 64-Bit Ultimate BenQ XL2411Z 144Hz CoolerMaster Storm QuickFire Pro Mechanical Corsair TX750 
CaseMouseMouse PadAudio
CoolerMaster 690 Newmen GX1-Pro SteelSeries QCK Heavy QPAD qh-90 
  hide details  
Reply
FPS Gaming System
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570K @ 4.2GHz Gigabyte Z77M D3H MVP MSI GTX 570 8 GB 1600 MHz G.Skill 
Hard DriveHard DriveOptical DriveCooling
Crucial M4 128 GB Western Digital 500 GB Samsung X22 Superwritemaster  Alpine 11 Pro 
OSMonitorKeyboardPower
Win 7 64-Bit Ultimate BenQ XL2411Z 144Hz CoolerMaster Storm QuickFire Pro Mechanical Corsair TX750 
CaseMouseMouse PadAudio
CoolerMaster 690 Newmen GX1-Pro SteelSeries QCK Heavy QPAD qh-90 
  hide details  
Reply
post #20 of 22
Quote:
Originally Posted by Jaggar View Post

Followed instructions to a T apart from the ASMEDIA SATA Controller. I guess I;ve got my SSD plugged into that because those this MOBO uses the ASMEDIA controller for all SATA 3.0 devices. All other sata ports are 2.0. I was able to disable I-GPU multimonitor outrite.

No need to disable onboard audio if you use it.
Are you sure that all ports are asmedia? Grey Sata 3.0 ports should be intel.
"The Intel ports will be named SATA3_0, the AsMedia ports will be named SATA3_A0."
Quote:
WIth these conditions NO INPUT LAG.... but now I've got no audio lol but at least im closer to figuring out what the deal is.

So with this tweaks(which were posted long time ago) you dont have input lag? And how exactly you get closer to figuring out what the deal is, if after this tweaks you got no input lag?
Edited by Berserker1 - 10/4/13 at 6:02am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › Mouse & KB input lag. Need help