Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › Little help with Windows 8 + UEFI + GPT + Raid + SSD install please
New Posts  All Forums:Forum Nav:

Little help with Windows 8 + UEFI + GPT + Raid + SSD install please

post #1 of 22
Thread Starter 
Yikes, talk about a real pain. Far as I can tell, they should be moving GPT partitions over to the new standard real soon eh? Not soon enough!

I have spent the entirety of today (and missed tonights raid/wow) trying to first get my boot drive (drives - raided ssd's) to partition as GPT like my storage drive (drives - raided hdds) and after accomplishing that, I figured installing windows 8 would be easy street. WRONG!

Apparently you cant install windows to a GPT partition unless you boot as UEFI. My issue is everything I have tried has either resulted in that message, or resulted in no drives at all showing during windows installation.

I am installing from a windows 8 x64 usb stick. One sticking point that is making this much harder than it has to be (but I know its not impossible) is the fact that I have GTX480's in my machine which are not UEFI complaint. This means when I turn off CSM - I get a blank screen with no display signal.

I have left CSM on and tried to configure/boot as UEFI but I am doing something wrong as my usb stick never shows up with the UEFI prefix.

I am out of ideas and have resorted to posting. Any help would be more than stellar.

Thanks guys!
post #2 of 22
Thread Starter 
Ugh, this I was afraid of! Such a retarded odd issue! I know i have seen my USB stick prefixed with UEFI before during the boot selection but now for the life of me I can't get it to reappear.

If all else fails hopefully when I Install my new efi compliant gpus I can just turn off CSM (effectively enabling efi across the board) and it will work. At this point I'm hoping I don't have to resort to that. I can't afford blocks for my 780s yet ( plus they all say titan!! ) so I will have to either go without a PC, use a PC ill just have to dump again, or redo my loop twice which is such a pain! ( once I get some blocks )

Seems other people are doing it with asus boards. I would like to think that means I can do it too.
post #3 of 22
On my Z77 Gigabyte board, it depends on what beta BIOS version I'm using regarding that UEFI prefix for the USB stick. Older versions don't really care about that as I remember, only know Legacy boot. The latest stable BIOS version is from before Windows 8 and Fast Boot and Secure Boot and stuff like that, so it also only wants to do Legacy.
post #4 of 22
Thread Starter 
Well unless there is a newer beta bios somewhere I don't know about, I'm def using the newest off their site. Now are you saying it no longer showed uefi but still used it? Or it was missing and didn't work? What gpu did you use at the time? Did you ever end up getting it sorted out?

Thanks for the feedback. Every little bit helps!
post #5 of 22
I have a GTX 560 Ti. No UEFI GOP is possible on that card as its BIOS chip is simply too small.

It will boot with CSM like normal, but it can read and boot that UEFI style boot loader stuff from a drive. I can choose to boot legacy or UEFI style for every drive.

If I go into the BIOS and go onto the last page where you can save and load profiles, there's also a list of all drives it can boot from. There's two entries for the USB stick, a normal one that will boot legacy style, and there's an entry that says "UEFI" at the front.

Do you have a Gigabyte board? There's a whole bunch of beta BIOS versions that never showed up on the Gigabyte site. You can find them in the tweaktown.com forum inside the official Gigabyte vendor support section in a sticky thread.
post #6 of 22
Thread Starter 
Yes I'm using an oc force with bios number 7. I am using a Buncha 480s till my 780s get here so I have no efi either. I know the last page you refer to as well as the boot order and boot override options where you can select from all bootable devices but nothing is showing up as uefi at all.

I know its a lot to ask but any chance you would care to list your bios settings for everything pertinent to booting the way you/I am looking to? Assuming u still have that box together anyhow.

I do know of the TT thread you are referring to but unless I can use other boards bios such as regular oc version, I think 7 is all it shows there as well unfortunately.

Again, Ty so much for the help!
post #7 of 22
Hey, I don't want to reboot into BIOS and make screenshots, but I can describe what I remember, though I don't know if my Z77 board will help you with your Z87 board.

Fast Boot is disabled. Secure Boot has to be disabled or in "Setup" mode, not "User".

The CSM settings, I've set that to Windows 8 mode. Directly beneath that setting are boot, network, pci, storage device options. For the boot device and storage device, I can choose if both UEFI and Legacy are enabled or only one of them. Perhaps that's where you should look? If you force storage (and/or boot?) to UEFI only, it wouldn't try to boot the Windows 8 USB stick as legacy anymore.

Did you create the USB stick with the Windows 8 Setup as FAT32? It doesn't work as NTFS format I think I remember.
post #8 of 22
Thread Starter 
Fwiw I think yours sounds identical to mind for the most part. Our settings were the same too. A bit off topic but let me tell you, booting uefi a hd reso via these new cards is aaaamazing looking. Shows much more info as well. Anyhow, I did just realize my USB stick was formatted as ntfs and I'll be damned if that was the issue all by itself! I'm using Rufus to reformat and recreate a windows installation stick as we speak. Info inc!
post #9 of 22
Thread Starter 
The problem when forcing uefi/non legacy storage is that no boot devices would be identified at all. (Likely due to ntfs) I think when I saw the uefi prefix in the past it must have been a diff usb stick of mine. All lending hope to this working now. We shall see.

I just replaced 4 gtx480s with 2 gtx780s and I have 2 more on the way. I'm thinking/hoping just the 2 will still be an upgrade. Long overdue and a lot of work went into this but man I should be good for awhile now I hope.

Now to see if upgrading 1866 ram to 2400 is worth the money.

Also trying to determine my next case. I'm gonna have to chop mine up even more to ensure my 4th 780 will fit since i A) have no $ for waterblocks at the moment and B) my current mid tower only has 7 mounts/slots in the back and while the older cards worked, these have dvi ports stacked instead of side by side.

Anyways, I'm getting off topic tongue.gif
post #10 of 22
Thread Starter 
Ha! so all along, my problem was a NTFS formatted usb stick. /sigh So I fixed that and realized that everytime I saw the uefi prefix on my disk in the past, I must have had a different usb stick in. (a fat32 one)

Anyhow, now I get to the point of installation, the next key is no longer grey'd out and I click it only to be greeted with a error that says something along the lines of "we cant locate a partition or create one" whaa? I just created one and cleaned the disk and made it active all with DISKPART.

I feel so helpless. On the bright-side, im learning something new which can never be a bad thing. Anyone know what i'm missing now?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Windows
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › Little help with Windows 8 + UEFI + GPT + Raid + SSD install please