Overclock.net › Forums › Components › Sound Cards and Computer Audio › Need help with my headset microphone problem.
New Posts  All Forums:Forum Nav:

Need help with my headset microphone problem.

post #1 of 2
Thread Starter 
Okay, I'm starting to have a huge headache trying to solve this. I've tried literally everything to get this fixed. Ticking boxes on and off, changing settings, changing volumes, and etc.

So here is the problem. I'm using a Razer Electra headphones. It comes with a mic but this headset needs an 3.5mm adapter to use it on the PC. I'm using the adapter and the sound comes out great through my headset. The only problem is I can't get the microphone to work. So I have these adapters plugged into the front panel jacks and everything works fine. I have the speaker plugged into the rear panel jack. I switch the playback sound to headset and speaker depending on what I'm doing.

Anyways, so when I enable my headset and use the microphone. I have the front-microphone enabled and did set everything to work. However, everytime I run a test, I would hear a loopback like if I say "Hello" then it'll go "Hello-o-o-o-o-o-o-o-o". Long echo. Then it'll start to pick up sounds that's coming from things such as facebook message. The sound isn't very clear and keeps having these echo sound. Anything from the computer that makes sound will go straight directly into my mic. However, if I set the default playback sound as my speaker instead of my headset and use my mic that's on my headset, it'll work perfectly fine. I can hear everything loud and clear and also hear my own voice when doing test runs. But this is not what I want. I want to use the mic on my headset and also use the headset for sound, especially when I'm gaming. I just can't figure out how to get this fixed.

My sound is RealTek HD Audio.

Drivers are up-to-date.
Listen to this device is unchecked.
I've tried messing with a lot of things like the volumes, the microphone boost, checking and unchecking boxes, and others.

If anyone has any suggestion, please help me fix this!
post #2 of 2
I'm guessing your sound problem has something to do with this
sinep
(11 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 GA-X58A-UD3R MSI GTX 650Ti Corsair XMS3 
Hard DriveOSMonitorKeyboard
WD10EZEX + Crucial M4 64-bit Windows 7 Home Premium Asus VG248QE </3 Sidewinder X4 
MouseMouse PadAudio
Logitech G302 Upside down Puretrak Talent Focusrite Scarlett 2i2 + Red Sony MDRZX300 
  hide details  
Reply
sinep
(11 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 GA-X58A-UD3R MSI GTX 650Ti Corsair XMS3 
Hard DriveOSMonitorKeyboard
WD10EZEX + Crucial M4 64-bit Windows 7 Home Premium Asus VG248QE </3 Sidewinder X4 
MouseMouse PadAudio
Logitech G302 Upside down Puretrak Talent Focusrite Scarlett 2i2 + Red Sony MDRZX300 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › Need help with my headset microphone problem.