Overclock.net › Forums › Graphics Cards › AMD/ATI › 7970 display port problem.
New Posts  All Forums:Forum Nav:

7970 display port problem.

post #1 of 7
Thread Starter 
I have looked all over the net and cant seem to fined a fix for this problem. When I restart my PC both my monitors will say no display port detected but if I shut the computer all the way down they come right back on. Anyone have any idea why this is happening. I have tried different drivers have the newest bios for my 7970 but cant get it to stop doing this. any ideas how to fix.
post #2 of 7
HDMI or DVI-D ?
When the monitors don't get detected after a restart, unplug the cable(s) from the back of the 7970 then plug it back in...do the monitors get a signal then ?
Edited by eXXon - 10/4/13 at 11:02am
TheSadFlute
(17 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI Golden Ed GTX980 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  HP 32' 1440p Logitech G710+ EVGA G2 750W 
CaseMouseMouse PadAudio
Cooler Master Stryker Logitech G602 Steel Series On-Board 
Audio
Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
TheSadFlute
(17 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI Golden Ed GTX980 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  HP 32' 1440p Logitech G710+ EVGA G2 750W 
CaseMouseMouse PadAudio
Cooler Master Stryker Logitech G602 Steel Series On-Board 
Audio
Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
post #3 of 7
Thread Starter 
Its not HDMI or DVI-D its display ports the smaller ones and not mini HDMI. I am running both my screens at 144HZ so I went with duel display port as my windforce has two of them.



Oh and if I unplug and plug them back in no they do not come on only shut down works.
post #4 of 7
Does it also happen when you have a single monitor connected?
TheSadFlute
(17 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI Golden Ed GTX980 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  HP 32' 1440p Logitech G710+ EVGA G2 750W 
CaseMouseMouse PadAudio
Cooler Master Stryker Logitech G602 Steel Series On-Board 
Audio
Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
TheSadFlute
(17 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI Golden Ed GTX980 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  HP 32' 1440p Logitech G710+ EVGA G2 750W 
CaseMouseMouse PadAudio
Cooler Master Stryker Logitech G602 Steel Series On-Board 
Audio
Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
post #5 of 7
Thread Starter 
Not sure I will try that to night when I get home.
post #6 of 7
Thread Starter 
Ok tried it with one monitor still the same problem. Also fyi I had another wind force 7970 I tried it on also a friend of mines and same thing on restart both screens will not come back on but shut down will.
post #7 of 7
How long is your display port cable?

I have read of people having issues if the cable was to long. Over 6 feet I think, also there are cheap quality cable that can cause an issue for some people.
MINE
(18 items)
 
Wifes/backup rig
(13 items)
 
My Ultimate Rig
(9 items)
 
CPUMotherboardGraphicsRAM
I3 2120 AsRock P67 Pro 3  MSI 950 twin frozr 8gb ripjaws 1600 
Hard DriveHard DriveCoolingOS
120gb sandisk ssd 750 gb caviar black hyper 212plus win7 home premium 
MonitorKeyboardPowerCase
Dell SE198WFP X3 surround Logitech G710+ 750w seasonic gold coolermaster HAF 912 advanced 
Mouse
G700 
CPUMotherboardGraphicsRAM
4930k Asus rampage extreme 4 2 290's 16gb 2133 quad channel 
Hard DriveCoolingOSPower
2tb cavier black h220 win 7 64 oem seasonic 1000w platnum 
Case
Haf x 
  hide details  
Reply
MINE
(18 items)
 
Wifes/backup rig
(13 items)
 
My Ultimate Rig
(9 items)
 
CPUMotherboardGraphicsRAM
I3 2120 AsRock P67 Pro 3  MSI 950 twin frozr 8gb ripjaws 1600 
Hard DriveHard DriveCoolingOS
120gb sandisk ssd 750 gb caviar black hyper 212plus win7 home premium 
MonitorKeyboardPowerCase
Dell SE198WFP X3 surround Logitech G710+ 750w seasonic gold coolermaster HAF 912 advanced 
Mouse
G700 
CPUMotherboardGraphicsRAM
4930k Asus rampage extreme 4 2 290's 16gb 2133 quad channel 
Hard DriveCoolingOSPower
2tb cavier black h220 win 7 64 oem seasonic 1000w platnum 
Case
Haf x 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › 7970 display port problem.