Overclock.net › Forums › AMD › AMD - General › Poor full HD video playback performance on my AMD desktop computer - any idea please?
New Posts  All Forums:Forum Nav:

Poor full HD video playback performance on my AMD desktop computer - any idea please?

post #1 of 9
Thread Starter 
Hi,

I have the following config (I mention just the interesting parts):

- AMD FX-4110 Black Edition processor
- Asus M5A99X Evo motherboard
- 16GB Corsair Vengeance memory
- Gainward NVidia GeForce GTX 560 Ti video card
- TFT screen with 1440x900 resolution
- Windows 7 Home Premium
- VLC Media Player

This config works excellent with all games, never freezes, never overheats (never measured more than 58C, not even when continuously pressing with CPU stress software for half an hour in a room that had 27C air tempereature...).

But what I don't understand... When it comes to watching Full/Full-ish HD video (1920X1080, 1920X960 etc) it just struggles to keep up with it!! I noticed the CPU load is between 70%(!) and 90%(!) for all four cores(!) with 1x speed Full HD video playback in VLC Media Player (same in other media players or even at YouTube in Opera/Firefox/etc). If I speed it up to 1.5x speed (yes, I like to do that at boring parts of movies) then it goes up to 95%-100% and it can keep up with it for only approx ten seconds before picture quality drops very significantly (not very enjoyable). 2.0x playback speed is completely unusable. Also, the idle temperature, which is usually 36-38C goes up to 50-52C. What is even worse, even with normal 1x playback speed it happens sometimes, that when the camera moves sideways (i.e. showing around a landscapce etc.) the video has very short stops (like 1/10th of a second) every 4-5 seconds, or when there is lot of action and the camera moves sideways in the same time then it feels like I have only 15-20fps only, i.e. playback is not smooth enough. Quite annoying.

What could be the reason for this? I expected a LOT more video playback performance. On my wife's old Intel I3 540 / Radeon 5850 computer (and this processor and video card supposed to be weaker than the AMD/NVidia mentioned above, or at least not more powerful) the same Full HD movie playback results only 20%-30% CPU load (and this processor has only 2 cores, not 4) and the CPU temperature goes up from 32C to only 36C or so...Plus, it plays back that video very nicely at 2x or even 3x speed... I already swapped around the two video cards and that makes no difference - so it is not the video card's fault then. Then must be the processor, I guess. Can and AMD processor be THIS week when it comes to full HD video playback? Or this much more inferior to Intel? I can't believe that. And I already ran out of ideas, I already installed the very latest drivers (motherboard, video card), performed BIOS update etc. (To be honest I have a 4+ year old laptop with an Intel Celeron T3100 processor with a Intel GMA 4500 MHD video chipset and to play the same full HD video on it causes only the same 70%-90% CPU load - so my AMD computer's full HD video playback power is equals about this old laptop's - that is very very very poor).

I tried, of course, quite playing a few more full HD movies, not just one, with same results. Also, I tried the playback with on AMD computer but with my wife's 1920x1080 23" screen attached to see if my screen's 1440x900 (I like lower resolutions) has anything to do with it - nope, no difference. I also tried to overclock/underclock the processor - a few percent change in the load, but nothing significant.

Any ideas please? Anybody experiencing the same?

Thank you
    
CPUMotherboardGraphicsRAM
Intel Core i5-6600 (Skylake) Gigabyte GA-Z170X-Gaming 3 MSI GeForce GTX 1070 GAMING X 8G 16GB Corsair Vengeance LPX 2400MHz DDR4 
Hard DriveCoolingOSMonitor
Samsung 850 Evo 500GB SSD Cooler Master Hyper 212X Windows 10 Home Acer 27" 1920x1080 
KeyboardPowerCaseMouse
Microsoft USB wired Corsair RM850 80 Plus Gold semi-passive 850W fu... Thermaltake Chaser A71 Miscorosft USB wired 
AudioOtherOther
On board Microsoft HD webcam and Microsoft Lifechat headset Logitech Z323 2.1 speakers 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i5-6600 (Skylake) Gigabyte GA-Z170X-Gaming 3 MSI GeForce GTX 1070 GAMING X 8G 16GB Corsair Vengeance LPX 2400MHz DDR4 
Hard DriveCoolingOSMonitor
Samsung 850 Evo 500GB SSD Cooler Master Hyper 212X Windows 10 Home Acer 27" 1920x1080 
KeyboardPowerCaseMouse
Microsoft USB wired Corsair RM850 80 Plus Gold semi-passive 850W fu... Thermaltake Chaser A71 Miscorosft USB wired 
AudioOtherOther
On board Microsoft HD webcam and Microsoft Lifechat headset Logitech Z323 2.1 speakers 
  hide details  
Reply
post #2 of 9
Could try enabling gpu acceleration if it isn't currently on

Stu
Betsy
(14 items)
 
  
CPUMotherboardGraphicsRAM
I5 4670k @ 4.2ghz Gigabyte GA-Z87X-OC MSI 7950 TFIII  8gb Corsair Vengance Arctic White 1600mhz 
Hard DriveOSMonitorKeyboard
2x 250gb raid 0 Win 7 64bit LG Flatron 23" Razer Blackwidow 
PowerCaseMouseOther
OCZ 600W NZXT Phantom Roccat Kone Razer Nostromo 
  hide details  
Reply
Betsy
(14 items)
 
  
CPUMotherboardGraphicsRAM
I5 4670k @ 4.2ghz Gigabyte GA-Z87X-OC MSI 7950 TFIII  8gb Corsair Vengance Arctic White 1600mhz 
Hard DriveOSMonitorKeyboard
2x 250gb raid 0 Win 7 64bit LG Flatron 23" Razer Blackwidow 
PowerCaseMouseOther
OCZ 600W NZXT Phantom Roccat Kone Razer Nostromo 
  hide details  
Reply
post #3 of 9
This was going to be my suggestion^.

I'll throw out a few additional suggestions.

Once you enable GPU acceleration, it will take some load off of the CPU. Not sure how much exactly without going and testing it myself, but even with my CPU (older than yours) I'm having no trouble playing full-scaled BD Rips (1080p .mkv files that weigh about 15-40GB).

-As stated: GPU Acceleration (Tools>Preferences>Input & Codecs> (check) Use GPU accelerated decoding)
-Have you tried disabling Cool n' Quiet (not sure if it's still called this)?

I'm willing to bet that the GPU acceleration is the root of the problem since you say games run perfectly fine. Your temps are more than fine, and without GPU Acc. your temps and CPU load sounds normal.
 
TBA
(14 items)
 
 
CPUMotherboardGraphicsRAM
i7 4770k [4.2GHz] Gigabyte Z97N G5 Titan X P [12GB] G.Skill Ripjaw X [16GB] 
Hard DriveHard DriveCoolingCooling
Kingston HyperX Savage [480GB] Mushkin Enhanced Reactor [1TB] Noctua NH-C14S + F120MP Phanteks PH-F120MP [x2] 
OSMonitorKeyboardPower
Windows 10 Professional [x64] Acer Predator X34 HHKB Pro 2 Corsair SF600 [600w] 
CaseMouseMouse PadAudio
NCASE M1 [v5] Logitech G900 QcK+ [Vault 111 Ed.] Schiit Bifrost Uber + Schiit Asgard 2 + TH-X00... 
CPUMotherboardGraphicsRAM
Penitum G3258 ASRock Z97E-ITX/ac ASUS GTX 1070 FE Kingston HyperX Fury DDR3 1866 [White Ed.] 
Hard DriveCoolingOSMonitor
Kingston HyperX 3K [120GB] Phanteks PH-TC14PE  Win 10 Pro [x64] Dell UltraSharp U2713HM [2K] 
KeyboardPowerCaseMouse
KC60 [Miami Ed.] EVGA 550 G2 Phanteks Enthoo Evolv ITX [White] Rival 300 [Fade] 
Mouse PadAudio
SS QcK Heavy Massdrop x HiFiMAN HE-350 
  hide details  
Reply
 
TBA
(14 items)
 
 
CPUMotherboardGraphicsRAM
i7 4770k [4.2GHz] Gigabyte Z97N G5 Titan X P [12GB] G.Skill Ripjaw X [16GB] 
Hard DriveHard DriveCoolingCooling
Kingston HyperX Savage [480GB] Mushkin Enhanced Reactor [1TB] Noctua NH-C14S + F120MP Phanteks PH-F120MP [x2] 
OSMonitorKeyboardPower
Windows 10 Professional [x64] Acer Predator X34 HHKB Pro 2 Corsair SF600 [600w] 
CaseMouseMouse PadAudio
NCASE M1 [v5] Logitech G900 QcK+ [Vault 111 Ed.] Schiit Bifrost Uber + Schiit Asgard 2 + TH-X00... 
CPUMotherboardGraphicsRAM
Penitum G3258 ASRock Z97E-ITX/ac ASUS GTX 1070 FE Kingston HyperX Fury DDR3 1866 [White Ed.] 
Hard DriveCoolingOSMonitor
Kingston HyperX 3K [120GB] Phanteks PH-TC14PE  Win 10 Pro [x64] Dell UltraSharp U2713HM [2K] 
KeyboardPowerCaseMouse
KC60 [Miami Ed.] EVGA 550 G2 Phanteks Enthoo Evolv ITX [White] Rival 300 [Fade] 
Mouse PadAudio
SS QcK Heavy Massdrop x HiFiMAN HE-350 
  hide details  
Reply
post #4 of 9
what clock speed does your cpu run at when watching a video?
there should be no need to use gpu acceleration. something is the matter
Dell E6430s
(2 items)
 
the old nag
(15 items)
 
 
CPUOther
i5-3320m PR03X Docking Station 
CPUMotherboardRAMHard Drive
Phenom II x4 955 Asus M3N78 PRO 2GB Corsair XMS2-8500 DDR2 5-5-5-15 (2) OCZ 128GB SSD 
Hard DriveHard DriveHard DriveOS
Samsung 2TB WD Black 2TB  WD Green 2TB Windows 8 x64 
MonitorKeyboardPowerCase
Dell P2414H Filco Magestouch MX Brown Tenkeyless Corsair CX430 v2 Antec 300 
MouseAudioOther
Logitech G400 Sennheiser HD598 Linksys E1000-RM N 2.4GHz 300Mbps 2T2R Wireless... 
  hide details  
Reply
Dell E6430s
(2 items)
 
the old nag
(15 items)
 
 
CPUOther
i5-3320m PR03X Docking Station 
CPUMotherboardRAMHard Drive
Phenom II x4 955 Asus M3N78 PRO 2GB Corsair XMS2-8500 DDR2 5-5-5-15 (2) OCZ 128GB SSD 
Hard DriveHard DriveHard DriveOS
Samsung 2TB WD Black 2TB  WD Green 2TB Windows 8 x64 
MonitorKeyboardPowerCase
Dell P2414H Filco Magestouch MX Brown Tenkeyless Corsair CX430 v2 Antec 300 
MouseAudioOther
Logitech G400 Sennheiser HD598 Linksys E1000-RM N 2.4GHz 300Mbps 2T2R Wireless... 
  hide details  
Reply
post #5 of 9
This is actually right^.

I just ran full 1080p Kill Bill Vol 1 BD Rip and with or without GPU acceleration, I had less than 15% being used on each CPU core.
 
TBA
(14 items)
 
 
CPUMotherboardGraphicsRAM
i7 4770k [4.2GHz] Gigabyte Z97N G5 Titan X P [12GB] G.Skill Ripjaw X [16GB] 
Hard DriveHard DriveCoolingCooling
Kingston HyperX Savage [480GB] Mushkin Enhanced Reactor [1TB] Noctua NH-C14S + F120MP Phanteks PH-F120MP [x2] 
OSMonitorKeyboardPower
Windows 10 Professional [x64] Acer Predator X34 HHKB Pro 2 Corsair SF600 [600w] 
CaseMouseMouse PadAudio
NCASE M1 [v5] Logitech G900 QcK+ [Vault 111 Ed.] Schiit Bifrost Uber + Schiit Asgard 2 + TH-X00... 
CPUMotherboardGraphicsRAM
Penitum G3258 ASRock Z97E-ITX/ac ASUS GTX 1070 FE Kingston HyperX Fury DDR3 1866 [White Ed.] 
Hard DriveCoolingOSMonitor
Kingston HyperX 3K [120GB] Phanteks PH-TC14PE  Win 10 Pro [x64] Dell UltraSharp U2713HM [2K] 
KeyboardPowerCaseMouse
KC60 [Miami Ed.] EVGA 550 G2 Phanteks Enthoo Evolv ITX [White] Rival 300 [Fade] 
Mouse PadAudio
SS QcK Heavy Massdrop x HiFiMAN HE-350 
  hide details  
Reply
 
TBA
(14 items)
 
 
CPUMotherboardGraphicsRAM
i7 4770k [4.2GHz] Gigabyte Z97N G5 Titan X P [12GB] G.Skill Ripjaw X [16GB] 
Hard DriveHard DriveCoolingCooling
Kingston HyperX Savage [480GB] Mushkin Enhanced Reactor [1TB] Noctua NH-C14S + F120MP Phanteks PH-F120MP [x2] 
OSMonitorKeyboardPower
Windows 10 Professional [x64] Acer Predator X34 HHKB Pro 2 Corsair SF600 [600w] 
CaseMouseMouse PadAudio
NCASE M1 [v5] Logitech G900 QcK+ [Vault 111 Ed.] Schiit Bifrost Uber + Schiit Asgard 2 + TH-X00... 
CPUMotherboardGraphicsRAM
Penitum G3258 ASRock Z97E-ITX/ac ASUS GTX 1070 FE Kingston HyperX Fury DDR3 1866 [White Ed.] 
Hard DriveCoolingOSMonitor
Kingston HyperX 3K [120GB] Phanteks PH-TC14PE  Win 10 Pro [x64] Dell UltraSharp U2713HM [2K] 
KeyboardPowerCaseMouse
KC60 [Miami Ed.] EVGA 550 G2 Phanteks Enthoo Evolv ITX [White] Rival 300 [Fade] 
Mouse PadAudio
SS QcK Heavy Massdrop x HiFiMAN HE-350 
  hide details  
Reply
post #6 of 9
Thread Starter 
Thank you for all the answers. Yes, I got it!! It was the GPU acceleration not ticked in VLC Media Player! I enabled it and now Core 1 has a load of approx 20%, and the other three cores have load of approx 10% when playing back full HD video. Also, no problem whatsoever with 1.5x or 2x playback speed. I checked my wife's computer as well, the VLC Media Player had that GPU acceleration box ticked. We did not even know about this so we definitely did not change this setting before. So it's weird that on one computer this option was on and on the other it was off.
Two questions though:
What is "Video quality post-processing level" (it is set to 6)
What is "Skip H.264 in/loop deblocking filter" (it is set to None)
Thank you!
    
CPUMotherboardGraphicsRAM
Intel Core i5-6600 (Skylake) Gigabyte GA-Z170X-Gaming 3 MSI GeForce GTX 1070 GAMING X 8G 16GB Corsair Vengeance LPX 2400MHz DDR4 
Hard DriveCoolingOSMonitor
Samsung 850 Evo 500GB SSD Cooler Master Hyper 212X Windows 10 Home Acer 27" 1920x1080 
KeyboardPowerCaseMouse
Microsoft USB wired Corsair RM850 80 Plus Gold semi-passive 850W fu... Thermaltake Chaser A71 Miscorosft USB wired 
AudioOtherOther
On board Microsoft HD webcam and Microsoft Lifechat headset Logitech Z323 2.1 speakers 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i5-6600 (Skylake) Gigabyte GA-Z170X-Gaming 3 MSI GeForce GTX 1070 GAMING X 8G 16GB Corsair Vengeance LPX 2400MHz DDR4 
Hard DriveCoolingOSMonitor
Samsung 850 Evo 500GB SSD Cooler Master Hyper 212X Windows 10 Home Acer 27" 1920x1080 
KeyboardPowerCaseMouse
Microsoft USB wired Corsair RM850 80 Plus Gold semi-passive 850W fu... Thermaltake Chaser A71 Miscorosft USB wired 
AudioOtherOther
On board Microsoft HD webcam and Microsoft Lifechat headset Logitech Z323 2.1 speakers 
  hide details  
Reply
post #7 of 9
My settings are both set to that. Unfortunately I cannot answer that question for you as it's outside of my scope of knowledge for video decoding and such. Good to see you have it fixed, though!
 
TBA
(14 items)
 
 
CPUMotherboardGraphicsRAM
i7 4770k [4.2GHz] Gigabyte Z97N G5 Titan X P [12GB] G.Skill Ripjaw X [16GB] 
Hard DriveHard DriveCoolingCooling
Kingston HyperX Savage [480GB] Mushkin Enhanced Reactor [1TB] Noctua NH-C14S + F120MP Phanteks PH-F120MP [x2] 
OSMonitorKeyboardPower
Windows 10 Professional [x64] Acer Predator X34 HHKB Pro 2 Corsair SF600 [600w] 
CaseMouseMouse PadAudio
NCASE M1 [v5] Logitech G900 QcK+ [Vault 111 Ed.] Schiit Bifrost Uber + Schiit Asgard 2 + TH-X00... 
CPUMotherboardGraphicsRAM
Penitum G3258 ASRock Z97E-ITX/ac ASUS GTX 1070 FE Kingston HyperX Fury DDR3 1866 [White Ed.] 
Hard DriveCoolingOSMonitor
Kingston HyperX 3K [120GB] Phanteks PH-TC14PE  Win 10 Pro [x64] Dell UltraSharp U2713HM [2K] 
KeyboardPowerCaseMouse
KC60 [Miami Ed.] EVGA 550 G2 Phanteks Enthoo Evolv ITX [White] Rival 300 [Fade] 
Mouse PadAudio
SS QcK Heavy Massdrop x HiFiMAN HE-350 
  hide details  
Reply
 
TBA
(14 items)
 
 
CPUMotherboardGraphicsRAM
i7 4770k [4.2GHz] Gigabyte Z97N G5 Titan X P [12GB] G.Skill Ripjaw X [16GB] 
Hard DriveHard DriveCoolingCooling
Kingston HyperX Savage [480GB] Mushkin Enhanced Reactor [1TB] Noctua NH-C14S + F120MP Phanteks PH-F120MP [x2] 
OSMonitorKeyboardPower
Windows 10 Professional [x64] Acer Predator X34 HHKB Pro 2 Corsair SF600 [600w] 
CaseMouseMouse PadAudio
NCASE M1 [v5] Logitech G900 QcK+ [Vault 111 Ed.] Schiit Bifrost Uber + Schiit Asgard 2 + TH-X00... 
CPUMotherboardGraphicsRAM
Penitum G3258 ASRock Z97E-ITX/ac ASUS GTX 1070 FE Kingston HyperX Fury DDR3 1866 [White Ed.] 
Hard DriveCoolingOSMonitor
Kingston HyperX 3K [120GB] Phanteks PH-TC14PE  Win 10 Pro [x64] Dell UltraSharp U2713HM [2K] 
KeyboardPowerCaseMouse
KC60 [Miami Ed.] EVGA 550 G2 Phanteks Enthoo Evolv ITX [White] Rival 300 [Fade] 
Mouse PadAudio
SS QcK Heavy Massdrop x HiFiMAN HE-350 
  hide details  
Reply
post #8 of 9
Post-processing applies a number of filters to help smooth out artifacts caused by prior digital compression/shortcomings and/or scaling from lower resolution. In some cases it will also inadvertently remove intended detail. The time to use it is when you're watching something that has obvious compression artifacts or is being blown up from lower resolution. If the content on tap is pretty good (like approaching say, bluray), then leaving the post processing turned off may result in a more accurate presentation. Some films or scenes are intentionally grainy and there is nothing wrong with leaving them that way while watching.
     
CPUMotherboardGraphicsRAM
FX-8350 990X EVO R2.0 Sparkle GTX460 768MB ballistix tactical 2 x 8GB 
Hard DriveHard DriveOptical DriveCooling
Toshiiba THNSNH 256GB Enterprise RE3 1TB Asus BD combo drive Artic A30 
OSMonitorMonitorMonitor
Manjaro Linux Samsung 21.5" LCD E2009WFP E2009WFP 
PowerCase
Seasonic G 550W Modular Fractal Design Core 3500 
CPUMotherboardGraphicsRAM
FX-6300, 4.7 GHZ@1.43V GA-970A-UD3P GTX 460 768MB Mixed DIMMs. 2x4GB + 2x8GB @ 1600-8-8-8 
Hard DriveHard DriveHard DriveHard Drive
Toshiba THNSNH 19nm 256GB 1TB Spinpoint F3 WD RE3 1TB WD RE3 1TB 
Optical DriveCoolingOSOS
yes CM Seidon 120V SolydK OpenSuse 13.1 
OSOSMonitorMonitor
Linux Mint 9-32 bit // Linux Mint 17-64 bit  Manjaro Xfce Samsung 21.5" HannsG 21.5" sideways! 
KeyboardPowerCaseMouse
Sticky ATNG Rosewill Green 630W NZXT Gamma Basic Microsoft corded 
CPUMotherboardGraphicsRAM
A10-6800k 4.8GHZ @ 1.375V, 1.2GHZ iGPU Gigabyte GA-F2A85XN-WIFI HD8670D Ripjaws 
Hard DriveOptical DriveCoolingOS
Seagate ST1000DM003 Asus BC-12B1ST/BLK/B/AS Zalman CNPS5X Linux Mint 15 
MonitorKeyboardPowerCase
LG IPS224V-PN Logitec K360 FSP 400W Aurum S 80+ gold Prodigy 
Mouse
logitec M235 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
FX-8350 990X EVO R2.0 Sparkle GTX460 768MB ballistix tactical 2 x 8GB 
Hard DriveHard DriveOptical DriveCooling
Toshiiba THNSNH 256GB Enterprise RE3 1TB Asus BD combo drive Artic A30 
OSMonitorMonitorMonitor
Manjaro Linux Samsung 21.5" LCD E2009WFP E2009WFP 
PowerCase
Seasonic G 550W Modular Fractal Design Core 3500 
CPUMotherboardGraphicsRAM
FX-6300, 4.7 GHZ@1.43V GA-970A-UD3P GTX 460 768MB Mixed DIMMs. 2x4GB + 2x8GB @ 1600-8-8-8 
Hard DriveHard DriveHard DriveHard Drive
Toshiba THNSNH 19nm 256GB 1TB Spinpoint F3 WD RE3 1TB WD RE3 1TB 
Optical DriveCoolingOSOS
yes CM Seidon 120V SolydK OpenSuse 13.1 
OSOSMonitorMonitor
Linux Mint 9-32 bit // Linux Mint 17-64 bit  Manjaro Xfce Samsung 21.5" HannsG 21.5" sideways! 
KeyboardPowerCaseMouse
Sticky ATNG Rosewill Green 630W NZXT Gamma Basic Microsoft corded 
CPUMotherboardGraphicsRAM
A10-6800k 4.8GHZ @ 1.375V, 1.2GHZ iGPU Gigabyte GA-F2A85XN-WIFI HD8670D Ripjaws 
Hard DriveOptical DriveCoolingOS
Seagate ST1000DM003 Asus BC-12B1ST/BLK/B/AS Zalman CNPS5X Linux Mint 15 
MonitorKeyboardPowerCase
LG IPS224V-PN Logitec K360 FSP 400W Aurum S 80+ gold Prodigy 
Mouse
logitec M235 
  hide details  
Reply
post #9 of 9
Thread Starter 
Thank you for the explanation!
    
CPUMotherboardGraphicsRAM
Intel Core i5-6600 (Skylake) Gigabyte GA-Z170X-Gaming 3 MSI GeForce GTX 1070 GAMING X 8G 16GB Corsair Vengeance LPX 2400MHz DDR4 
Hard DriveCoolingOSMonitor
Samsung 850 Evo 500GB SSD Cooler Master Hyper 212X Windows 10 Home Acer 27" 1920x1080 
KeyboardPowerCaseMouse
Microsoft USB wired Corsair RM850 80 Plus Gold semi-passive 850W fu... Thermaltake Chaser A71 Miscorosft USB wired 
AudioOtherOther
On board Microsoft HD webcam and Microsoft Lifechat headset Logitech Z323 2.1 speakers 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i5-6600 (Skylake) Gigabyte GA-Z170X-Gaming 3 MSI GeForce GTX 1070 GAMING X 8G 16GB Corsair Vengeance LPX 2400MHz DDR4 
Hard DriveCoolingOSMonitor
Samsung 850 Evo 500GB SSD Cooler Master Hyper 212X Windows 10 Home Acer 27" 1920x1080 
KeyboardPowerCaseMouse
Microsoft USB wired Corsair RM850 80 Plus Gold semi-passive 850W fu... Thermaltake Chaser A71 Miscorosft USB wired 
AudioOtherOther
On board Microsoft HD webcam and Microsoft Lifechat headset Logitech Z323 2.1 speakers 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD - General
Overclock.net › Forums › AMD › AMD - General › Poor full HD video playback performance on my AMD desktop computer - any idea please?