Overclock.net › Forums › Graphics Cards › AMD/ATI › Fix for vertical screen tearing with eyefinity
New Posts  All Forums:Forum Nav:

Fix for vertical screen tearing with eyefinity

post #1 of 4
Thread Starter 
Thought I would post this in case anyone else is having the same problem.
The Problem
Since I started using eyefinity with my 7950 I have had a section of one of my screens that always seems to have a "vertical" screen tear on it. When anything moved on this display, part of the display would update at the same speed as the rest of my panels, but the other part would seem to lag behind a bit. This causes a vertical bar to appear across the screen that was similar to a screen tear, but always appeared in the same spot. The tear was only visible when there was movement in its location.
Old Setup
I used to be using 2 monitors connect by mini display port and one on DVI. Monitors were 3 Samsung SA850s. GPU a Gigabyte Windforce 7950.
Attempted fixes
Tried running displays in both portrait and landscape mode. Both configs had the vertical tear. Also tried changing which displays were hooked to DVI. The display hooked to DVI always had the tear on it.

Solution
Just got a Club3D 1 -> 3 displayport (MST) hub today. For some reason I can't run 3 displays off the hub, but with 2 running off the hub and one running off my gpu's other displayport output I no longer have any vertical screen tearing issue.

Seems I can only connect 2 dispaly to the hub due to possible bandwidth restrictions. My displays are only running at 60Hz, but Catalyst seems to think they may be able to do 75Hz somehow (will have to look into this more in the future).



Also if any Canadians are looking for a mst hub, Canada Computers sells them:
http://www.canadacomputers.com/product_info.php?cPath=44_689&item_id=062631
ζ Puppis
(17 items)
 
γ Serpentis
(9 items)
 
α Centauri
(12 items)
 
CPUMotherboardGraphicsRAM
3570k Gigabyte Z77X-UD5H Club 3D 295x2 (x2) Patriot Viper (4x8GB) 
Hard DriveHard DriveCoolingCooling
Samsung 840 EVO Western Digital Black (750GB) (x2) EK Supremacy EVO Full Nickle EK-FC R9-295X2 - Nickel (x2) 
CoolingCoolingOSMonitor
Swiftech MCP655 (x2) Bitfenix Spectre PWM 140mm (x12) Windows 8.1 Samsung S27A850D (x6) 
MonitorKeyboardPowerCase
Wacom 24HD Touch Das Keyboard 4 Ultimate (MX Blue) Enermax Maxrevo 1500 Lian-Li PC-A71F 
Other
AverMedia Live Gamer HD 
CPUMotherboardGraphicsRAM
Intel Q9450 EVGA nForce 780i SLI EVGA 9800GT Kingston HyperX DDR2 (4x2GB) 
Hard DriveHard DriveHard DriveHard Drive
Intel 320 SSD 160 GB WD Caviar Black 2TB WD Caviar Black 2TB WD Caviar Black 2TB 
Hard DriveHard DriveOSCase
WD Caviar Black 2TB WD Caviar Black 2TB Windows Server 2012 R2 HP Blackbird 002 
  hide details  
Reply
ζ Puppis
(17 items)
 
γ Serpentis
(9 items)
 
α Centauri
(12 items)
 
CPUMotherboardGraphicsRAM
3570k Gigabyte Z77X-UD5H Club 3D 295x2 (x2) Patriot Viper (4x8GB) 
Hard DriveHard DriveCoolingCooling
Samsung 840 EVO Western Digital Black (750GB) (x2) EK Supremacy EVO Full Nickle EK-FC R9-295X2 - Nickel (x2) 
CoolingCoolingOSMonitor
Swiftech MCP655 (x2) Bitfenix Spectre PWM 140mm (x12) Windows 8.1 Samsung S27A850D (x6) 
MonitorKeyboardPowerCase
Wacom 24HD Touch Das Keyboard 4 Ultimate (MX Blue) Enermax Maxrevo 1500 Lian-Li PC-A71F 
Other
AverMedia Live Gamer HD 
CPUMotherboardGraphicsRAM
Intel Q9450 EVGA nForce 780i SLI EVGA 9800GT Kingston HyperX DDR2 (4x2GB) 
Hard DriveHard DriveHard DriveHard Drive
Intel 320 SSD 160 GB WD Caviar Black 2TB WD Caviar Black 2TB WD Caviar Black 2TB 
Hard DriveHard DriveOSCase
WD Caviar Black 2TB WD Caviar Black 2TB Windows Server 2012 R2 HP Blackbird 002 
  hide details  
Reply
post #2 of 4
Running into the same problem right now with two crossfired 7970s in eyefinity connected to three Dell U2311H monitors in portrait mode. Unfortunately the cards only have one DP out and because of eyefinity I have to connect all monitors to the primary card. So I ended up with center monitor on DP and the others on DVI. Center monitor runs fine but I get tearing on both the left and right monitor which is driving me bonkers. Been looking for solutions and the Club3D hub is the only thing I can find so far that may address the issue. My cards have DP 1.2 outs but my monitors only DP 1.1. Trying to find out if that will cause problems with bandwidth limitations. DP 1.2 card --> DP 1.2 Hub --> 3 DP 1.1 monitors.

Do you know what DP version your Samsungs are using? I looked at the Samsung product page but the support documentation doesn't clarify.

Your limitation on the number of monitors definitely is a bandwidth issue. As per the specs on the product page for 1440p it maxes out at two monitors at 60Hz.
post #3 of 4
Thread Starter 
I can't find any thing about what version of display port is being used, but page 5 of this document seems to show it would work.

http://www.amd.com/us/Documents/50279_AMD_FirePro_DisplayPort_1-2_WP.pdf

I'm thinking since it doesn't matter what type of connection is coming out of the hub, it shouldn't matter which version of display port the monitor has.
ζ Puppis
(17 items)
 
γ Serpentis
(9 items)
 
α Centauri
(12 items)
 
CPUMotherboardGraphicsRAM
3570k Gigabyte Z77X-UD5H Club 3D 295x2 (x2) Patriot Viper (4x8GB) 
Hard DriveHard DriveCoolingCooling
Samsung 840 EVO Western Digital Black (750GB) (x2) EK Supremacy EVO Full Nickle EK-FC R9-295X2 - Nickel (x2) 
CoolingCoolingOSMonitor
Swiftech MCP655 (x2) Bitfenix Spectre PWM 140mm (x12) Windows 8.1 Samsung S27A850D (x6) 
MonitorKeyboardPowerCase
Wacom 24HD Touch Das Keyboard 4 Ultimate (MX Blue) Enermax Maxrevo 1500 Lian-Li PC-A71F 
Other
AverMedia Live Gamer HD 
CPUMotherboardGraphicsRAM
Intel Q9450 EVGA nForce 780i SLI EVGA 9800GT Kingston HyperX DDR2 (4x2GB) 
Hard DriveHard DriveHard DriveHard Drive
Intel 320 SSD 160 GB WD Caviar Black 2TB WD Caviar Black 2TB WD Caviar Black 2TB 
Hard DriveHard DriveOSCase
WD Caviar Black 2TB WD Caviar Black 2TB Windows Server 2012 R2 HP Blackbird 002 
  hide details  
Reply
ζ Puppis
(17 items)
 
γ Serpentis
(9 items)
 
α Centauri
(12 items)
 
CPUMotherboardGraphicsRAM
3570k Gigabyte Z77X-UD5H Club 3D 295x2 (x2) Patriot Viper (4x8GB) 
Hard DriveHard DriveCoolingCooling
Samsung 840 EVO Western Digital Black (750GB) (x2) EK Supremacy EVO Full Nickle EK-FC R9-295X2 - Nickel (x2) 
CoolingCoolingOSMonitor
Swiftech MCP655 (x2) Bitfenix Spectre PWM 140mm (x12) Windows 8.1 Samsung S27A850D (x6) 
MonitorKeyboardPowerCase
Wacom 24HD Touch Das Keyboard 4 Ultimate (MX Blue) Enermax Maxrevo 1500 Lian-Li PC-A71F 
Other
AverMedia Live Gamer HD 
CPUMotherboardGraphicsRAM
Intel Q9450 EVGA nForce 780i SLI EVGA 9800GT Kingston HyperX DDR2 (4x2GB) 
Hard DriveHard DriveHard DriveHard Drive
Intel 320 SSD 160 GB WD Caviar Black 2TB WD Caviar Black 2TB WD Caviar Black 2TB 
Hard DriveHard DriveOSCase
WD Caviar Black 2TB WD Caviar Black 2TB Windows Server 2012 R2 HP Blackbird 002 
  hide details  
Reply
post #4 of 4
That's what I was thinking - that it shouldn't matter as long as the graphics card and hub run under 1.2. I just was hoping for positive confirmation. I'm somewhat annoyed that I am looking at a $150 "fix" for something that should have been working out of the box.

Almost makes me want to go out and get a decent 1440p monitor instead. rolleyes.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Fix for vertical screen tearing with eyefinity