Overclock.net › Forums › Components › Mice › Steelseries Rival
New Posts  All Forums:Forum Nav:

Steelseries Rival - Page 120

post #1191 of 2803
Quote:
Originally Posted by vss vintorez View Post

I would suggest to install the driver, set the mouse up and then uninstall it or try to play with the mouse on another pc which hasn't the driver installed.
Well I tried it both with and without drivers but it doesn't make any difference.
Quote:
Originally Posted by gnrtb View Post

Mariachi - my LOD is like you said with goliathus speed (textured like QCK, nothing like the control edition) ... I don't think your mouse pad will give you any problem. Anyway if it is sluggish after some time, it is 100% a software issue, honestly there's nothing to try other than reinstalling windows IMO. Also try to update bios before you reinstall, maybe your USB rom will be different.
Actually I did all these numerous times. I installed windows for several times, tried it with no updates/with updates, using mouse with and without drivers, messing with regedit, windows and bios settungs, updated bios to the newest version, checked voltage of usb ports and so on. Yesterday I tried to load safe mode and mouse was ok. But still I'm not sure that this is absolutely software issue. Maybe several bios flashes could somehow start to kill my motherboard.
Edited by Mariachi - 4/16/14 at 5:17am
post #1192 of 2803
So if none feels the input lags it's a placebo, as i said already.
While lift off distance is for sure lower hence people who swipe around the lift on/off change are getting the spazz out which they had not before, my theory.

If you do the swipes on the mousepad it won't ever do that.
post #1193 of 2803
That might be why. I got an Asus VG248QE and i don't have this input lag issue some people are talking about.
post #1194 of 2803
Hey, I just bought the Rival and I am having no issues. I love it so far. I was just wondering if I should update the firmware on this mouse?
post #1195 of 2803
Quote:
Originally Posted by Buckmoney View Post

Hey, I just bought the Rival and I am having no issues. I love it so far. I was just wondering if I should update the firmware on this mouse?

yeah update it to the newest firmware after that you will ove the new feel its amazing
post #1196 of 2803
Quote:
Originally Posted by James N View Post

That might be why. I got an Asus VG248QE and i don't have this input lag issue some people are talking about.

I have the same monitor. I've never felt this whole smoothing crap people keep talking about.
L1m1t
(22 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5 GHz ASUS P8Z68-V LX ASUS DirectCU II GTX 770 OC Patriot G2 
Hard DriveHard DriveCoolingOS
Western Digital Caviar Black Kingston SSDNow Cooler Master Hyper 212+ Windows 8.1 x64 
MonitorKeyboardPowerCase
ASUS VG248QE SteelSeries 6Gv2 MX Red Corsair TX650 NZXT Source 210 
MouseMouse PadAudioAudio
Zowie FK1 Puretrak Talent ASUS Xonar DG Sennheiser PC350 
AudioAudioAudioAudio
Creative Fatal1ty HS-800 Shure SRH440 Audio Technica ATH-M40x AKG K701 
AudioAudio
beyerdynamic DT770 AKG K550 
  hide details  
Reply
L1m1t
(22 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5 GHz ASUS P8Z68-V LX ASUS DirectCU II GTX 770 OC Patriot G2 
Hard DriveHard DriveCoolingOS
Western Digital Caviar Black Kingston SSDNow Cooler Master Hyper 212+ Windows 8.1 x64 
MonitorKeyboardPowerCase
ASUS VG248QE SteelSeries 6Gv2 MX Red Corsair TX650 NZXT Source 210 
MouseMouse PadAudioAudio
Zowie FK1 Puretrak Talent ASUS Xonar DG Sennheiser PC350 
AudioAudioAudioAudio
Creative Fatal1ty HS-800 Shure SRH440 Audio Technica ATH-M40x AKG K701 
AudioAudio
beyerdynamic DT770 AKG K550 
  hide details  
Reply
post #1197 of 2803
Quote:
Originally Posted by James N View Post

That might be why. I got an Asus VG248QE and i don't have this input lag issue some people are talking about.

Are you on Windows 8.1?
R116
(23 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 5820k @ 4.6GHz / 4.3GHz Asus X99 Deluxe Nvidia GTX 980Ti 4 X 4GB G.Skill Ripjaws 4  
Hard DriveHard DriveCoolingCooling
Seagate Barracuda 2TB Samsung 850 Evo 250GB EK Supremacy Evo  EK Mosfet X99 
CoolingCoolingCoolingCooling
EK-FC Titan X Alphacool NexXxos XT45 360 Alphacool NexXxos UT60 240 Alphacool VPP655T + EK D5 X-RES 200 CSQ 
CoolingCoolingOSMonitor
Corsair SP120 x5 Corsair AF140 x1 Windows 10 Pro x64 Benq XL2730Z @ 144Hz 
KeyboardPowerCaseMouse
CM Storm Quickfire TK EVGA 850W Supernova G2 Corsair 750D Zowie EC2-A 
Mouse PadAudioOther
OCUK Mega Mat / Steelseries QCK+ CREATIVE Soundblaster Z mCubed T-Balancer 
  hide details  
Reply
R116
(23 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 5820k @ 4.6GHz / 4.3GHz Asus X99 Deluxe Nvidia GTX 980Ti 4 X 4GB G.Skill Ripjaws 4  
Hard DriveHard DriveCoolingCooling
Seagate Barracuda 2TB Samsung 850 Evo 250GB EK Supremacy Evo  EK Mosfet X99 
CoolingCoolingCoolingCooling
EK-FC Titan X Alphacool NexXxos XT45 360 Alphacool NexXxos UT60 240 Alphacool VPP655T + EK D5 X-RES 200 CSQ 
CoolingCoolingOSMonitor
Corsair SP120 x5 Corsair AF140 x1 Windows 10 Pro x64 Benq XL2730Z @ 144Hz 
KeyboardPowerCaseMouse
CM Storm Quickfire TK EVGA 850W Supernova G2 Corsair 750D Zowie EC2-A 
Mouse PadAudioOther
OCUK Mega Mat / Steelseries QCK+ CREATIVE Soundblaster Z mCubed T-Balancer 
  hide details  
Reply
post #1198 of 2803
Quote:
Originally Posted by Razor 116 View Post

Are you on Windows 8.1?

idk about him but I am on 8.1 with this monitor and no latency here.
L1m1t
(22 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5 GHz ASUS P8Z68-V LX ASUS DirectCU II GTX 770 OC Patriot G2 
Hard DriveHard DriveCoolingOS
Western Digital Caviar Black Kingston SSDNow Cooler Master Hyper 212+ Windows 8.1 x64 
MonitorKeyboardPowerCase
ASUS VG248QE SteelSeries 6Gv2 MX Red Corsair TX650 NZXT Source 210 
MouseMouse PadAudioAudio
Zowie FK1 Puretrak Talent ASUS Xonar DG Sennheiser PC350 
AudioAudioAudioAudio
Creative Fatal1ty HS-800 Shure SRH440 Audio Technica ATH-M40x AKG K701 
AudioAudio
beyerdynamic DT770 AKG K550 
  hide details  
Reply
L1m1t
(22 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5 GHz ASUS P8Z68-V LX ASUS DirectCU II GTX 770 OC Patriot G2 
Hard DriveHard DriveCoolingOS
Western Digital Caviar Black Kingston SSDNow Cooler Master Hyper 212+ Windows 8.1 x64 
MonitorKeyboardPowerCase
ASUS VG248QE SteelSeries 6Gv2 MX Red Corsair TX650 NZXT Source 210 
MouseMouse PadAudioAudio
Zowie FK1 Puretrak Talent ASUS Xonar DG Sennheiser PC350 
AudioAudioAudioAudio
Creative Fatal1ty HS-800 Shure SRH440 Audio Technica ATH-M40x AKG K701 
AudioAudio
beyerdynamic DT770 AKG K550 
  hide details  
Reply
post #1199 of 2803
I've got Acer p223w. Using it for about 6 years and never felt latency. Yesterday I played with rival without any software and it was ok. But sometimes I get the feeling that mouse is like hovering. Don't know how to describe.
Still is there any way I can check monitor? And is it possible that nvidia drivers do this to mouse?
post #1200 of 2803
my post was removed for a word I used lol
so again

I bet this is a monitor issue. I never seen it discussed before, but after tons of testing with my DELL E228WFP, it had worse input lag randomly. I was going crazy for months, switching from Win 7, to 8, to vista! just to be able to play BF3 as good as I want. Tried flashing wrong gpu bios (from different company), not installing drivers (except GPU), screwing with the HPET myths,trying all the 3 gpu outputs ... until I tried another LCD and realized mine had huge input lag sometimes.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › Steelseries Rival