Overclock.net › Forums › Cooling › Water Cooling › Bubble keep forming and goin into pump
New Posts  All Forums:Forum Nav:

Bubble keep forming and goin into pump

post #1 of 3
Thread Starter 


So recently i redid my loop since i got a new pump (Swiftech MCP665). So pretty much the loop goes Pump => Res/Pump (pump not plugged in - xspc x2o 750) => cpu => rad => pump with a drain plug on the bottom.

As the purple arrow shows, this is where the bubble/air pocket keeps forming and going into my pump, causing noise periodically =/ any idea why a bubble keeps forming there? i tried to shake out the bubbles that were probably in the radiator, but i guess it didnt help.

any ideas ?
post #2 of 3
It's advisable to have your pump directly after your reservoir in loop order. How long has your system been running? Certain setups can take a while to bleed. Also speeding up and slowing down your pump can help. Also tilting your case 45 degrees in each direction can help bubbles find their way home.
post #3 of 3
Thread Starter 
Quote:
Originally Posted by Terrorbyte View Post

It's advisable to have your pump directly after your reservoir in loop order. How long has your system been running? Certain setups can take a while to bleed. Also speeding up and slowing down your pump can help. Also tilting your case 45 degrees in each direction can help bubbles find their way home.

i understand the concept of having the res first before pump ... due to limited space of the case, this is the best i can do.

the system runs 24/7 and its been going for.... a few days ? yeah i did the tilting thing as i had learned when i first got into w/c'ing last year.

*edit*

maybe ill try a way to put res before pump... tho wont look as clean but maybe would help.. theres an annoying "kink" kind of forming between pump and res that id like to get rid of anyway

*edit again*

re-did loop around pump area... most of the bubbles are gone. even the small ones ! had both pumps going for a while. periodically changed the speed on the MCP655.. helped push bubbles out of the rad and blocks. looks good now !


Edited by iandroo888 - 10/12/13 at 8:23pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › Bubble keep forming and goin into pump