post #1 of 1
Thread Starter 
I know there's a lot of Asrock lovers out there... but I'm pissed.

In November 2011 (for the mathematically challenged, that's slightly less than two years ago), I bought a ASRock Z68 Fatal1ty Gen3. It worked fine for about a year and a bit. Then one day, I went to bed with my PC on doing downloads or updates or something. In the morning, I went to go shut it off and was surprised to find it was already off. And then... wouldn't turn on. Yuk.

I assumed it was the PSU. Anyway, long story short, it was determined it was the Mobo and an RMA was appropriate. Fine. But this is a critical machine to me, so I sent the Mobo off to Asrock and bought another mid-range Gigabyte off Amazon to tide me over. Good thing too, because it took 2 months for the Asrock to get back to me!

Anyway, I let it sit in the box until just yesterday when I decided to put it back in the system (the Gigabyte, for whatever reason, can't control fan speed so it finally annoyed me enough to do something).

At first it wouldn't boot. It would start to, and then just shut off and cycle. Hmmm... I pulled a few connectors out and put them back in and then it booted so I guess that worked (in hindsight, I think this was just coincidence). I had a few video issues, so I made some changes to the video card arrangement and then I had that power cycling issue again. ***? Pulled out all the video cards, and I got it to boot again. Put the video cards back in, and it booted again. OK, weird, but it works (again, in hindsight I think that was just coincidence and the pulling/replacing components has nothing to do with anything). I figured I should check for a bios update just in case whatever version was on there (I didn't check) was causing that weird issue. I see they ONLY list beta for that board w/ Windows 8... but it dates to 2012 so surely its stable, right? Flashing process goes as one would expect, right up until it finishes. Says to click OK (or whatever) to reboot. The weird thing was that the INSTANT I clicked the button, the power shut off.... that felt strange. No shutdown, no thinking for a split second... just "poof". OK, maybe that's normal, I don't know. But since that moment... I get an even more rapid boot cycle.

The onboard LED diagnostic gets to 4F where it sits for half a second, then it flashes what looks like 62 but its so quick I'm not sure, then dies and tries again. Over, and over, and over. Lights are on, fans are on... nobody's home.

I know ALL components are good as they work in the Gigabyte mobo. I know ALL components are compatible, as they worked in the Asrock originally. JUST in case the Gigabyte is more "forgiving" than the Asrock, I went and bought a brand new PSU last night and gave that a try this morning... no difference. I've completely breadboarded it with just 1 stick of ram (which I've swapped with the other 3 and used every position... just in case). So its not the CPU, its not the RAM, its not the PSU... it can't be any other component since they're all removed.

I removed the BIOS chip... that changes to now it cycles even more rapidly. No display on the onboard LED at all, just fans and lights on, then off, then on, then off... that tells me perhaps it is the bios chip that's the problem. And that's a simple enough solution too... but should I even bother? I don't have any confidence that's the ONLY problem. I think there's a bigger issue with this board, and the power happened to turn off at the end of the BIOS update which ALSO corrupted the BIOS.

But I don't know.

One last thing: During the RMA, they said that I'd get a new board "from Asia supply". I think now, what that means is: "we send you a crappier version that we'd normally sell in China where people expect crappier things". Why? I swear the board is thinner than the original I had. The whole thing flexes visibly in the middle, and when inserting the CPU cooler (or anything that requires any pressure at all), I hear a disgusting crackling sound in the PCB. Also, on the back, there's those spring-loaded screws (probably the wrong word, but they're on the back of my Gigabyte too so I guess they're standard... they look like screws with a spring between the board and the screw head) and one of them is obviously mis-threaded (in at an angle). I half expect the paint to come off on my fingers. This board just feels "cheap" compared to the one I sent them.

So this post is mostly a rant. But if anyone has any suggestions, I'm up for it.

ps. its still under warranty (2 years). But I don't know if I want to bother frown.gif Just the postage costs are enough to make me cringe right now