Overclock.net › Forums › Components › Power Supplies › Troubleshooting this PSU?
New Posts  All Forums:Forum Nav:

Troubleshooting this PSU?

post #1 of 3
Thread Starter 
Short story:
I purchased Thermaltake TR-600 new power supply probably about six months ago. It's not POSTing, but on occasion I've gotten it to boot and it runs without problem, which is what is confusing me.

Details:
Started to happen a little after I moved to a new apartment. Was working great until I went to hook it up to my TV. And since then, no matter what outlet I use, it's not POSTing. (I'm unsure of the configuration of the power circuits, but I've got now power problems elsewhere.) I did get it to post twice after waiting at least 8 hours. But no avail this past weekend. I've incrementally torn down the components to the bare minimum and double checked some wires. I did notice some very minor grime on back of the motherboard near the top, but all the caps look fine.

Looking for some ideas to try
post #2 of 3
Which TR-2 did you get?

W0388RU
TR-600
TR-600P

If you got a W0388RU forget all about it stomp on it kick it then smash it with a hammer and set it on fire
Seravee
(23 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core I7 6850K Gigabyte X99 Ultra Gaming EVGA GTX 1080 FTW2 Kingston HyperX DDR4 Savage 3000 MHz 
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 Evo WD Green WD40EZRX  WD Green WD60EZRX  WD Red WD80EFZX 8TB  
Optical DriveCoolingCoolingOS
LG CH12NS30 5x Noctua NF-A14 FLX Noctua NH-D15S Windows 7 64 Bit 
MonitorKeyboardPowerCase
Asus PG279Q Corsair Gaming Strafe RGB EVGA SuperNova G2 750 watt Phanteks Enthoo Luxe 
MouseMouse PadAudioAudio
Roccat Kone XTD Laser Roccat Sense Metor Sennheiser HD 598 Onkyo TX NR646  
AudioOtherOther
Harman Kardon HKTS 60 CableMod E series PSU cable set CableMod LED Strips 
  hide details  
Reply
Seravee
(23 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core I7 6850K Gigabyte X99 Ultra Gaming EVGA GTX 1080 FTW2 Kingston HyperX DDR4 Savage 3000 MHz 
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 Evo WD Green WD40EZRX  WD Green WD60EZRX  WD Red WD80EFZX 8TB  
Optical DriveCoolingCoolingOS
LG CH12NS30 5x Noctua NF-A14 FLX Noctua NH-D15S Windows 7 64 Bit 
MonitorKeyboardPowerCase
Asus PG279Q Corsair Gaming Strafe RGB EVGA SuperNova G2 750 watt Phanteks Enthoo Luxe 
MouseMouse PadAudioAudio
Roccat Kone XTD Laser Roccat Sense Metor Sennheiser HD 598 Onkyo TX NR646  
AudioOtherOther
Harman Kardon HKTS 60 CableMod E series PSU cable set CableMod LED Strips 
  hide details  
Reply
post #3 of 3
Thread Starter 
Nah, for records sake it's a TR2-600NL2NG. I'll just RMA it if I can find a receipt since I'm fairly certain the PSU is the problem.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › Troubleshooting this PSU?