Overclock.net › Forums › General Hardware › General Processor Discussions › Random PSU with newer mobo (Connection problems)
New Posts  All Forums:Forum Nav:

Random PSU with newer mobo (Connection problems)

post #1 of 2
Thread Starter 
Hey everyone, I recently bought this: for $25






The plan was to buy all the components for cheap and make myself a half decent desktop so I can learn how to build a computer.

When I bought this I did not know it would be coming with a mobo, CPU and quite a bit of ram.
This also came with a PSU that was mentioned. I'm not going to complain about free stuff!

The PSU that came with this is not the original... So there are a few little problems...

  • The first one being that the 4 pin ATX 12v CPU power cord does not reach the socket... Would something like this: http://www.ebay.com.au/itm/180636960005 fix this problem?
  • The second thing being that this PSU does not come with Any PCI-e power connectors that would be used if I was to install a GPU, there are two molex connectors free though. Is there some way I can use these instead? Another thing I am wondering about... Do ALL GPU's require their own direct power source?
  • The last thing I am wondering about is that my mobo ( http://www.asus.com/Motherboards/M2NE_SLI/#specifications ) has a 24 pin main power connection while my PSU only has a 20 pin connector, I know it would work, but will this cause some trouble in the future?


Also, there is a chance that the mobo/cpu (both or either) will be fried. Can I damage my GPU by trying to turn it on?




Thanks! smile.gif
Edited by Chillz - 10/15/13 at 5:12am
post #2 of 2
The 4 pin power extender will work fine.

You can get an adapter for 4 pin molex to 4 pin PCI.
Some (low power) video cards do not have an auxiliary power connector, and some that do will work without it powered.

There are 20 pin to 24 pin mobo power adapters.
Edited by billbartuska - 10/16/13 at 5:08am
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
FX6300 Black M5A99X EVO R2.0 Nvidia GTS450 Team Vulcan PC3 12800 
Hard DriveOptical DriveCoolingOS
Samsung 840 PRO Asus DRW-1608P (x2) Custom Water Cooling Win7 (Ult), Win 8.1 & Win Server 2012 R2 
MonitorKeyboardPowerCase
2 X Samsung 915N Ducky Shine III, Blue Cherry/Blue LEDs PCP&C 1kw Lian Li PC-71 (W/Window) 
MouseAudio
Logiteck G400s none 
  hide details  
Reply
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
FX6300 Black M5A99X EVO R2.0 Nvidia GTS450 Team Vulcan PC3 12800 
Hard DriveOptical DriveCoolingOS
Samsung 840 PRO Asus DRW-1608P (x2) Custom Water Cooling Win7 (Ult), Win 8.1 & Win Server 2012 R2 
MonitorKeyboardPowerCase
2 X Samsung 915N Ducky Shine III, Blue Cherry/Blue LEDs PCP&C 1kw Lian Li PC-71 (W/Window) 
MouseAudio
Logiteck G400s none 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: General Processor Discussions
Overclock.net › Forums › General Hardware › General Processor Discussions › Random PSU with newer mobo (Connection problems)