Overclock.net › Forums › Overclockers Care › Overclock.net Folding@Home Team › Disable web-control at app start & internet remote access for f@h clients?
New Posts  All Forums:Forum Nav:

Disable web-control at app start & internet remote access for f@h clients? - Page 2

post #11 of 19
Thread Starter 
Ok, this is what I'll do:

- access the router, and reserve the local network IP for the client that's running V7 (in case DHCP likes to play games on me tongue.gif);
- port forward the 36330 port for the local client's IP;
- use HFM or FAHControl to monitor everything.

The hardest part will be getting into the router since someone else set it up, hopefully no one tampered with the default id& password biggrin.gif

Sorry for the double post, I though I was editing the previous post redface.gif.
post #12 of 19
Quote:
Originally Posted by FIX_ToRNaDo View Post

Ok, this is what I'll do:

- access the router, and reserve the local network IP for the client that's running V7 (in case DHCP likes to play games on me tongue.gif);
- port forward the 36330 port for the local client's IP;
- use HFM or FAHControl to monitor everything.

The hardest part will be getting into the router since someone else set it up, hopefully no one tampered with the default id& password biggrin.gif

Sorry for the double post, I though I was editing the previous post redface.gif.
You've got it! 36330 would be the port. Just throw the public IP address into your computer that's running HFM and if you set it up correctly in the router, it should do the rest
post #13 of 19
I don't want to hijack this thread and I apologize, but I have some issues. Perhaps some help? tongue.gif

I've set up my workstation (assume name PC1) to fold on the CPU. All configuration should be good. Password-enabled remote connection @ port 4(figuratively). Router is set to forward incoming connections at port 3(figuratively) to PC1's local IP:4. I'm trying to connect the outside monitor (assume PC2) on port 3 and it all goes well - can see packets passing through the router.
And when I attempt to test my connection from HFM (PC2) I don't get an error, but no confirmation too. Only one packet has been forwarded.
Also, in F@H Control on PC1 I've allowed 0.0.0.0/0 for remote connections with none denied.
To represent it visually: (Click to show)

[PC1(F@H client)]:4- - - - - -port4:[Router]:port3- - - - - -port3:[PC2 (HFM)]

PC1 accepts password-protected attempts from any IP/port, passwordless from localhost only.
F@H runs on port 4 and remote connection is aimed at port 4 as well.

Traffic is forwarded from PC1 to PC2 but no data is fetched.
MEGATRON
(24 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i5-3570K @ 4.8/1.32V | Hammer&Vice'd ASUS Sabertooth Z77 PowerColor R9 290 PowerColor R9 290 
RAMHard DriveHard DriveCooling
Samsung MV-3V4G3D/US 4x4GB kit @ 2200MHz 9-10-1... 2x Western Digital Caviar Black 1TB RAID 0 Samsung 840 Evo 250GB 2xAquacomputer Kryographics Hawaii Nickel/Acrylic 
CoolingCoolingCoolingCooling
XSPC Rasa Swiftech MCP-655 Vario Aquacomputer Aqualis 450mm w/ nano & Pump top 2x XSPC RX360; 1x XSPC RS360; 1x Alphacool ST 1... 
CoolingOSMonitorMonitor
EK-Vardar F4-120 8.1 x64; Ubuntu 14.10 Dell U2412M Dell U2412M 
MonitorMonitorKeyboardPower
Dell U2312H BenQ XL2411Z KBC Poker II MX Clears SeaSonic SS-850AM 
CaseMouseMouse PadAudio
Thermaltake Core X9 Mionix AVIOR 7000 Razer Goliathus Aune T1 -> Yamaha A-720 -> Sennheiser HD650 | S... 
  hide details  
Reply
MEGATRON
(24 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i5-3570K @ 4.8/1.32V | Hammer&Vice'd ASUS Sabertooth Z77 PowerColor R9 290 PowerColor R9 290 
RAMHard DriveHard DriveCooling
Samsung MV-3V4G3D/US 4x4GB kit @ 2200MHz 9-10-1... 2x Western Digital Caviar Black 1TB RAID 0 Samsung 840 Evo 250GB 2xAquacomputer Kryographics Hawaii Nickel/Acrylic 
CoolingCoolingCoolingCooling
XSPC Rasa Swiftech MCP-655 Vario Aquacomputer Aqualis 450mm w/ nano & Pump top 2x XSPC RX360; 1x XSPC RS360; 1x Alphacool ST 1... 
CoolingOSMonitorMonitor
EK-Vardar F4-120 8.1 x64; Ubuntu 14.10 Dell U2412M Dell U2412M 
MonitorMonitorKeyboardPower
Dell U2312H BenQ XL2411Z KBC Poker II MX Clears SeaSonic SS-850AM 
CaseMouseMouse PadAudio
Thermaltake Core X9 Mionix AVIOR 7000 Razer Goliathus Aune T1 -> Yamaha A-720 -> Sennheiser HD650 | S... 
  hide details  
Reply
post #14 of 19
Thread Starter 
Quote:
Originally Posted by fragamemnon View Post

I don't want to hijack this thread and I apologize, but I have some issues. Perhaps some help? tongue.gif

I've set up my workstation (assume name PC1) to fold on the CPU. All configuration should be good. Password-enabled remote connection @ port 4(figuratively). Router is set to forward incoming connections at port 3(figuratively) to PC1's local IP:4. I'm trying to connect the outside monitor (assume PC2) on port 3 and it all goes well - can see packets passing through the router.
And when I attempt to test my connection from HFM (PC2) I don't get an error, but no confirmation too. Only one packet has been forwarded.
Also, in F@H Control on PC1 I've allowed 0.0.0.0/0 for remote connections with none denied.
To represent it visually: (Click to show)

[PC1(F@H client)]:4- - - - - -port4:[Router]:port3- - - - - -port3:[PC2 (HFM)]

PC1 accepts password-protected attempts from any IP/port, passwordless from localhost only.
F@H runs on port 4 and remote connection is aimed at port 4 as well.

Traffic is forwarded from PC1 to PC2 but no data is fetched.

I don't think I followed through your entire explanation. Let's see if I got this right.

You have two computers in your LAN, PC1 folds on the CPU and the other, PC2 is used to monitor PC1 through HFM.

You don't need to change the default port for the clients (36330), all you need to do is assign in HFM your PC1 local IP and the port 36330, plus the password when set.

Let me know what have I got wrong tongue.gif
post #15 of 19
Quote:
Originally Posted by FIX_ToRNaDo View Post

Quote:
Originally Posted by fragamemnon View Post

I don't want to hijack this thread and I apologize, but I have some issues. Perhaps some help? tongue.gif

I've set up my workstation (assume name PC1) to fold on the CPU. All configuration should be good. Password-enabled remote connection @ port 4(figuratively). Router is set to forward incoming connections at port 3(figuratively) to PC1's local IP:4. I'm trying to connect the outside monitor (assume PC2) on port 3 and it all goes well - can see packets passing through the router.
And when I attempt to test my connection from HFM (PC2) I don't get an error, but no confirmation too. Only one packet has been forwarded.
Also, in F@H Control on PC1 I've allowed 0.0.0.0/0 for remote connections with none denied.
To represent it visually: (Click to show)

[PC1(F@H client)]:4- - - - - -port4:[Router]:port3- - - - - -port3:[PC2 (HFM)]

PC1 accepts password-protected attempts from any IP/port, passwordless from localhost only.
F@H runs on port 4 and remote connection is aimed at port 4 as well.

Traffic is forwarded from PC1 to PC2 but no data is fetched.

I don't think I followed through your entire explanation. Let's see if I got this right.

You have two computers in your LAN, PC1 folds on the CPU and the other, PC2 is used to monitor PC1 through HFM.

You don't need to change the default port for the clients (36330), all you need to do is assign in HFM your PC1 local IP and the port 36330, plus the password when set.

Let me know what have I got wrong tongue.gif

Heh sorry, PC2 - the monitor, is my PC at home. And PC1 is my workstation at work, which is behind the firewall mentioned here. So they are not in the same LAN. And I should have the firewall set up right - I mean, I do this for a living and it should be fine. redface.gif Unless I am derping really hard somewhere.
Rather I miss something in the configuration of the client.

Edit: I just clicked the spoiler. I had an update there showing the cloud and describing both LANs. doh.gif I guess it didn't post before I closed the browser tab.
MEGATRON
(24 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i5-3570K @ 4.8/1.32V | Hammer&Vice'd ASUS Sabertooth Z77 PowerColor R9 290 PowerColor R9 290 
RAMHard DriveHard DriveCooling
Samsung MV-3V4G3D/US 4x4GB kit @ 2200MHz 9-10-1... 2x Western Digital Caviar Black 1TB RAID 0 Samsung 840 Evo 250GB 2xAquacomputer Kryographics Hawaii Nickel/Acrylic 
CoolingCoolingCoolingCooling
XSPC Rasa Swiftech MCP-655 Vario Aquacomputer Aqualis 450mm w/ nano & Pump top 2x XSPC RX360; 1x XSPC RS360; 1x Alphacool ST 1... 
CoolingOSMonitorMonitor
EK-Vardar F4-120 8.1 x64; Ubuntu 14.10 Dell U2412M Dell U2412M 
MonitorMonitorKeyboardPower
Dell U2312H BenQ XL2411Z KBC Poker II MX Clears SeaSonic SS-850AM 
CaseMouseMouse PadAudio
Thermaltake Core X9 Mionix AVIOR 7000 Razer Goliathus Aune T1 -> Yamaha A-720 -> Sennheiser HD650 | S... 
  hide details  
Reply
MEGATRON
(24 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i5-3570K @ 4.8/1.32V | Hammer&Vice'd ASUS Sabertooth Z77 PowerColor R9 290 PowerColor R9 290 
RAMHard DriveHard DriveCooling
Samsung MV-3V4G3D/US 4x4GB kit @ 2200MHz 9-10-1... 2x Western Digital Caviar Black 1TB RAID 0 Samsung 840 Evo 250GB 2xAquacomputer Kryographics Hawaii Nickel/Acrylic 
CoolingCoolingCoolingCooling
XSPC Rasa Swiftech MCP-655 Vario Aquacomputer Aqualis 450mm w/ nano & Pump top 2x XSPC RX360; 1x XSPC RS360; 1x Alphacool ST 1... 
CoolingOSMonitorMonitor
EK-Vardar F4-120 8.1 x64; Ubuntu 14.10 Dell U2412M Dell U2412M 
MonitorMonitorKeyboardPower
Dell U2312H BenQ XL2411Z KBC Poker II MX Clears SeaSonic SS-850AM 
CaseMouseMouse PadAudio
Thermaltake Core X9 Mionix AVIOR 7000 Razer Goliathus Aune T1 -> Yamaha A-720 -> Sennheiser HD650 | S... 
  hide details  
Reply
post #16 of 19
Thread Starter 
If you've opened port "4" (UDP/TCP) for PC1's local IP, that's what you have to use when trying to access it through HFM on PC2, plus the public IP the router at work is getting and the password.

You also might want to open those ports with the software firewall you're using.
post #17 of 19
Yeah. And, well my firewall is fine. :/ Packets are being transferred accordingly.

Meh I'll look into it tomorrow. Thanks though! If the issue is of another kind, I'll update the post.
MEGATRON
(24 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i5-3570K @ 4.8/1.32V | Hammer&Vice'd ASUS Sabertooth Z77 PowerColor R9 290 PowerColor R9 290 
RAMHard DriveHard DriveCooling
Samsung MV-3V4G3D/US 4x4GB kit @ 2200MHz 9-10-1... 2x Western Digital Caviar Black 1TB RAID 0 Samsung 840 Evo 250GB 2xAquacomputer Kryographics Hawaii Nickel/Acrylic 
CoolingCoolingCoolingCooling
XSPC Rasa Swiftech MCP-655 Vario Aquacomputer Aqualis 450mm w/ nano & Pump top 2x XSPC RX360; 1x XSPC RS360; 1x Alphacool ST 1... 
CoolingOSMonitorMonitor
EK-Vardar F4-120 8.1 x64; Ubuntu 14.10 Dell U2412M Dell U2412M 
MonitorMonitorKeyboardPower
Dell U2312H BenQ XL2411Z KBC Poker II MX Clears SeaSonic SS-850AM 
CaseMouseMouse PadAudio
Thermaltake Core X9 Mionix AVIOR 7000 Razer Goliathus Aune T1 -> Yamaha A-720 -> Sennheiser HD650 | S... 
  hide details  
Reply
MEGATRON
(24 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i5-3570K @ 4.8/1.32V | Hammer&Vice'd ASUS Sabertooth Z77 PowerColor R9 290 PowerColor R9 290 
RAMHard DriveHard DriveCooling
Samsung MV-3V4G3D/US 4x4GB kit @ 2200MHz 9-10-1... 2x Western Digital Caviar Black 1TB RAID 0 Samsung 840 Evo 250GB 2xAquacomputer Kryographics Hawaii Nickel/Acrylic 
CoolingCoolingCoolingCooling
XSPC Rasa Swiftech MCP-655 Vario Aquacomputer Aqualis 450mm w/ nano & Pump top 2x XSPC RX360; 1x XSPC RS360; 1x Alphacool ST 1... 
CoolingOSMonitorMonitor
EK-Vardar F4-120 8.1 x64; Ubuntu 14.10 Dell U2412M Dell U2412M 
MonitorMonitorKeyboardPower
Dell U2312H BenQ XL2411Z KBC Poker II MX Clears SeaSonic SS-850AM 
CaseMouseMouse PadAudio
Thermaltake Core X9 Mionix AVIOR 7000 Razer Goliathus Aune T1 -> Yamaha A-720 -> Sennheiser HD650 | S... 
  hide details  
Reply
post #18 of 19
Thread Starter 
Quote:
Originally Posted by fragamemnon View Post

Yeah. And, well my firewall is fine. :/ Packets are being transferred accordingly.

Meh I'll look into it tomorrow. Thanks though! If the issue is of another kind, I'll update the post.

Good luck thumb.gif
post #19 of 19
I figured it out. I used an apostrophe in my password and it wasn't escaped properly.
Code:
&apos
doh.gif
That also explains why I never got a connection success/fail prompt when I tried Test Connection.
MEGATRON
(24 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i5-3570K @ 4.8/1.32V | Hammer&Vice'd ASUS Sabertooth Z77 PowerColor R9 290 PowerColor R9 290 
RAMHard DriveHard DriveCooling
Samsung MV-3V4G3D/US 4x4GB kit @ 2200MHz 9-10-1... 2x Western Digital Caviar Black 1TB RAID 0 Samsung 840 Evo 250GB 2xAquacomputer Kryographics Hawaii Nickel/Acrylic 
CoolingCoolingCoolingCooling
XSPC Rasa Swiftech MCP-655 Vario Aquacomputer Aqualis 450mm w/ nano & Pump top 2x XSPC RX360; 1x XSPC RS360; 1x Alphacool ST 1... 
CoolingOSMonitorMonitor
EK-Vardar F4-120 8.1 x64; Ubuntu 14.10 Dell U2412M Dell U2412M 
MonitorMonitorKeyboardPower
Dell U2312H BenQ XL2411Z KBC Poker II MX Clears SeaSonic SS-850AM 
CaseMouseMouse PadAudio
Thermaltake Core X9 Mionix AVIOR 7000 Razer Goliathus Aune T1 -> Yamaha A-720 -> Sennheiser HD650 | S... 
  hide details  
Reply
MEGATRON
(24 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i5-3570K @ 4.8/1.32V | Hammer&Vice'd ASUS Sabertooth Z77 PowerColor R9 290 PowerColor R9 290 
RAMHard DriveHard DriveCooling
Samsung MV-3V4G3D/US 4x4GB kit @ 2200MHz 9-10-1... 2x Western Digital Caviar Black 1TB RAID 0 Samsung 840 Evo 250GB 2xAquacomputer Kryographics Hawaii Nickel/Acrylic 
CoolingCoolingCoolingCooling
XSPC Rasa Swiftech MCP-655 Vario Aquacomputer Aqualis 450mm w/ nano & Pump top 2x XSPC RX360; 1x XSPC RS360; 1x Alphacool ST 1... 
CoolingOSMonitorMonitor
EK-Vardar F4-120 8.1 x64; Ubuntu 14.10 Dell U2412M Dell U2412M 
MonitorMonitorKeyboardPower
Dell U2312H BenQ XL2411Z KBC Poker II MX Clears SeaSonic SS-850AM 
CaseMouseMouse PadAudio
Thermaltake Core X9 Mionix AVIOR 7000 Razer Goliathus Aune T1 -> Yamaha A-720 -> Sennheiser HD650 | S... 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Overclock.net Folding@Home Team
Overclock.net › Forums › Overclockers Care › Overclock.net Folding@Home Team › Disable web-control at app start & internet remote access for f@h clients?