post #1 of 1
Thread Starter 
This has been posted at a couple of other forums, but no real resolution, so I thought I'd try the venerable Overclock gang on this one.

For a couple of weeks now, I've been chasing some PCIe RAID port resets that are sent to my LSI 84016E RAID controller that I cannot seem to solve. For several weeks, the SAN performed great, and then began having regular and erratic Event 129 Reset to Device errors.

Anytime that the RAID is under load of any kind (it serves media for my XBMC HTPCs in the house, among other things), drive activity to the RAID volume will lock up for 60 seconds, and then resume, seemingly randomly. It's only current function is to serve media files out to HTPCs around the house via Windows File Sharing, however, prior to this, it was serving as a iSCSI mount for VMWare ESXi nodes. Total free space is around 40%.

The event log always shows an Event ID 129 with the message "Reset to device, \Device\RaidPort1, was issued" with the provider as megasas. The RAID card logs show NO ERRORS when this happens. The last troubleshooting I did was to unhook the drives from the RAID card and do a surface scan of each one with Hitachi's tool (around 6 hours per drive) and all came back clean. I've swapped cables, OS, motherboard and power supply in an attempt to pin it down.

This is a custom built SAN with the following specs:

  • CPU: FX-6100 Motherboard: ASUS M5A97 (current) MSI 970A-G43 (prior)
  • RAM: 32GB DDR3-1600
  • RAID Card: LSI 84016E in PCIex16 slot
  • Power Supply: Corsair Professional Series HX 750 (prior) / PC Power and Cooling Silencer Mk II 950W (current)
  • OS Drive: 128GB Crucial M4 SSD
  • RAID Drives: 16 x 2TB Hitachi 7200RPM (3Gbps/6Gbps mixed w/14 drives in RAID6, 2 drives in RAID1)
  • OS: Win7 Ultimate (current) Server2008R2 (prior)


Drive Models for the Drives:

  • HDS5C302 Deskstar 6gbps 32MB = x4
  • HDS72302 Deskstar 6gbps 64MB = x4
  • HDS72202 Deskstar 3gbps 32MB = x2
  • HUA72202 Ultrastar 3Gbps 64MB cache = x3


History and Troubleshooting:
  • RAM Tests come back clean
  • Drives unhooked from RAID and connected directly to motherboard and all SMART tests come back clean
  • Drives unhooked from RAID and surface scans performed with WD Digital Lifeguard, all come back clean
  • Cables swapped on RAID card with new cables
  • Motherboard replaced
  • Power Supply replaced
  • RAID card replaced with identical model
  • RAID card Firmware updated (both cards)
  • Fan attached to heatsink on RAID card for better temperature regulation
  • OS Changed from Server2008R2 to Win7 Ultimate
  • Power supply tested via a tester and multimeter. All rails holding steady voltage, even under load drive load
  • Can replicate error/reset by using CrystalDiskMark3. Lockup/reset SEEMS to happen on the write cycle
  • Cannot replicate error/reset using HDTunePro or IOMeter, even allowing them to run 1 hour+
  • IOMeter does not cause the error even on write cycles (see the CrystalDiskMark3 entry above)
  • Have tried DirectIO and Cached IO on the RAID card
  • Have tried NQC on and off
  • Errors happen to both the RAID1 and RAID6 virtual drives, suggesting it's not limited to a single virtual drive or set of physical drives
  • RAID card consistency check comes back clean
  • RAID card Read Patrol comes back clean
  • Chkdsk on both virtual drives comes back clean
  • sfc /scannow comes back clean (See above: OS replaced)
  • Virus checks come back clean (See above: OS replaced)
  • No errors in RAID card log
  • RAID card log shows no correctable errors, or other errors or alarms
  • MegaCLI shows no errors or SMART errors
  • Motherboard switched from ACHI to IDE for the SATA ports for the SSD, no change
  • OS installed on a SATA drive instead of SSD to rule out a RAID/SSD conflict, no change

Full error text, including the details tab from the Windows Event Viewer:

Code:
Reset to device, \Device\RaidPort1, was issued.
- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="megasas" /> 
  <EventID Qualifiers="32772">129</EventID> 
  <Level>3</Level> 
  <Task>0</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2013-10-22T17:32:26.936828400Z" /> 
  <EventRecordID>21077</EventRecordID> 
  <Channel>System</Channel> 
  <Computer>SAN.xxxxxxxx.local</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data>\Device\RaidPort1</Data> 
  <Binary>0F001800010000000000000081000480040000000000000000000000000000000000000000000000000000000000000001000000810004800000000000000000</Binary>

Edited by vintagedon - 10/31/13 at 4:32pm