Overclock.net › Forums › Software, Programming and Coding › Networking & Security › [Problem] My Domain Name routes to my router settings page, not my linux website
New Posts  All Forums:Forum Nav:

[Problem] My Domain Name routes to my router settings page, not my linux website

post #1 of 5
Thread Starter 
I host a website/fileserver on my linux PC. It contains a few HTML webpages along with some personal files. I recently got a new router, a Buffalo AirStation Extreme AC1200. Problem is, my domain name's DNS settings point to my public IP address. This allowed my linux server to be access via the internet using my domain name (or if you knew it, the public IP address).

Now the public IP address links to my router's setup page. I do not want this. Is there a way I can change the settings on my AirStation to stop this from happening and force the IP address to go back to routing to the linux server/website rather than allowing anyone and their grandma to try and access my router's settings?

Troubleshooting tests I've run: Yes, I can access the site using the LAN-side IP address assigned to the Linux server/PC. It works fine. However, the front-facing public IP address simply links to the router's setup page which in my case is normally accessible via 198.168.1.1.
post #2 of 5
Website URLs default to port 80, so for instance, typing http://www.overclock.net is the shortcut for typing http://www.overclock.net:80. The key thing to note here is that your router's interface is also on port 80. You will have to either change it to a different port, or more likely, set up port forwarding so that all external references to port 80 are forwarded to your server. Specific configuration depends on your router so you should take a look at your manual (http://cdn.cloudfiles.mosso.com/c85091/WZR1750Manual_en.pdf) - the section under WebAccess might be of use if you have the external interface enabled. Otherwise you will have to forward the correct ports to the correct internal IP address.
post #3 of 5
You can see if you can turn off Remote Access through HTTP, and use an alternate port. Assuming Buffalo uses DD-WRT it could be pretty easy.
ESXi Home Box
(6 items)
 
The Workstation.
(16 items)
 
 
CPURAMHard DriveOS
Dual L5630 72GB DDR3 RECC 120GB VERTEX 4 + 6TB RAID5 ESXi 6.0 U2 
Other
Dell PowedgeR710  
CPUGraphicsRAMHard Drive
Intel Core i5 2.4GHZ Intel Iris Pro 16GB DDR3 256GB PCI-e x2 
OSKeyboardMouse
OSX 10.11 + Win 10 Apple Wireless Keyboard Apple Magic Trackpad 
  hide details  
Reply
ESXi Home Box
(6 items)
 
The Workstation.
(16 items)
 
 
CPURAMHard DriveOS
Dual L5630 72GB DDR3 RECC 120GB VERTEX 4 + 6TB RAID5 ESXi 6.0 U2 
Other
Dell PowedgeR710  
CPUGraphicsRAMHard Drive
Intel Core i5 2.4GHZ Intel Iris Pro 16GB DDR3 256GB PCI-e x2 
OSKeyboardMouse
OSX 10.11 + Win 10 Apple Wireless Keyboard Apple Magic Trackpad 
  hide details  
Reply
post #4 of 5
Thread Starter 
The model I use supports DD-WRT, but I have not installed it. Also, strangely enough, it turns out that when going to my domain or IP from a computer that is NOT on the same network as the router, it works fine. The only time it redirects me to the router's page is when I try to access the website via a computer on the local network. This is odd, but not nearly as bad as I thought. Though I would VERY much like to get rid of this redirect if possible. Anyone have an idea? I can still access the site from the local network, but only if I type the LAN IP address I've permanently assigned to the Linux PC. But I'd prefer to be able to use the domain name/public IP.

Ideas?


Also, +repped to the people who've already answered.
post #5 of 5
Thread Starter 
Another update: FileZilla won't work anymore unless I use the Linux PC's LAN-IP to connect to my server instead of the public domain address. Works normally on computers connected to other networks
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Networking & Security
Overclock.net › Forums › Software, Programming and Coding › Networking & Security › [Problem] My Domain Name routes to my router settings page, not my linux website