Overclock.net › Forums › Components › Power Supplies › what causes the 20pin psu connector to get burn marks??
New Posts  All Forums:Forum Nav:

what causes the 20pin psu connector to get burn marks??

post #1 of 26
Thread Starter 
About 2weeks ago my pc was getting unstable and wouldn't hold a overclock at all, And when in bios it would restart,

So when looking in bios i see the 3.3rail was ony reading 2.8v usely it was at 2.9 and 3.0 which i know are still to low but it was stable. So i figure i try another psu which is a hyper 4 580 out of my other pc, So when i was taking the 20pin off there was burns marks in 2 of the corner pins..

Than when i was taking the 8 pin off the board the connected was discolored on one side.. So yea after i pop the 580 watt in the system everything was 100% stable,

So i contacted power and cooling to get a rma on my power and cooling 750watt which was about 4 years old but it had a 5year warranty:)

Got it back today and they said they replaced the 20pin connector and cleaned the dust and glue up. even tho i already blew the dust out before i sent it but i guess i didn't get everything.

I pop it in my pc and everything is rock stable again and the 12v is reading 12.1 which before it was 12 and going down to 11.80, And the 3.3v rail reads 3.360v which before it was 2.8.


But now what would cause the 20pin connector getting burnt?


heres the pics.




**
gigaryzen
(10 items)
 
saberex
(10 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 1700 @ 3.9 AX370-Gaming K7 Nvidia 1080 founders corsair lpx 3200@3200 
RAMHard DriveCoolingOS
corsair lpx 3200@3200 ssd 120gb H100 windows 10 
PowerCase
tagan 900watts thermaltake core x9 
CPUMotherboardGraphicsRAM
amd fx 8370e 5ghz SABERTOOTH 990FX R2.0 msi 390 gskill sniper 8gb 1866 
RAMHard DriveCoolingOS
gskill sniper 8gb 1866 ssd 120gb xspc rasa 750 with tons of fans!! windows 8.1 
PowerCase
power and cooling 750watt thermaltake core x9 
  hide details  
Reply
gigaryzen
(10 items)
 
saberex
(10 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 1700 @ 3.9 AX370-Gaming K7 Nvidia 1080 founders corsair lpx 3200@3200 
RAMHard DriveCoolingOS
corsair lpx 3200@3200 ssd 120gb H100 windows 10 
PowerCase
tagan 900watts thermaltake core x9 
CPUMotherboardGraphicsRAM
amd fx 8370e 5ghz SABERTOOTH 990FX R2.0 msi 390 gskill sniper 8gb 1866 
RAMHard DriveCoolingOS
gskill sniper 8gb 1866 ssd 120gb xspc rasa 750 with tons of fans!! windows 8.1 
PowerCase
power and cooling 750watt thermaltake core x9 
  hide details  
Reply
post #2 of 26
is it on the inside or outiside ? only thing that i see that could burn it like that is some electrical arc , but i don't see how this would be happening inside a connector, even more on the male side . did the female connector had burn mark too ? if the female side were to be too wide and a gap would be present between the male and female pin then some arc could happen.
HAF X - main rig
(24 items)
 
HAF XB
(14 items)
 
 
CPUMotherboardGraphicsRAM
E8500 ASUS P5E3 ASUS dcuii TOP GTX 670 OCZ reaper x hpc  
Hard DriveOptical DriveCoolingOS
samsung 500 gb samsung dvd antec H2O 920 windows vista 64b 
MonitorKeyboardPowerCase
LG 23 passive 3d logitech g15 CORSAIR GS800 haf xb 
MouseAudio
logitech g500 logitech Z 2300 
  hide details  
Reply
HAF X - main rig
(24 items)
 
HAF XB
(14 items)
 
 
CPUMotherboardGraphicsRAM
E8500 ASUS P5E3 ASUS dcuii TOP GTX 670 OCZ reaper x hpc  
Hard DriveOptical DriveCoolingOS
samsung 500 gb samsung dvd antec H2O 920 windows vista 64b 
MonitorKeyboardPowerCase
LG 23 passive 3d logitech g15 CORSAIR GS800 haf xb 
MouseAudio
logitech g500 logitech Z 2300 
  hide details  
Reply
post #3 of 26
Thread Starter 
Nope the female side motherboard connector don't seem to have any burn marks, Maybe some slight discolor. It was more burnt inside than outside. the Outside was burnt from the inside burning.

The weird thing is the 8pin 12v connector is little discolored, They didn't replace that.
gigaryzen
(10 items)
 
saberex
(10 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 1700 @ 3.9 AX370-Gaming K7 Nvidia 1080 founders corsair lpx 3200@3200 
RAMHard DriveCoolingOS
corsair lpx 3200@3200 ssd 120gb H100 windows 10 
PowerCase
tagan 900watts thermaltake core x9 
CPUMotherboardGraphicsRAM
amd fx 8370e 5ghz SABERTOOTH 990FX R2.0 msi 390 gskill sniper 8gb 1866 
RAMHard DriveCoolingOS
gskill sniper 8gb 1866 ssd 120gb xspc rasa 750 with tons of fans!! windows 8.1 
PowerCase
power and cooling 750watt thermaltake core x9 
  hide details  
Reply
gigaryzen
(10 items)
 
saberex
(10 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 1700 @ 3.9 AX370-Gaming K7 Nvidia 1080 founders corsair lpx 3200@3200 
RAMHard DriveCoolingOS
corsair lpx 3200@3200 ssd 120gb H100 windows 10 
PowerCase
tagan 900watts thermaltake core x9 
CPUMotherboardGraphicsRAM
amd fx 8370e 5ghz SABERTOOTH 990FX R2.0 msi 390 gskill sniper 8gb 1866 
RAMHard DriveCoolingOS
gskill sniper 8gb 1866 ssd 120gb xspc rasa 750 with tons of fans!! windows 8.1 
PowerCase
power and cooling 750watt thermaltake core x9 
  hide details  
Reply
post #4 of 26
if it s inside then it s some sort of arc or short circuit. since there is 2 of them burned i would vote for a short circuit or overload, because bad pins that cause arcing on 2 pins of the same connector is just too unlikely.

but for that to happen it would need either a huge problem during manufacturing (on the pcb/component if it s a short, on the connector if it s an arc) , another possibility is that you moved it while powered or worst you unplugged it while powered.

Are you 100% sur your psu is more then enough for your power usage ?

what price is that psu ? i don't know this manufacturer , but for me it s more then likely that the psu was faulty , which is rare in all but the cheapest psu.
HAF X - main rig
(24 items)
 
HAF XB
(14 items)
 
 
CPUMotherboardGraphicsRAM
E8500 ASUS P5E3 ASUS dcuii TOP GTX 670 OCZ reaper x hpc  
Hard DriveOptical DriveCoolingOS
samsung 500 gb samsung dvd antec H2O 920 windows vista 64b 
MonitorKeyboardPowerCase
LG 23 passive 3d logitech g15 CORSAIR GS800 haf xb 
MouseAudio
logitech g500 logitech Z 2300 
  hide details  
Reply
HAF X - main rig
(24 items)
 
HAF XB
(14 items)
 
 
CPUMotherboardGraphicsRAM
E8500 ASUS P5E3 ASUS dcuii TOP GTX 670 OCZ reaper x hpc  
Hard DriveOptical DriveCoolingOS
samsung 500 gb samsung dvd antec H2O 920 windows vista 64b 
MonitorKeyboardPowerCase
LG 23 passive 3d logitech g15 CORSAIR GS800 haf xb 
MouseAudio
logitech g500 logitech Z 2300 
  hide details  
Reply
post #5 of 26
Thread Starter 
Yep im sure its enough for my system, Well i would think so. At the moment im ony running 1 card instead of crossfire. i haven't used 2 cards in like 7 months.

And my hyper r580 watt powered this system for like 2 weeks 24.7 with out any problems.

But yea power and cooling is very known brand This is my psu http://www.newegg.com/Product/Product.aspx?Item=N82E16817703009 at the time on black Friday i got it for 120$ was a 200$ psu when it came out. which is like 4 years ago.

yea i haven't moved it when it was on or pull it out with it on, Tho it is possible that one of my cats might of bump it or something but not sure.
gigaryzen
(10 items)
 
saberex
(10 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 1700 @ 3.9 AX370-Gaming K7 Nvidia 1080 founders corsair lpx 3200@3200 
RAMHard DriveCoolingOS
corsair lpx 3200@3200 ssd 120gb H100 windows 10 
PowerCase
tagan 900watts thermaltake core x9 
CPUMotherboardGraphicsRAM
amd fx 8370e 5ghz SABERTOOTH 990FX R2.0 msi 390 gskill sniper 8gb 1866 
RAMHard DriveCoolingOS
gskill sniper 8gb 1866 ssd 120gb xspc rasa 750 with tons of fans!! windows 8.1 
PowerCase
power and cooling 750watt thermaltake core x9 
  hide details  
Reply
gigaryzen
(10 items)
 
saberex
(10 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 1700 @ 3.9 AX370-Gaming K7 Nvidia 1080 founders corsair lpx 3200@3200 
RAMHard DriveCoolingOS
corsair lpx 3200@3200 ssd 120gb H100 windows 10 
PowerCase
tagan 900watts thermaltake core x9 
CPUMotherboardGraphicsRAM
amd fx 8370e 5ghz SABERTOOTH 990FX R2.0 msi 390 gskill sniper 8gb 1866 
RAMHard DriveCoolingOS
gskill sniper 8gb 1866 ssd 120gb xspc rasa 750 with tons of fans!! windows 8.1 
PowerCase
power and cooling 750watt thermaltake core x9 
  hide details  
Reply
post #6 of 26
Also 2.8v on the 3.3v rail is far below spec, and quite likely dangerous to use, even if the system seems stable. Stable and safe are not the same thing.

That burn is around the 3.3v wire, implying that too much current was being drawn through it, and/or the connection was poor.
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.3/3.6GHz core/uncore, 1.225/1.2v Gigabyte X99 SOC Champion (F22n) 2x Sapphire R9 290X Tri-X OC New Edition (10036... 4x4GiB Crucial @ 2667, 12-11-12-27-T1, 1.37v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.05) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Cooler Master Nepton 280L 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Reference R9 290X w/Stilt's MLU 1000e / 1375m E... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.3/3.6GHz core/uncore, 1.225/1.2v Gigabyte X99 SOC Champion (F22n) 2x Sapphire R9 290X Tri-X OC New Edition (10036... 4x4GiB Crucial @ 2667, 12-11-12-27-T1, 1.37v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.05) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Cooler Master Nepton 280L 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Reference R9 290X w/Stilt's MLU 1000e / 1375m E... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
post #7 of 26
Thread Starter 
Quote:
Originally Posted by Blameless View Post

Also 2.8v on the 3.3v rail is far below spec, and quite likely dangerous to use, even if the system seems stable. Stable and safe are not the same thing.

That burn is around the 3.3v wire, implying that too much current was being drawn through it, and/or the connection was poor.



Yep i know 2.8 is very low and thats what was causeing my problems before. But i said in my first post that i had it fixed and all is good now it reads 3.360v now. All they said they replaced the 20pin cable and cleaned up the dust and glue.

Yea hopefully it was a bad connection. If there was to much current being drawn what was doing that? Last i herd my system shouldn't touch anywhere near this psu. When this happened i ony had the 5870 in.
Edited by gordesky1 - 11/6/13 at 8:09am
gigaryzen
(10 items)
 
saberex
(10 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 1700 @ 3.9 AX370-Gaming K7 Nvidia 1080 founders corsair lpx 3200@3200 
RAMHard DriveCoolingOS
corsair lpx 3200@3200 ssd 120gb H100 windows 10 
PowerCase
tagan 900watts thermaltake core x9 
CPUMotherboardGraphicsRAM
amd fx 8370e 5ghz SABERTOOTH 990FX R2.0 msi 390 gskill sniper 8gb 1866 
RAMHard DriveCoolingOS
gskill sniper 8gb 1866 ssd 120gb xspc rasa 750 with tons of fans!! windows 8.1 
PowerCase
power and cooling 750watt thermaltake core x9 
  hide details  
Reply
gigaryzen
(10 items)
 
saberex
(10 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 1700 @ 3.9 AX370-Gaming K7 Nvidia 1080 founders corsair lpx 3200@3200 
RAMHard DriveCoolingOS
corsair lpx 3200@3200 ssd 120gb H100 windows 10 
PowerCase
tagan 900watts thermaltake core x9 
CPUMotherboardGraphicsRAM
amd fx 8370e 5ghz SABERTOOTH 990FX R2.0 msi 390 gskill sniper 8gb 1866 
RAMHard DriveCoolingOS
gskill sniper 8gb 1866 ssd 120gb xspc rasa 750 with tons of fans!! windows 8.1 
PowerCase
power and cooling 750watt thermaltake core x9 
  hide details  
Reply
post #8 of 26
The only things that touch the 3.3v rail in most modern systems are chipset and memory, none of which should be pulling the sort of current to cause what you saw.
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.3/3.6GHz core/uncore, 1.225/1.2v Gigabyte X99 SOC Champion (F22n) 2x Sapphire R9 290X Tri-X OC New Edition (10036... 4x4GiB Crucial @ 2667, 12-11-12-27-T1, 1.37v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.05) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Cooler Master Nepton 280L 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Reference R9 290X w/Stilt's MLU 1000e / 1375m E... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
Primary
(15 items)
 
Secondary
(13 items)
 
In progress
(10 items)
 
CPUMotherboardGraphicsRAM
5820K @ 4.3/3.6GHz core/uncore, 1.225/1.2v Gigabyte X99 SOC Champion (F22n) 2x Sapphire R9 290X Tri-X OC New Edition (10036... 4x4GiB Crucial @ 2667, 12-11-12-27-T1, 1.37v 
Hard DriveHard DriveHard DriveCooling
Plextor M6e 128GB (fw 1.05) M.2 (PCI-E 2.0 2x) 2x Crucial M4 256GB 4x WD Scorpio Black 500GB Cooler Master Nepton 280L 
OSMonitorKeyboardPower
Windows 7 Professional x64 SP1 BenQ BL3200PT Filco Majestouch Tenkeyless (MX Brown) Corsair RM1000x 
CaseMouseAudio
Fractal Design Define R4 Logitech G402 Realtek ALC1150 + M-Audio AV40 
CPUMotherboardGraphicsRAM
X5670 @ 4.4/3.2GHz core/uncore, 1.36 vcore, 1.2... Gigabyte X58A-UD5 r2.0 w/FF3mod10 BIOS Reference R9 290X w/Stilt's MLU 1000e / 1375m E... 2x Samsung MV-3V4G3D/US @ 2000, 10-11-11-30-T1,... 
RAMHard DriveHard DriveHard Drive
1x Crucial BLT4G3D1608ET3LX0 @ 2000, 10-11-11-3... OCZ (Toshiba) Trion 150 120GB Hyundai Sapphire 120GB 3x Hitachi Deskstar 7k1000.C 1TB 
CoolingOSPowerCase
Noctua NH-D14 Windows 7 Pro x64 SP1 Antec TP-750 Fractal Design R5 
Audio
ASUS Xonar DS 
CPUMotherboardGraphicsRAM
i7-6800K @ 4.3/3.5GHz core/uncore, 1.36/1.2v ASRock X99 OC Formula (P3.10) GTX 780 (temporary) 4x4GiB Crucial DDR4-2400 @ 11-13-12-28-T2, 1.33v 
Hard DriveHard DriveCoolingOS
Intel 600p 256GB NVMe 2x HGST Travelstar 7k1000 1TB Corsair H55 (temporary) Windows Server 2016 Datacenter 
PowerCase
Seasonic SS-860XP2 Corsair Carbide Air 540 
  hide details  
Reply
post #9 of 26
Thread Starter 
welp something went really wrong about a hour ago....

I was watching twitch tv and i was falling asleep.. Than i herd my pc turning off so i figure maybe it was windows..

Than i started to smell a electronic smell.. So i pulled the plug fast. It was really bad smell on top part of the board, So i plugged it in again and when i push the power it just turns on a split second and that's it... So i went to try my other psu in it,

And when im disconnecting the atx 12v connector it was really really hot But not burnt . So i tried my other psu and it does the same thing turns on 1 sec and goes off.. I even tried with out the gpu and ram and still does the same thing, So i tried the atx 12v out and the lights and fans turns on but that's it. So every time the atx 12v is plugged in it will turn turn on.

So it looked like the psu damage the board... Now what can i do about this? Will power and cooling cover this? The psu had to do this because 20hours later when first installed it my pc is dead now. and the atx 12v was discolored and they didn't replace that.

I also have another problem i have alot of files on my raid drives and pretty much i probably will need the same board to get the files right? ...


I sent power and cooling a message about it few mins ago to see what they have to say about it.


This really sucks because at the moment i cant afford anything cause i recent lost my job...
gigaryzen
(10 items)
 
saberex
(10 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 1700 @ 3.9 AX370-Gaming K7 Nvidia 1080 founders corsair lpx 3200@3200 
RAMHard DriveCoolingOS
corsair lpx 3200@3200 ssd 120gb H100 windows 10 
PowerCase
tagan 900watts thermaltake core x9 
CPUMotherboardGraphicsRAM
amd fx 8370e 5ghz SABERTOOTH 990FX R2.0 msi 390 gskill sniper 8gb 1866 
RAMHard DriveCoolingOS
gskill sniper 8gb 1866 ssd 120gb xspc rasa 750 with tons of fans!! windows 8.1 
PowerCase
power and cooling 750watt thermaltake core x9 
  hide details  
Reply
gigaryzen
(10 items)
 
saberex
(10 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 1700 @ 3.9 AX370-Gaming K7 Nvidia 1080 founders corsair lpx 3200@3200 
RAMHard DriveCoolingOS
corsair lpx 3200@3200 ssd 120gb H100 windows 10 
PowerCase
tagan 900watts thermaltake core x9 
CPUMotherboardGraphicsRAM
amd fx 8370e 5ghz SABERTOOTH 990FX R2.0 msi 390 gskill sniper 8gb 1866 
RAMHard DriveCoolingOS
gskill sniper 8gb 1866 ssd 120gb xspc rasa 750 with tons of fans!! windows 8.1 
PowerCase
power and cooling 750watt thermaltake core x9 
  hide details  
Reply
post #10 of 26
Thread Starter 
update i got the board out of the case, and inspected it, And the smell is coming from the mofets under the heat sink and it looks like the caps under there all are slanted sideways.. will a psu cause that kind of damage?

And the back of the board has a discolored blackish to it...
Edited by gordesky1 - 11/7/13 at 12:08am
gigaryzen
(10 items)
 
saberex
(10 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 1700 @ 3.9 AX370-Gaming K7 Nvidia 1080 founders corsair lpx 3200@3200 
RAMHard DriveCoolingOS
corsair lpx 3200@3200 ssd 120gb H100 windows 10 
PowerCase
tagan 900watts thermaltake core x9 
CPUMotherboardGraphicsRAM
amd fx 8370e 5ghz SABERTOOTH 990FX R2.0 msi 390 gskill sniper 8gb 1866 
RAMHard DriveCoolingOS
gskill sniper 8gb 1866 ssd 120gb xspc rasa 750 with tons of fans!! windows 8.1 
PowerCase
power and cooling 750watt thermaltake core x9 
  hide details  
Reply
gigaryzen
(10 items)
 
saberex
(10 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 1700 @ 3.9 AX370-Gaming K7 Nvidia 1080 founders corsair lpx 3200@3200 
RAMHard DriveCoolingOS
corsair lpx 3200@3200 ssd 120gb H100 windows 10 
PowerCase
tagan 900watts thermaltake core x9 
CPUMotherboardGraphicsRAM
amd fx 8370e 5ghz SABERTOOTH 990FX R2.0 msi 390 gskill sniper 8gb 1866 
RAMHard DriveCoolingOS
gskill sniper 8gb 1866 ssd 120gb xspc rasa 750 with tons of fans!! windows 8.1 
PowerCase
power and cooling 750watt thermaltake core x9 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › what causes the 20pin psu connector to get burn marks??