Overclock.net › Forums › Graphics Cards › AMD/ATI › Weird 280x issue o.O
New Posts  All Forums:Forum Nav:

Weird 280x issue o.O

post #1 of 5
Thread Starter 
My Saphire Vapour-X 280x is behaving like a 7970? headscratch.gif Anyone got a clue why it's doing this?
GPU Z Valadation
post #2 of 5
Seems like a bios issue. A 280x is just a rebadge 7970 anyways.
post #3 of 5
Try updating your version of GPU-Z to the latest and check again smile.gif.
Tick Tac Tock!
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD | Intel Asrock | Asus AMD 32GB Vengeance Pro DDR3-2666 
Hard DriveOptical DriveCoolingOS
IntelSSD Pioneer | Samsung NiCu Heatkiller 3.0 | 655 | MicroRes | GTX360 Win7 x64 
MonitorKeyboardPowerCase
1920x1200 Logitech Corsair-Enermax Open air MoBoX | MSI Bench 3G 
  hide details  
Reply
Tick Tac Tock!
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD | Intel Asrock | Asus AMD 32GB Vengeance Pro DDR3-2666 
Hard DriveOptical DriveCoolingOS
IntelSSD Pioneer | Samsung NiCu Heatkiller 3.0 | 655 | MicroRes | GTX360 Win7 x64 
MonitorKeyboardPowerCase
1920x1200 Logitech Corsair-Enermax Open air MoBoX | MSI Bench 3G 
  hide details  
Reply
post #4 of 5
Mine is the same, 3DMark also recognises it as a 7970.
New Build
(10 items)
 
  
CPUMotherboardGraphicsGraphics
Intel i7-4930k @ 4.5ghz, 1.215v Asus Rampage IV Formula Gigabyte 780 TI OC @ 1295/7400 Gigabyte 780 TI OC @ 1295/7400 
RAMHard DriveOSMonitor
Corsair Dominator Platinum @ 2133 9-10-10-24, 2T 2x Corsair GS 120gb SSD Windows 8 QNIX QX2710 Evolution ll @ 120hz 
PowerCase
Seasonic 1250W Corsair Vengeance C70 
  hide details  
Reply
New Build
(10 items)
 
  
CPUMotherboardGraphicsGraphics
Intel i7-4930k @ 4.5ghz, 1.215v Asus Rampage IV Formula Gigabyte 780 TI OC @ 1295/7400 Gigabyte 780 TI OC @ 1295/7400 
RAMHard DriveOSMonitor
Corsair Dominator Platinum @ 2133 9-10-10-24, 2T 2x Corsair GS 120gb SSD Windows 8 QNIX QX2710 Evolution ll @ 120hz 
PowerCase
Seasonic 1250W Corsair Vengeance C70 
  hide details  
Reply
post #5 of 5
Thread Starter 
I re installed my drivers now it works like a 200 series now and also dropped 10c wheee.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Weird 280x issue o.O