post #1 of 1
Thread Starter 
Okay hello everyone i will try to explain this in full detail, but i am stressing out a little bit right now because of this problem.
Okay i have had the asrock z68 extreme 3 gen 3 for a while now, just recently have i ran into a problem i updated the bios too the latest version 2.30 from one of the first versions 1.30 or something like that.
Now the flash went okay and everything and my system seems to be working but i am having one huge problem
Whatever is plugged into PCI slots on my motherboard are not being detected by windows i don't think my motherboard is detecting them either.
I have too unplug my video card from PCIE too get into the bios to change it so onboard is the main video priority and not my graphics card.
I can also strongly say my GPU is not faulty as i was just using it yesterday, but my windows got corrupted and i had to reformat today.
I installed every driver on there website and my GPU is still not detecting or my m-audio delta 44 soundcard that i also have plugged into PCI
i had my system running somehow that my GPU was still detecting but since i reformatted its not.

So.. i don't think i need to buy any new hardware as i know things still work i just cant figure out whats not causing my PCI slots to work.
As i said i was just using everything yesterday perfectly fine, i was still having a problem with my mobo not reading my soundcard but somehow got it to read my GPU.
Can somebody help me please? i also have the latest nvidia drivers installed.