Overclock.net › Forums › Consumer Electronics › Photography › Canon 70D quit recording video and says lens not attached!
New Posts  All Forums:Forum Nav:

Canon 70D quit recording video and says lens not attached!

post #1 of 4
Thread Starter 
The other night i was using my Canon 70D with a Tamron 17-50 F/2.8 to record a low lit barn party/dance.

Settings: it was fairly dark, so i was at 17mm, F/2.8, 1/30, Iso 3200. I used 30fps instead of 24 as i wanted to use 1/30's instead of 1/50's due to how dark it was.

Problem:
The camera would quit recording after a few seconds (normally 5-10 seconds) sometimes it would quit after 2 min, sometimes never.

The camera would give me a pop up saying that there was not a lens attached.

I tried losening the lens and wiggling it a little to no avail.

The barn was so dusty and narrow that i needed a wide angle and i didn't want to switch lenses to my nifty fifty as i could see dust in the air.

I have tried video since, but i can't get the same problem to occur. (though i have not tried in the pitch dark, just lower light)

Was the issue simple an AF issue and it was searching too much?
Any help or advice?
post #2 of 4
hi there. I also had the Canon 70D and the Tamron lens and sadly for video they won't play nice together! It's ok for photos.. but for video The Tamron needs a firmware update and when I contacted the local Tamron distributor/rep here In Toronto Canada, they told me they were aware of the problem and that they "would let me know" when a solution was found...aha..haven't heard back from them in over 2 months...
too bad...will stay away from Tamron! But I will continue to use it with my T3i

so for the Canon 70D I ended up getting the new Sigma f1.8 which is a bit short in Zoom range and no IS but really nice otherwise as I always use a monopod or tripod..
contact your local Tamron rep and see what they say..pls share the info!
E
post #3 of 4
Thread Starter 
Thank you so much for the info. I don't know that i would have ever found out about this otherwise.
post #4 of 4
yep..the Tamron is a good lens otherwise..but I'm not even sure that firmware would help...not sure if other third party lens are affected...I do have a tokina 11-16mm and that one worked ok..
smile.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Photography
Overclock.net › Forums › Consumer Electronics › Photography › Canon 70D quit recording video and says lens not attached!