Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Troubleshooting Intel Rapid Storage Technology with Samsung 840 EVO ssd
New Posts  All Forums:Forum Nav:

Troubleshooting Intel Rapid Storage Technology with Samsung 840 EVO ssd

post #1 of 5
Thread Starter 
Hello!

Before I begin, let me say that I am new to Overclock.net, and maybe posting this to the incorrect section. This one seemed the closest/most relevant, but if it is incorrect a friendly pointer would be much appreciated.

I just got my Samsung Electronics 840 EVO-Series 120GB ssd about a week ago. My pre-ssd setup was a 2tb and a 3tb seagate barracuda drive. I originally had Windows 7 (64-bit) installed on the 2tb before migrating it to the 3tb. I just added the ssd and wanted to setup the Intel Rapid Storage Technology with the ssd, however, I originally installed windows in a mode that was not compatible with the ssd. I have a Asus z77 sabertooth motherboard, and ended up changing the BIOS and Windows 7 settings to AHCI mode, which is what I am currently in. However, the "Samsung Magician" software says that AHCI mode is not enabled - despite windows saying that it IS in AHCI mode. Intel RST also does not pick up the ssd at all, and will not allow me to accelerate it using the caching mode (I tried troubleshooting this further but the only solution is to delete the current volume, which I have done). Does anyone have any experience in this matter or should I be going about this in an entirely different way? I am new to ssds as well and I am just trying to maximize performance from it.

Also, on an unrelated note, what are the main advantages of RAID vs AHCI? It has important features for multiple drives? I followed a guide earlier that suggested putting the computer in RAID mode, but doing this only results in a lovely blue screen and the need for a install medium, probably because I would have needed to install windows initially in RAID mode. I'm attempting to avoid the hassle of re-imaging if at all possible, however, if it comes to that it is an option for me.

Important system specs:
Asus z77 Motherboard
Samsung 840 EVO 120gb ssd
Intel i5-3570k Quad Core LGA 1155
Windows 7 (64 bit) - Installed in IDE, now using AHCI (although the software isn't recognizing that fact, despite windows and the drivers saying otherwise)

Brief Summary:
Want to use Intel RST, but can't because the ssd isn't in "AHCI mode" despite having changed all the settings over from IDE.

Thanks for your help!
post #2 of 5
Quote:
... and ended up changing the BIOS and Windows 7 settings to AHCI mode, which is what I am currently in. However, the "Samsung Magician" software says that AHCI mode is not enabled
Could you explain how you changed the settings in Windows?
ASRock E3G3
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K ASRock Extreme3 Gen3 ASUS Radeon R9 290X DirectCU II Corsair Vengeance 2x4gb 
Hard DriveHard DriveHard DriveHard Drive
Crucial M4 Western Digital Caviar Blue Western Digital Caviar Green Western Digital Caviar Blue 
Optical DriveCoolingOSMonitor
Samsung S222 CoolerMaster 212 EVO Windows 10 64bit Crossover 27q 
KeyboardPowerCaseMouse
Lenovo OEM Corsair TX650 Fractal Define R3 Medion Erazer 
Mouse PadOther
Trust High Precision Gelpad Logitech X-230 
  hide details  
Reply
ASRock E3G3
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K ASRock Extreme3 Gen3 ASUS Radeon R9 290X DirectCU II Corsair Vengeance 2x4gb 
Hard DriveHard DriveHard DriveHard Drive
Crucial M4 Western Digital Caviar Blue Western Digital Caviar Green Western Digital Caviar Blue 
Optical DriveCoolingOSMonitor
Samsung S222 CoolerMaster 212 EVO Windows 10 64bit Crossover 27q 
KeyboardPowerCaseMouse
Lenovo OEM Corsair TX650 Fractal Define R3 Medion Erazer 
Mouse PadOther
Trust High Precision Gelpad Logitech X-230 
  hide details  
Reply
post #3 of 5
post #4 of 5
Thread Starter 
You can use the MS Fix it tool or edit the registry yourself.

Link to tool here: (link)

Regedit:
Exit all Windows-based programs.
Press [Win] + R or take the RUN option from the start menu.
Now type Regedit there and press Enter Key to open up the Registry Editor Window. (If you receive the User Account Control dialog box, click Continue.)
Locate and then click the following registry sub key:
Code:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\msahci

In the right pane right-click Start in the Name column and then click Modify.
In the Value data box, type 0 [3 is default], and then click OK.
On the File menu, click Exit to close Registry Editor.
Restart your computer
Go to UEFI/BIOS and enable AHCI, Save & Reboot
Another restart will be required to finish the driver installation.

I followed the steps in the guide found on this website (being overclock.net)
post #5 of 5
Thread Starter 
Quote:

This was the guide I followed. I wouldn't have posted the question if I could easily google or search overclock.net for the solution. Thanks though.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: SSD
Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Troubleshooting Intel Rapid Storage Technology with Samsung 840 EVO ssd