Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › [Solved] Can't Remove Main (Admin) account from RDP connection allowed list. [Solved]
New Posts  All Forums:Forum Nav:

[Solved] Can't Remove Main (Admin) account from RDP connection allowed list. [Solved]

post #1 of 5
Thread Starter 
Hello all,
Some people may think this is a silly question, but its not.
I do not want to have the ability to login as my Administrative account via RDP, for a few reasons;
  1. You don't need a password to grant admin rights to programs (Except on first login, but one password to protect absolutely everything is outrageous)
  2. Access to all files and settings
  3. And many more reasons.
I value my security and will do anything to insure it.
Windows does not give an option to disallow Administrator login via RDP, it only says that the user already has access.
I know how to use regedit to an extent so if it is needed, i don't mind using it.

This is one of the many reasons why i am (mainly) a unix person, but windows (just about) does it's job for me.
OS is Windows 8 + Pro Pack (I am not going to upgrade/update to windows 8.1 for any reason at all)

I Really need to keep RDP enabled so if i have to go somewhere and require my computer, i can simply RDP into it at ease.

Thank you all who ever responds smile.gif

[Images are below this line. might be updated with new images i progress in solving the problem]


Progress/What i've tried

(After first trying from Cwix)
Edited by jakesta13 - 11/15/13 at 8:47am
post #2 of 5
Since you are using pro you should be able to set this up in the local policy editor.

There is a setting to Deny logon through remote desktop services. If you add your admin account to it, it should be blocked from connecting.

http://technet.microsoft.com/en-us/library/dn221959.aspx
That link is for a group policy, but it should be similar for local policies.

I do not have much experience on 8 so YMMV but feel free to let me know if you still need help.
Alienware
(5 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 3630QM M14xR2 NVIDIA GeForce GT 650M  DDR3 
Hard Drive
Samsung SSD PM830 
  hide details  
Reply
Alienware
(5 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 3630QM M14xR2 NVIDIA GeForce GT 650M  DDR3 
Hard Drive
Samsung SSD PM830 
  hide details  
Reply
post #3 of 5
Thread Starter 
Quote:
Originally Posted by Cwix View Post

Since you are using pro you should be able to set this up in the local policy editor.

There is a setting to Deny logon through remote desktop services. If you add your admin account to it, it should be blocked from connecting.

http://technet.microsoft.com/en-us/library/dn221959.aspx
That link is for a group policy, but it should be similar for local policies.

I do not have much experience on 8 so YMMV but feel free to let me know if you still need help.

I think i now have it going, i have to test it out soon.
Here's a image showing m progress

Solution Quoted
Quote:
Originally Posted by Cwix View Post

Since you are using pro you should be able to set this up in the local policy editor.

There is a setting to Deny logon through remote desktop services. If you add your admin account to it, it should be blocked from connecting.

http://technet.microsoft.com/en-us/library/dn221959.aspx
That link is for a group policy, but it should be similar for local policies.

I do not have much experience on 8 so YMMV but feel free to let me know if you still need help.

Edited by jakesta13 - 11/15/13 at 8:55am
post #4 of 5
Thread Starter 
Quote:
Originally Posted by Cwix View Post

Since you are using pro you should be able to set this up in the local policy editor.

There is a setting to Deny logon through remote desktop services. If you add your admin account to it, it should be blocked from connecting.

http://technet.microsoft.com/en-us/library/dn221959.aspx
That link is for a group policy, but it should be similar for local policies.

I do not have much experience on 8 so YMMV but feel free to let me know if you still need help.
Quote:
Originally Posted by jakesta13 View Post

I think i now have it going, i have to test it out soon.
Here's a image showing m progress

Yup! it worked! thank you so much for finding that, i couldn't find anything to help me...

Again, Thanks smile.gif
+1 rep
post #5 of 5
Glad I could help!
Alienware
(5 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 3630QM M14xR2 NVIDIA GeForce GT 650M  DDR3 
Hard Drive
Samsung SSD PM830 
  hide details  
Reply
Alienware
(5 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 3630QM M14xR2 NVIDIA GeForce GT 650M  DDR3 
Hard Drive
Samsung SSD PM830 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Windows
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › [Solved] Can't Remove Main (Admin) account from RDP connection allowed list. [Solved]